Showing results for 
Search instead for 
Did you mean: 

Transform the CUCM IP(source alias)

Level 1
Level 1

Hi everybody,

somebody tells me, since X7.2 the VCS is able to change the CUCM-IP from an incoming CUCM call.

Is this working? How? I'm not able to do this.

My problem is, endpoints who are located at the cucm and calls via VCSE, are not able to display the correct SIP-Domain.

The only show all the time the private CUCM IP as source.b How can i fix it.

Kind regards


1 Accepted Solution

Accepted Solutions

Hi Ahmad

with your example it didn't match on the first entry, I modified it a little, now it works:



xsi:schemaLocation="urn:ietf:params:xml:ns:cpl cpl.xsd">











Many thanks to everyone


View solution in original post

15 Replies 15

Alok Jaiswal
Cisco Employee
Cisco Employee

Hi Jens,

can you elaborate more on your setup??  are you looking to force the media through the VCS-E ???

From VCS x7.2 you can force the encryption on the zones/subzones and hence the VCS always stayed in call not only signaling but it also takes the media in this case.



I believe he want to change the source alias - e.g. right now when he makes a call from a CUCM registered endpoint it would have 12345@ as the source alias, he wants to transform this to

I also want to be able to do the same thing!

Yes, thats correct.

If my endpoint is calling somewhere in the internet, I can see 1234@ as source alias is coming from the SIP Trunk (CUCM <-> VCSC).

The call goes through the traversal Zone and the Expressway(public IP

On the called internet endpoint I can see that 1234@ is calling, but the displayed name should be

Is there any solution? A cisco guy has told me, that since X7.2 this is possible.

But all testing was not successful.


Level 1
Level 1


the transformation of the source alias can be done via a cpl script. Who looks like in this thread.

Because of this I have build the folowing script.








But the transform do not work, the debug looks like.

Detail="CPL: "

Detail="CPL:   "

Detail="CPL: trying to match 12345@ "


matched "

Detail="CPL:" diversion="" dest-url-for-message="" sip-route-set="" dest-service=""> added to location set "

Has anybody an idea where the problem is?

Hi Jens,

I'm facing the same problem - have you found a solution?



I have a different suggestion:

You could configure the Enterprise Parameter "Organization Top Level Domain" and set up the sip trunk to use fqdn names. So you will get the internal domain from cucm to show up on your endpoints.

Regards, Paul

Regarding the cpl: I did not test it, but maybe not all SIP Contact headers are updated with the CPL.

Regards, Paul


@peter: The configuration of the cpl i have shown is correct, but the VCS is actually not able to replace the source header.

only the destination header is supported. This feature should be available in one of the next releases.

@Paul: Yes this is one opinion to set the "Organization Top Level Domain", but in my customer enviroment is it not possible.

Level 4
Level 4


please try this instead (this is not really regex, it's just matching single address of 12345@







regards, Ahmad


can this be done via "VCS-Configuration --> Call Policy" or via "VCS-Configuration --> Dialplan --> Policy Service" ?

Actually I have only tried via the first way and it is not working.

At the second way I get all the time an "Loopback" error.

regards Jens