Showing results for 
Search instead for 
Did you mean: 

Unable to add Polycom HDX to TMS

Nick Boylan

We already have 1 Polycom unit added to TMS.

I have put exactly the same settings into a 2nd Polycom unit but TMS gives the following error

'Update failed on: Software version: hostAddress:, description:send command 'Volume get' failed, base exception:send failed for host, connection state: Disconnected, data sent:vol'

The endpoint is online and I can browse to it with no issues. The only difference with this endpoint and the endpoint already registered is the management server. But there is no option to add the management server on the endpoint.

On the Polycom GDS screen it shows as registered.

The system has been purged from TMS and re added but we get the same message.

The Polycom unit was on software version 3.0.5 and the other Polycom that is registered to TMS is on 3.0.1.

We downgraded the system to 3.0.1 and attempted to add to TMS again but TMS gave the same message.

We have gone through every option on the codec and ensured they are exactly the same as the codec that is registered.

Has anyone got any suggestions?

Thank you

6 Replies 6

Darren McKinnon

I am getting the same message from TMS (V13.2.1).  I was troubleshooting the communication between TMS and this endpoint because users are receiving a message during booking that there is no route possible to this endpoint.  I web browsed to the HDX and updated the SNMP community from public to what I wanted it to be, and then tried a force refresh from TMS.

This is from my log-web.txt:

14:59:02,705 [43] ERROR ASP.tandberg_tms_ui_systemnavigator_systemgeneralsettings_ascx -
Tandberg.TMS.Common.SystemExceptions.UpdateFieldException: Update Field failed on: SoftwareVersion ---> System.NullReferenceException: Object reference not

set to an instance of an object.
   at Tandberg.TMS.SystemAPI.PolycomVSX.SharedFunctions.GetConfigurationFromSystem()
   at Tandberg.TMS.SystemAPI.PolycomVSX.SharedFunctions.LoadSettingsFromSystem(Boolean forceRefresh)
   at Tandberg.TMS.SystemAPI.PolycomVSX.SharedFunctions.get_SoftwareVersion()
   at Tandberg.TMS.SystemAPI.SystemBase.get_SoftwareVersion()
   at Tandberg.TMS.SystemAPI.SystemBase.GetStringFieldValue(FieldTypes fieldType, Int32 index)
   at Tandberg.TMS.SystemAPI.PolycomVSX.SystemImp.GetStringFieldValue(FieldTypes fieldType, Int32 index)
   at Tandberg.TMS.TMSSystems.SystemToSystemAPIFunctions.RefreshTMSSystemFromSystem(TMSSystem myTMSSystem, Boolean clearCache)
   --- End of inner exception stack trace ---
   at Tandberg.TMS.TMSSystems.SystemToSystemAPIFunctions.RefreshTMSSystemFromSystem(TMSSystem myTMSSystem, Boolean clearCache)
   at Tandberg.TMS.TMSSystems.SystemService.InternalRefreshTMSSystemFromSystem(TMSSystem myTMSSystem, Boolean ignorePreregisteredSystems, Boolean clearCache)
   at Tandberg.TMS.Service.TMSSystemService.TMSSystemService.RefreshTMSSystemFromSystem(TMSSystem system, Boolean ignorePreregisteredSystems)
   at Tandberg.TMS.UI.Common.SystemNavigatorHelperFunctions.ForceRefresh(SystemId systemId, ModuleControl moduleControl, Boolean throwAllExceptions)
   at Tandberg.TMS.UI.SystemNavigator.SystemGeneralSettings.forceRefresh_Click(Object sender, EventArgs e)

I was able to get my issue resolved by changing the community back to public.  That wasn't it, though.  after changing it to public, the problem persisted.  Now, my HDX uses ISDN, and I have played with H.323 from it before.  TMS has the word "get" in the active gatekeeper box for the HDX, so I went back into the HDX, enabled H.323, inserted all the right info, and updated it.  Then I was able to fully re-establish communications with TMS. 

After re-establishing the communication with TMS, I disabled H.323 and the problem came back again!  I have re-enabled H.323 on the HDX, and got communications working again!

On the HDX, I then went into the Call Preference settings, and unchecked H.323 and updated it.  This caused TMS to give the error again. 

I don't know why this is happening.  I have another HDX managed by this TMS, and it is not having any issues.



Recently we had the same problem with message "Update failed on: Software version" with several HDX.

We solved this disabling "Admin Settings > General Settings > Security > Security Settings > Use Room Password for Remote Access" on HDX config and then re-enabling it. Then TMS could read all the info about the HDX.

We hope it'll be useful.

Kjetil Ree
Cisco Employee
Cisco Employee

Looks like defect CSCub82520.

Does it help if you disable the 'Enable Session List' setting on the endpoint?


We already had the 'Enable Session List' disabled.


I realise this is an old post but I recently had this issue on 4 systems and was able to resolve it by enabling TELNET.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers