Showing results for 
Search instead for 
Did you mean: 

VCS 7.2 Compatibility

John Faltys
Level 1
Level 1

Has anyone experienced one way video when in calls with PLCM Viewstations?

With 7.1, these old systems worked fine. 


MXP registered to VCS Express 7.2

Viewstation unregistered on public ip address

MXP Calls viewstation and call comes up, but no video/audio comes back to the MXP.

I thought that since the RTP ports changed in 7.2 it might be a firewall issue (ie. port negotiated above 52399), but the firewall is allowing up to 54999.


1 Accepted Solution

Accepted Solutions

Just for quick update, plan to support this again from X7.2.1. (tested in lab and result shows very promising).

Information is also available from

View solution in original post

33 Replies 33

Tomonori Taniguchi
Cisco Employee
Cisco Employee

Are you able to retrieve diagnostic log from VCS and verify the open logical channel negotiation and ACK on it?

Also check IP address and port that negotiate in it…

If you can provide me the log, I’m happy to check it.

BTW, RTP port range is configurable, so what happen if you modify RTP port back to X7.1 range (which should isolate port issue with firewall)?

Thanks for the reply.  In fact the 7.2 upgrade did not change the port range.  It is currently set to

MediaMedia port rangeH.32350000-51199UDP
MediaMedia port rangeSIP50000-51199UDP

I had assumed it did, since the release notes suggest so.

I plan on setting up a diagnostic session with the viewstation user in the next couple of days, so I will have diagnostic logs then.

Thank you

Here is the log from the VCS.  IP addresses changed.

Thank you

john.faltys.movi is the caller is the viewstation is the VCSE.

Also notice that there is no terminalcapack from viewstation...

It appears to me that x7.2 for the VCS has changed the H.245 messaging in some way as this problem did not seem to exist in the previous version.


The problem starts when we send the terminal capability set request to viewstation.

From the logs we don't see the ACK response coming from the viewstation and it fails to open the logical channel. However VCS OLC messages are going properly.

We are having a simillar case with the customer and currently diagnosing the issue. However it is interesting to note that its working in x7.1 in your case since in other case its not even working on x7.1 and endpoints are registered on vcs-control and no firewall involved.

have you tried not to do any interworking on vcs??Although i think it won't make too much difference.



Yes I saw that there was no term capability set ack back from the viewstation.

I was going to test without interworking, but the system I am testing with is offline.

Actually what should happen is they should replace the viewstation with something that is not 20 years old:-)

Tomonori Taniguchi
Cisco Employee
Cisco Employee

ViewStation is not responding ACK for H.245 Terminal CapSet from VCS.

Any log from VS contain error indication why VS it not responding Terminal CapSet from VCS?

Are you able to make non-interworking call with  ViewStation (H.323-H.323 call, i.e., ViewStation to ViewStation which  both registered on VCS).

VCS use received H.245 Terminal CapSet message for native call,  but will generate H.245 Terminal CapSet message for SIP interworking  call.

VCS generate CapSet message with H.245 CapSet for interworking call from SIP UA.

However this is same between X7.1 and X7.2.

I just did a non-interworking call and it behaves the same.

See the wireshark call flow.  The viewstation is on the left.

Do you see any additional information on H.245 endSession Command from ViewStation log?

Also any error message in log from ViewStation?

I do not have access to the viewstation. 

Humm ok, the log from VS will help to understand what VS don’t like…

As Alok is working on similar case as TAC case, hope he manage to get additional log to identify what is going on.

i am not the direct case owner of the case..however if i get any udpate i will post here.

however checking the release notes for x6.1 and x7.x i see polycom viewstation clearly mentioned in the release notes on x6.1 but its not there in x7 release notes.



I have some good news.  I was able to telnet into the viewstation and capture the trace from it as well as tcpdumps from the VCS.

I made a call from an MXP into the Viewstation which exhibited the 1 one way video problem as described above.

It happens to be running F9.0.2.  Telnet log and tcpdump captured.

Then I made a call from an MXP into the Viewstation which worked perfectly.  2 way video.  It is running F6.3. Telnet log and tcpdump captured.

I do not have time tonight to look at the traces, but I would like to provide you with them. I just don't want to make them public.  So if you can provide me a ftp or email, I will send them to you. So you can see what is going on differently between the working and non-working call.


An update after some more testing. 

It seems that the MXP F9.0.2 is overloading the Viewstation with capsets which cause the viewstation to no acknowledge the capset.  The call connects, but no incoming video back towards the MXP.  I was told by the customer this had been working fine for about 1 year prior to upgrade the VCS from 7.1 to 7.2.  And the call does work fine with an MXP version 6.x.

Tomonori thought we should test the call after turning off some of the capabilities.  After turning off and on different capabilities, I found that if the h.239 capability was turned off on the MXP, then the call worked fine.

So now the question is; What caused this change (VCS Version?).  And is there a better work around?