cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2288
Views
0
Helpful
18
Replies

VCS Expressway Starter- Movi user creation

jayrajag
Beginner
Beginner

Hi ,

I am trying to configure some login users for Movi accounts using our new VCS Expressway starter pack. Just to not ,we are not using the TMS.

When i tried to configure the user as per the document Cisco_VCS_Expressway_Starter_Pack_Deployment_Guide_X5-1.pdf. But unfortunatley i am not seeing the "New" button to click on, but rather a screen telling "“ Cannot read the user accounts database". Can someone help me in figuring it out what could be the issue. Thanks in Advance.

  cannot_create_usr.jpg

Thanks & Regards,

JK

18 Replies 18

Marwan ALshawi
Advisor
Advisor

can you go to maintenace and somewhere in the users or user accounts setting where you can specify the to use local database for users ! not sure but give it a go

good luck

Hi,

It was already set to the local database.still the issue remains...:-(

What happens if you go to VCS Configuration --> Authentication --> Devices --> Local Database and create a new local credential there first?

I did that too..but still the same error appears when i go to create the users.

"Cannot read the user accounts database"

Hi,

have you changed the LDAP Passwords from default before?

Maybe the VCS uses a wrong LDAP Password to access the VCS LDAP Database.

you can test this by login to root via ssh and try to change the password with the command

     tmsagent_ldap_passwd

If you get an error, try to reinstall the ldap with the command

     tmsagent_destroy_and_purge_data

Note: all ldap data will get lost. You can also try do this step in anyway.

After that, try to read the users again, before changing the ldap default password.

regards,

Tino

Hi,

Since i am using local database, i am not using the LDAP authentication.

Hi,

the local users are stored in a local ldap directory directly on your vcs expressway. If you read an create users, vcs will connect to it´s local ldap in the backround.

regards,

Tino

Hi,

I have upgraded the software from X6.0 to X7.0 which solved the current issue. But now when i tried creating the user , i get the below error

Error creating user: Unable to insert provisioned device address.

After this when i navigate to some other page and come again to the user account page,i can see that the user is listed. So when i tried using this in the movi clinet I get the below error

"Login failed – Wrong username, domain, and / or password. Check the spelling and CapsLock".

I saw in the deployment guide that it is due to the imporper SIP domain name etc, But I double checked it and  both are same (VCS and Movi). So can anyone point me what am i doing wrong?.

Thanks,

JK

Hi,

We've met a similar problem: Movi cannot connect to VCS Starter Pack because of invalid username/password/domain though the configuration seems right. Here are the details:

1. Starter Pack deployment began from locating VCS in internal network (not DMZ);

2. VCS was tuned according the deployment guide;

     2.1. NTP

     2.2. DNS

     2.3. Cluster name was set to local ip-address of the VCS;

     2.4. SIP domainname was set;

     2.5. User account was created (with FendMe name different);

3. Movi client was configured to use the ip-address of VCS as internal VCS address;

4. SIP domainname as configured in VCS.

After trying login with username/password configured the message is "Invalid username/password/domain".

I've double checked these fields in Movi and VCS but the error remains.

I attempted to change the type of cluster name - FQDN with SRV record (to check if depends), recreated user accounts, but nothing changed - still cannot logon in Movi.

Software version: X6.1.

Any ideas?

Thanks beforehand

P.S. Movi client was downloaded from cisco.com, because i could not understand if it supplied with Starter Pack. Would appreciate if smb explain me the thing.

You can check the VCs Configuration>Local Zone>Default Subzone > Authentication Policy ,Allow and Treat as authenticated

p.behera, thanks for answer!

Unfortunately this tune didn't help. It had been "Allow - Do not check credentials" pair of values before the change.

After some time I got an idea that when we create a user there are several types of credentials: the one to enter VCS from the web interface and the second one to connect to VCS from added devices (e.g. Movi). The problem might be there. Now trying to investigate

Hi,

did you manage to solve the login problem? We have this problem, too.

Upgrade from x6 to x 7 did not help.

Yea, our engineers did some magic and got login working fine.

We had x6.1 software and did no upgrade. It worth to be mentioned that following instructions in the VCS Starter Pack Deployment Guide is not enough (as it seems to me).

I think i could see the details of working configuration, if you let me know what is interesting for you.

/ru/catalog/categories/7/detail/22.html

Hi,

I managed to solve the auth. problem but now I have a new problem.

It just says Login failed due to registration failure.

It sign in, but can not register.

I made a new thread here were you can see the logs.

https://supportforums.cisco.com/message/3473596

I am actually not sure what all I need in order to be able to register the MOVI client and to call my workmates.

This is the first time that I use the VCS and I don't know what is mandatory for basic configuration.

Is an AD database really necessary or can I use the local database for auth, and registration?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: