Showing results for 
Search instead for 
Did you mean: 

VCS Starter pack 7.2 - Weird behavior with static routes

Cisco Employee
Cisco Employee

Hi team,

We wanted to share our experience in our first VCS Starter Pack deployment, where some routing problems arose.

The scenario is the following:

- LAN1 is directly connected to Internet, with a public IP configured. This is intended for external connections.

- LAN2 is  connected to LAN. This is intended for internal connections.

We configured the default gateway towards WAN (LAN1), and added a few static routes pointing to LAN2 so that the VCS could reach the corporate remote sites via VPN , next hop being a VPN router located in LAN2 network.

The routes were added via CLI using the command "xconf ip route ...", we verified they were inserted in the routing table correctly.

Jabber video and SX20 worked ok in LAN. We then tested with a Jabber Video client on a remote site, verified ping and DNS worked ok against the internal IP of the VCS, but the client didn´t register. The error was "Could not provision on time", but the VCS log did show the user as provisioned OK. Additional troubleshooting (sniffers)  showed that the VCS was not routing all the traffic correctly through LAN2 on VCS, the initial request was responded ok but the second packet was never going out through LAN2 interface. It was like the static route was not being used 100% of the time on VCS.

We then changed the gateway configured and pointed it to the VPN router, via LAN2. After a reboot, the remote site Jabber registered without a problem. We rolled back and placed the original WAN gateway again, leaving the static routes for the VPN sites. We rebooted again, and still the remote Jabber registered OK.

Customer is now concerned whether this internal routing problem may appear again after a reboot. We  can´t reproduce it in production, it would be great to know is anyone has experienced such routing issues, or perhaps a caveat is identified.

1 Reply 1

Level 7
Level 7


in general I would recommend using the 'xCommand RouteAdd' and 'xCommand RouteDelete' commands to add and remove static routes on the VCS, rather than inserting them in the configuration directly via the xConfiguration commands.

Apart from that, the best way to troubleshoot an issue like the one you describe would be to capture a diagnostics log (Network log level = DEBUG) and a tcpdump (with parameters '-i any -s0') on the VCS while reproducing the issue.

I'd recommend you capture these logs and raise a TAC case should the issue arise again.