cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1072
Views
10
Helpful
6
Replies

xCommand Provisioning Service Fetch

cwade23
Level 1
Level 1
Greetings
I am trying to create a template in TMS that allows me to push a custom command that fetches and installs a macro
 
Scripting using API: - xCommand Provisioning Service Fetch Mode:Add URL: 'https://<YourPath>/nameofroomdeviceprovisioningfile.zip'
 
What would be the correct format to do this? An example would be helpful.
 
I added my example but it was removed as an invalid HTML so I have added a screen shot of it instead
 
I am not sure if I have the correct syntax or not but I keep getting an error: (see attached screen shot)
 
Can someone provide guidance on this?
6 Replies 6

cwade23
Level 1
Level 1

Any help on this is appreciated

Looks like it is complaining about that there is no checksum. I’ll try to dig up some information about this when at work tomorrow.



Response Signature


This is what we have in CM for this.
image.png

Not sure what it would equate to in an xcommand.



Response Signature


I just checked in a RoomKit and this is what I get when doing xCommand Provisioning Service Fetch ?

xCommand Provisioning Service Fetch

Checksum: <S: 0, 128>
ChecksumType: <SHA512> (default SHA512)
Mode: <Add, Replace> (default Add)
Origin: <Other, Provisioning> (default Other)
URL(r): <S: 0, 2048>



Response Signature


Thanks

What I am trying to do is put it in xml format and add it as a custom command for a template in TMS

Below is what I have and I am not sure what the correct syntax is as I get a missing parameter error:

 

<Command><Provisioning><Service><Fetch><Checksum>"d122c2ae5039a28c6a0bb3bf4b9fe5e8af2fae4a651d396da8fe353acb2be6776cd188ff11ce724cc66f5547cffa39914ef427d9ae798dbd6a29fd8704c8bb85"<ChecksumType>SHA512<Mode>Add<Origin>Provisioning<URL>"https://blahblahblah/ProvisionableApplicationPackage-Report_Issue_IMv1.zip"</URL></Origin></Mode></ChecksumType></Checksum></Fetch></Service></Provisioning></Command>

 

When I SSH to the endpoint and put in the command it works perfectly

We had this setup in TMS back when we used it, but we don’t anymore, so I can’t unfortunately check on this in it. From what I recall we did not have it set as an xml string, but I’m not sure.



Response Signature