Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

C20 touch panel lost directories

I have several new codecs, C20 mostly, all with the InTouch controller.  When you go to the Directories tab on the InTouch, often times nothing appears.  Sometimes if you start to search for something it will find it but the list is blank if you don't search.  I keep seeing this issue on a lot of codecs at various sites around the world.  I have a single TMS install that supports all of these endpoints.  Has anyone ran into this before?



Magnus Ohm
Cisco Employee

Hi cody, are you sure the search gives you entries from TMS and not just 'history' or 'recents'? First you need to isolate where the problem is... Is it on the TMS side or the endpoint side? If you see this issue on all the endpoints and the phonebook uri is correct and the phonebooks are set on the systems and you know tms is accessible from the endpoint then its most likely the TMS. A wireshark trace on the tms server while searching the phonebook should give you some clues. There are plenty of threads in here discussing similar phonebook issues with troubleshooting descriptions.


Sent from Cisco Technical Support iPhone App

Hi Magnus, thanks for the response.

I am sure that when searching it is pulling TMS entries and not only recent calls.  I do not believe the problem to be on the TMS side as this does not happen on ever endpoint.  It seems to happen to some more than others but it's still random.  At the same time it works on one endpoint it will fail on another.  Rebooting the endpoint, upgrading the endpoint, unpair/repair of touch and factory rest of touch and endpoint do not resolve.  I have looked on here before for someone with similar issues but never found much.  I can't imagine that I am the only one out there!

A new problem has surfaced in the last week that may or may not be connected.  I have two C20s that by looking at the touch panel things look good.  The problem is that as the others, directories are empty but calling, camera control, and selfview do not work.  The touch is responsive, you can unpair/repair all day long, same result in the end.  A TAC case was open, it was suggested to factory reset the touch, did that and it didn't fix.  TAC RMAd the touch, however a few days later another touch across the world from the first one started doing the same thing.

Thanks, Cody

Hi Cody,

Basically if you're seeing this problem on multiple codecs, it seems to be coming from some configuration conflict. Magnus can guide you on the TMS configuration.

However, from the endpoint perspective, I would request you to check the credentials being used to pair the touch panel. Please make sure the account you use to pair the touch panel is an admin account. If you're using a normal user account, the directories might not show up.

Also one more thing you can check is to see if you're able to search the contacts via Web or list the corporate directory via the API. You can type the following command on the API:

xcommand Phonebook Search PhonebookId: 1 PhonebookType: Corporate

Please note that the PhonebookID might be different in your case.


Mubashshir Akhtar

Technical Lead
TelePresence Solution Group

Thanks Mubashshir Akhtar

I think this could be a DNS issue.  I'm able to replicate the situation this morning and do some testing.  I have two codecs, in the same VLAN - directoires fine on one and missing on the other.

xStatus Network on both codecs shows all the same DNS, GW and SM, the only difference is the IP.  When I run the Phonebook Search API command from the working codec I see a listing of my directories, when I run it from the codec with no directories I get this:

*r PhonebookSearchResult Reason: "TMSHttp failure: ''(Couldn't resolve host name)"

Both codecs also point to the same phonebook server (which is using hostname, not IP).  Is there a command I can run from the codec to do a NSLOOKUP on the my TMS server?

Magnus Ohm
Cisco Employee

Hi the phonebook lookup is just a http request and should be easily troubleshooted via a wireshark trace. Does the request even reach the tms or vice verca??

A common and easy mistake that we sometimes see is that the tms is pushing out the DNS name and the endpoint is not configured with a DNS server or the correct dns server as the request fail due to the dns name does not resolve.


Sent from Cisco Technical Support iPhone App

Content for Community-Ad

Spotlight Awards 2021