cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
2450
Views
0
Helpful
1
Replies
epicolo
Participant

C20 with Echo on HDMI1 output

Hi all,

we have two diferrent C20 and both are presenting tha same behaviour.

When we connect the HDMI1 out to a LCD screen, the other end receives echo. It look like the Echo canceller on MIC1 input can´t act when the audio is sent by HDMI1. The same thing happen with another LCD screen (different manufactor).

The strange behaviour is that if we connect an external amplifier on the RCA output and turn down the volume on the LCD (audio only by RCA), the echo disapear. It look like the Echo canceler can act only if the sound is sent over RCA connect and not by HDMI.

Does anyone had this behaviour? Is this a bug on this model?

PS: If we use a C40 or C60 on the same LCD screen, we don´t have Echo.

Thanks

1 REPLY 1
John Regan
Beginner

Hello,

Usually this is because the LCD screen will be processing the video image and thus delays the audio as well and this pushes the audio outside our echo cancellation threshold.  Having said that it is strange that the same screen works fine with C40+.

You can try and see if the screen has something like a game mode (name is different for each manufacturer), basically the image is displayed immediately with no processing in this mode so audio is not delayed.

You can also try increasing the following to see if this helps:

xConfiguration Experimental Audio EcReferenceDelay

default is 0 but it can be configured up to 300(ms).

If none of this helps I would recommend opening a support case so that this can be investigated further and a bug opened.

Content for Community-Ad

Spotlight Awards 2021