cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
7862
Views
0
Helpful
56
Replies
Luke Sykes
Beginner

C40 Layout and wallpaper issue

Hi All

I have a customer who has a C40, dual screen on the latest version of firmware (6.1.1). Outputs to the screens are on HDMI. They are used to it being full screen self view on both screens but now after upgrading the firmware its always the wallpaper. Every time they manually put it on full screen selfview, after the codec comes back out of standby the screens are on the wall paper again.

Is there a way of keeping both monitors on full screen self view all of the time when out of a call or not displaying local presentation.

Another problem they are having, when calling another site, they get self view on the right for a moment, the far end on the left and then the right hand screen goes black. They can however show presentations in a call which do come up on the right and a self view PIP on the left but when the presentation is cancelled, the screen goes black again and the PIP disapears. The customer is expecting full screen self view on the right when the presentation is not active.

(Monitor 1 is left and Monitor 2 is right)

Can you help?

Kind regards

Luke

56 REPLIES 56
Jens Didriksen
Engager

The settings may have changed during/after upgrade, so make sure

System Configuration-->Video-->Selfview is set to "On"

I take it they're going DVI from the codec, using a DVI/HDMI adapter to the second monitor, so make sure

Video--->Output-->DVI2-->MonitorRole is set to "Second" and not "PresentationOnly".

And, of course, the old re-boot wouldn't hurt.

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Hi Jens

Thank you for your reply

I have checked this with the customer. The customer has just informed me that the codec is not wired directly to the screen using the HDMI, there is an extron device in the mix also. All connections are HDMI though. I have requested a wiring diagram.

Many thanks

Luke

Yes, but the the C40 only has one HDMI out, which is normally used for display 1, and one DVI out, which is normally used for display 2.

We also use HDMI in to our displays, but we have to use a DVI/HDMI adaptor for that to work with display2, otherwise we would have to go DVI to VGA.

I would've thought the Extron device would be for input from the presentation devices to the codec, not from the codec to the displays - unless it's a HDMI matrix switcher, DA or something similar that is.

Regardless of what it is, they won't get away from having to convert DVI to HDMI as far as the output from the C40 goes.

We use Extron DVS605 between our presentation sources and the codec, but these go straight into the back of the codec, not into the displays.

Would be interesting to see what you discover when you get the diagram.

/jens

Please rate replies and mark question(s) as "answered" if applicable.

This discussion, https://supportforums.cisco.com/message/3873123, might be related to what you're wanting.

Oleksandr Yurchenko
Enthusiast

Luke Sykes написал(а):

Is there a way of keeping both monitors on full screen self view all of the time when out of a call or not displaying local presentation.

Hi Luke

TC5x software resolve your issue for both monitor )

You can also regularly to change the values for monitor (single or dual), but this action is not applicable for everyday work ...

Luke Sykes написал(а):

Another problem they are having, when calling another site, they get self view on the right for a moment, the far end on the left and then the right hand screen goes black. They can however show presentations in a call which do come up on the right and a self view PIP on the left but when the presentation is cancelled, the screen goes black again and the PIP disapears. The customer is expecting full screen self view on the right when the presentation is not active.

(Monitor 1 is left and Monitor 2 is right)

This issue partially resolved from advanced configuration menu:

Video> Selfview Default>OnMonitorRole> Second

Video> Selfview Default>FuulScreenMode> On

Partially, because after the presentation is ends then selfview picture is remains PIP  :-(

br Oleksandr

Luke Sykes
Beginner

Hi All

The codec is connected to an Extron DXP44 HDMI using HDMI on output 1 and DVI / HDMI adapter on port 2 as suggested.

From there it’s HDMI to the screens.

I have had a thought, the system is crestron controlled. Could it be possible that the Crestron panel may be defaulting the codec back to wall paper instead of full screen self view?

As far as the presentation goes, this goes into the Extron DXP44 and back out to an Altona De-embeder to separate the audio and the video and back into the codec.

Many thanks

Luke

It is certainly possible, we've had issues in the past with some of our AMX controlled rooms where, on system start-up, it would re-set a couple of codec settings, which was correct at the time the AMX code was written, but created problems later on.

We did find the "offending" lines of code, which was subsequently deleted, and the issue disappeared.

We've got a similar set-up to the one you describe in one of our rooms, not identical, but very similar, so I can take a look and see if I can reproduce your issue when back at work on Monday.

(We never use self-view, but a custom wallpaper with contact details for tech support etc, so I wouldn't have seen it.)

Having said all that, I would also consider what Oleksandr mentioned, particulary if this is a new issue.

Again, the issue discussed here https://supportforums.cisco.com/thread/2202094?tstart=0 which Oleksandr refers to, could be the culprit - it's not an issue for us as we never use selfview, and second monitor/projector in all of our rooms/auditoriums are configured as "PresentationOnly" - which all of users are very happy with.

We had complaints in the past that they could see themselves, which most find distracting when in a "talking heads only" kind of call, asking us to "get rid of it".

/jens     

Please rate replies and mark question(s) as "answered" if applicable.
Pratik Sachdeva
Cisco Employee

Hi Luke,

TC5.x code used to show selfview on both screens in fullscreen. This issue is seen in TC6.x as there has been a change in behavior/code. Cisco has opened Bug Id CSCue74341 for this and a solution/workaround is likely expected in TC6.2 release.

Regards,

Pratik Sachdeva

Luke Sykes
Beginner

Hi All

Thank you all for your updates. You are all very helpful.

Pratik, do you know when TC6.2 is likely to be released?

Kind regards

Luke

Hi Lukes,

TC6.2 is expected in June. Its beta version is being tested as if now.

Thanks,

Pratik Sachdeva

Pratik

Do you know if this fix will definately be in 6.2?

My customer is asking me this and i would like to give him a difinitive answer.  I suppose the r and d team would know...

Cheers

Luke

Tom Kalikajaros
Beginner

Hi Luke,

Behaviour certainly changed with TC6 and through our service provider a bug was logged - CSCue42649. Like your client the behaviour under TC5 was:-

  1. Self-view on LHS and RHS when not in call
  2. People on LHS when in call and self-view on RHS when in call (see below)

  3. People on LHS when in call and content on RHS when in call and sending content.

We played a bit with new settings in SelfViewDefault (TC6) to and emulate all of the above. All we could achieve was point 1. We could not achieve point 2 and 3.

Instead of 2. People on LHS when in call and self-view on RHS when in call we get A. People on LHS and a black on RHS (see below)

Instead of 3.People on LHS when in call and content on RHS when in call and sending content, we get People on LHS and content on RHS with an annoying PIP (see below). As you can see, it impacts content!

Whilst TC6 came with some new controls for PIP, it is limited to placement on the screen. It either starts and stays on one monitor or the other in the corner of your choice. It would be great if:-

  1. PIP can be turned off altogether when content is sent (default).
  2. A prefered monitor can be set for PIP is on for when content is sent.

We were told changes would come in TC6.1 but it has not surfaced. We have also tested TC6.1.1 and nothing has changed. Hoping 6.2 comes with the changes.

Hi Tom   

This is the exact issue my client has discribed to me. I'm sorry you are seeing the same issue, but I'm glad this is not an issolated case aswell.

Lets hope our frinds at cisco can solve the problem.

Thank you for your input

Kind regards

Luke

Hi Luke,

Certainly great knowing others have issue with the changes.

Hoping Cisco hurries up and provides the fix/change many clients are asking for. We will not moving to TC6 on any of our dual screen systems until it is resolved.

Cheers

Tom

Create
Recognize Your Peers
Content for Community-Ad