cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2247
Views
0
Helpful
4
Replies

Chromecast don't work sending HDMI through Spark Codecs

I tried now to plug in a Chromecast to the Cisco Room Kit and Room Kit Plus HDMI inputs, but there is no picture from the device althought it is recognized as a PC,MediaPlayer,Other & etc on the Touch panel. When I chose share, the video does not show up.

 

If I turn off the Chromecast and turn it on, then press share as soon as the Touch panel recognized the input, I can see the "G" splash screen. Can you tell from this log of video, what might be failing to allow the Chromecast video from being presented. The log starts from the moment I turn on the Chromecast.

 

For the test, I inserted Chromecast, Pressed share on touch panel, plugged in Chrome Cast, then waited for the Share button under the PC icon, the screen flips on the codec to show black, then I see google icon, then screen is light gray then black. No chrome cast works over the device. But if I put it in a monitor, i have proper chromecasting. 

 

2017-09-21T13:49:24.808-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: connector status for /dev/video1 0x00000001
2017-09-21T13:49:24.808-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: 0: connected (bm:0x00000001)
2017-09-21T13:49:24.811-04:00 MY-TP-CODEC I/video ( 1174): VIDSRCCTRL_FSM-0: connector event on 1 present
2017-09-21T13:49:24.811-04:00 MY-TP-CODEC I/video ( 1174): 2671844.01 VIDEOLC-0 I: VLC_readySignalSourceEvent port:HDMI 2: have signal
2017-09-21T13:49:24.811-04:00 MY-TP-CODEC I/video ( 1174): 2671844.01 CECCTRL I: Device /dev/cec1 present = 1
2017-09-21T13:49:24.918-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: format change event for '/dev/video1'
2017-09-21T13:49:24.921-04:00 MY-TP-CODEC I/video ( 1174): 2671844.12 HdmiStreams-1 I: new settings 0x0@0, fmt=875713089
2017-09-21T13:49:24.921-04:00 MY-TP-CODEC I/video ( 1174): 2671844.12 HdmiStreams-1 I: ignore same settings
2017-09-21T13:49:24.970-04:00 MY-TP-CODEC I/video ( 1174): 2671844.17 HdmiStreams-1 I: new settings 0x0@0, fmt=875713089
2017-09-21T13:49:24.970-04:00 MY-TP-CODEC I/video ( 1174): 2671844.17 HdmiStreams-1 I: ignore same settings
2017-09-21T13:49:24.971-04:00 MY-TP-CODEC I/video ( 1174): 2671844.17 VIDEOLC-0 I: Received SourceFormatEvent from video link 1 (0x0@0, unknown type, unknown format status) in ready state
2017-09-21T13:49:25.016-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: connector status for /dev/video1 0x00000000
2017-09-21T13:49:25.016-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: 0: not connected (bm:0x00000001)
2017-09-21T13:49:25.016-04:00 MY-TP-CODEC I/video ( 1174): VIDSRCCTRL_FSM-0: connector event on 1 away
2017-09-21T13:49:25.016-04:00 MY-TP-CODEC I/video ( 1174): 2671844.22 VIDEOLC-0 I: VLC_readySignalSourceEvent port:HDMI 2: no signal
2017-09-21T13:49:25.016-04:00 MY-TP-CODEC I/video ( 1174): 2671844.22 CECCTRL I: Device /dev/cec1 present = 0
2017-09-21T13:49:25.066-04:00 MY-TP-CODEC I/video ( 1174): 2671844.27 HdmiStreams-1 I: new settings 0x0@0, fmt=875713089
2017-09-21T13:49:25.066-04:00 MY-TP-CODEC I/video ( 1174): 2671844.27 HdmiStreams-1 I: ignore same settings
2017-09-21T13:49:25.067-04:00 MY-TP-CODEC I/video ( 1174): 2671844.27 VIDEOLC-0 I: Received SourceFormatEvent from video link 1 (0x0@0, unknown type, unknown format status) in ready state
2017-09-21T13:49:26.629-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: connector status for /dev/video1 0x00000001
2017-09-21T13:49:26.629-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: 0: connected (bm:0x00000001)
2017-09-21T13:49:26.630-04:00 MY-TP-CODEC I/video ( 1174): VIDSRCCTRL_FSM-0: connector event on 1 present
2017-09-21T13:49:26.630-04:00 MY-TP-CODEC I/video ( 1174): 2671845.83 VIDEOLC-0 I: VLC_readySignalSourceEvent port:HDMI 2: have signal
2017-09-21T13:49:26.630-04:00 MY-TP-CODEC I/video ( 1174): 2671845.83 CECCTRL I: Device /dev/cec1 present = 1
2017-09-21T13:49:30.848-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: TMDS clock presence event for '/dev/video1': 1
2017-09-21T13:49:30.849-04:00 MY-TP-CODEC I/video ( 1174): 2671850.05 VIDEOLC-0 I: Received SourceTmdsClockEvent from video link 1 (1) in ready state
2017-09-21T13:49:34.322-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: format change event for '/dev/video1'
2017-09-21T13:49:34.334-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: get input format 720x480@60Hz for '/dev/video1'
2017-09-21T13:49:34.334-04:00 MY-TP-CODEC I/video ( 1174): 2671853.54 HdmiStreams-1 I: new settings 0x0@0, fmt=875713089
2017-09-21T13:49:34.334-04:00 MY-TP-CODEC I/video ( 1174): 2671853.54 HdmiStreams-1 I: ignore same settings
2017-09-21T13:49:34.405-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: accept digital input timings 720 0 138 0, 480 0 45 0, prog 27027000Hz for '/dev/video1'
2017-09-21T13:49:34.405-04:00 MY-TP-CODEC I/video ( 1174): 2671853.61 HdmiStreams-1 I: new settings 720x480@60, fmt=875713089
2017-09-21T13:49:34.411-04:00 MY-TP-CODEC I/video ( 1174): 2671853.61 HdmiStreams-1 I: updateSource done
2017-09-21T13:49:34.412-04:00 MY-TP-CODEC I/video ( 1174): 2671853.61 VIDEOLC-0 I: Received SourceFormatEvent from video link 1 (720x480@60, digital, ok) in ready state
2017-09-21T13:49:35.123-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: format change event for '/dev/video1'
2017-09-21T13:49:35.136-04:00 MY-TP-CODEC I/video ( 1174): 2671854.34 HdmiStreams-1 I: new settings 0x0@60, fmt=875713089
2017-09-21T13:49:35.136-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: TMDS clock presence event for '/dev/video1': 0
2017-09-21T13:49:35.153-04:00 MY-TP-CODEC I/video ( 1174): 2671854.36 HdmiStreams-1 I: updateSource done
2017-09-21T13:49:35.153-04:00 MY-TP-CODEC I/video ( 1174): 2671854.36 HdmiStreams-1 I: new settings 0x0@60, fmt=875713089
2017-09-21T13:49:35.155-04:00 MY-TP-CODEC I/video ( 1174): 2671854.36 HdmiStreams-1 I: ignore same settings
2017-09-21T13:49:35.155-04:00 MY-TP-CODEC I/video ( 1174): 2671854.36 VIDEOLC-0 I: Received SourceTmdsClockEvent from video link 1 (0) in ready state
2017-09-21T13:49:35.204-04:00 MY-TP-CODEC I/video ( 1174): 2671854.41 HdmiStreams-1 I: new settings 0x0@0, fmt=875713089
2017-09-21T13:49:35.213-04:00 MY-TP-CODEC I/video ( 1174): 2671854.42 HdmiStreams-1 I: updateSource done
2017-09-21T13:49:35.214-04:00 MY-TP-CODEC I/video ( 1174): 2671854.42 VIDEOLC-0 I: Received SourceFormatEvent from video link 1 (0x0@0, unknown type, unknown format status) in ready state
2017-09-21T13:49:36.398-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: TMDS clock presence event for '/dev/video1': 1
2017-09-21T13:49:36.399-04:00 MY-TP-CODEC I/video ( 1174): 2671855.60 VIDEOLC-0 I: Received SourceTmdsClockEvent from video link 1 (1) in ready state
2017-09-21T13:49:39.873-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: format change event for '/dev/video1'
2017-09-21T13:49:39.885-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: get input format 1920x1080@60Hz for '/dev/video1'
2017-09-21T13:49:39.886-04:00 MY-TP-CODEC I/video ( 1174): 2671859.09 HdmiStreams-1 I: new settings 0x0@0, fmt=875713089
2017-09-21T13:49:39.886-04:00 MY-TP-CODEC I/video ( 1174): 2671859.09 HdmiStreams-1 I: ignore same settings
2017-09-21T13:49:39.955-04:00 MY-TP-CODEC I/video ( 1174): vidiotrace: device 1: vidIo: accept digital input timings 1920 0 280 0, 1080 0 45 0, prog 148500000Hz for '/dev/video1'
2017-09-21T13:49:39.958-04:00 MY-TP-CODEC I/video ( 1174): 2671859.16 HdmiStreams-1 I: new settings 1920x1080@60, fmt=875713089
2017-09-21T13:49:39.966-04:00 MY-TP-CODEC I/video ( 1174): 2671859.17 HdmiStreams-1 I: updateSource done
2017-09-21T13:49:39.966-04:00 MY-TP-CODEC I/video ( 1174): 2671859.17 VIDEOLC-0 I: Received SourceFormatEvent from video link 1 (1920x1080@60, digital, ok) in ready state
2017-09-21T13:49:41.437-04:00 MY-TP-CODEC I/video ( 1174): 2671860.64 ENC_FSM-0 I: start standard JPEG, width 1920, height: 1080, framerate 1000, bitrate 0, video mtu 1300, packetization mode -1, maxnalusize 0, maxtilerows -1, maxtilecolumns -1, minspatialsegidc -1, maxreferenceframes 0, dynamic mbps 1, static mbps 1, analyzerConfig 'slidechange=[id=15]', EncodeForUnknown
2017-09-21T13:49:41.437-04:00 MY-TP-CODEC I/video ( 1174): Enc-0: creating worker thread 0xf3dbe930
2017-09-21T13:49:41.439-04:00 MY-TP-CODEC I/video ( 1174): 2671860.64 ENC_FSM-0 I: created "ttvenc_jpeg_omx"
2017-09-21T13:49:41.440-04:00 MY-TP-CODEC I/video ( 1174): 2671860.64 HdmiStreams-1 I: Created stream 25 (10.00 frames per second)
2017-09-21T13:49:41.455-04:00 MY-TP-CODEC I/video ( 1174): 2671860.65 HdmiStreams-1 I: Use format 1920x1080@60, fmt=875713089
2017-09-21T13:49:41.455-04:00 MY-TP-CODEC I/video ( 1174): 2671860.65 HdmiStreams-1 I: Requested 12 buffers
2017-09-21T13:49:41.456-04:00 MY-TP-CODEC I/video ( 1174): 2671860.66 HdmiStreams-1 I: Stream on
2017-09-21T13:49:41.600-04:00 MY-TP-CODEC I/video ( 1174): 2671860.80 CECCTRL I: Not setting active source as we have no valid physical address
2017-09-21T13:49:41.679-04:00 MY-TP-CODEC I/video ( 1174): 2671860.88 HdmiStreams-1 I: Created stream 26 (60.00 frames per second)
2017-09-21T13:49:41.702-04:00 MY-TP-CODEC I/video ( 1174): layout_id: 44, swap interval: 1, frame period: 0ns, refresh: 16666667ns, display: 0

 

I just found that I can hear sound from the unit when I connect to chrome cast by the phone app, home -> youtube -> play ... Sound comes out but no images.

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
VIP Advisor

Re: Chromecast don't work sending HDMI through Spark Codecs

It's more along the lines of "I will not show your content as you've marked it as requiring protection, and I'm not authorised to broadcast copy protected content".

Note: the new RoomKit55's will actually display HDCP content locally, but none of the other endpoints will do so at this point in time.  None of them support tranmitting HDCP content in a call.

 

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

View solution in original post

Re: Chromecast don't work sending HDMI through Spark Codecs

In addition to what Wayne said, the Chromecast doesn't differentiate between copyright protected and non-copyright protected content, so incorrectly treats everything as if it was copyright protected.

 

Put a cheap HDMI splitter like this one: https://www.jaycar.com.au/2-way-hdmi-2-0-uhd-splitter/p/AC1766 in between and you should be OK, but be mindful of the laws in your country around HDCP.

 

View solution in original post

4 REPLIES 4
VIP Advisor

Re: Chromecast don't work sending HDMI through Spark Codecs

It's be because the chromecast is outputting content marked as HDCP, and the codec is correctly detecting this and then not transmitting the content.

If you want it to be able to transmit what you're showing, you'll need to insert something to bypass the HDCP.

Have a look at this web site: Why HDCP Causes Errors on Your HDTV, and How to Fix It

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Highlighted

Re: Chromecast don't work sending HDMI through Spark Codecs

thanks you for the advice. So I read the blog about HDCP and notice it wourking like this:

 

"The outputting device says “Hey display! Are you HDCP compliant? Here is my license, show me your license!” The display (or other HDCP compliant device) returns with “Why yes, I am legit! Here is my license!”"

 

So, I am guessing talk between Chromecast and Cisco Codec looks like:

 

"The Chromecast device says “Hey Codec! Are you HDCP compliant? Here is my license, show me your license!” The Codec (or other HDCP compliant device) returns with “No. I don't have a license!”"

 

 

Is that right? Then what happens to the video?

 

Does Chromecast don't send anymore video signal?

 

Or does Codec decides, "I will not show your content just incase it is copyrighted?"

VIP Advisor

Re: Chromecast don't work sending HDMI through Spark Codecs

It's more along the lines of "I will not show your content as you've marked it as requiring protection, and I'm not authorised to broadcast copy protected content".

Note: the new RoomKit55's will actually display HDCP content locally, but none of the other endpoints will do so at this point in time.  None of them support tranmitting HDCP content in a call.

 

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

View solution in original post

Re: Chromecast don't work sending HDMI through Spark Codecs

In addition to what Wayne said, the Chromecast doesn't differentiate between copyright protected and non-copyright protected content, so incorrectly treats everything as if it was copyright protected.

 

Put a cheap HDMI splitter like this one: https://www.jaycar.com.au/2-way-hdmi-2-0-uhd-splitter/p/AC1766 in between and you should be OK, but be mindful of the laws in your country around HDCP.

 

View solution in original post

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards