cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

2804
Views
5
Helpful
14
Replies
Beginner

Cisco C20 codec audio issue

Hi All,

recently we experienced a weird issue with one of our customer's C20 codecs.

Cu called us complaining about a branch office not being able to hear sound anymore; we went on place and discovered indeed no more audio was coming out of the C20 (they have an HDMI connection to a NEC TV with external speakers); not even buttons clicks, when enabled.

At the beginning we thought the culprit was either the TV or the external speakers but, when we lowered the TV resolution to match an external monitor, for test purposes, we realized the audio started to come out again !

In few words, this C20 started to behave like this: if you set full HD resolution you get no audio over the HDMI; if you lower it (whatever other resolution you want but full HD) you get audio as you would expect.

SW version is TC 5.1.0.280662

... as far as we know, C20 has not been upgraded just before this happened but we can't swear CU didn't do that on his own.

Any idea, hint or suggestion is more than welcome ;-) !

- Andrea

Everyone's tags (2)
14 REPLIES 14
Cisco Employee

Cisco C20 codec audio issue

Hi Andrea.

I have not experienced this before.

1. Try to upgrade the system to TC5.1.4 ( newest software version )

2. I would recommend you to try another HDMI cabel.

3. Try connect another screen that supports the same resolution and hdmi sound. Test sound.

          a) If sound is present on the screen, please check the NEC screen for faults.

          b) If there is no sound, please create a TAC service request and send me the SR# in PM

Thanks

//Marius

Cisco Employee

Cisco C20 codec audio issue

hi,

check if the output resolution is set to or 'negotiated' to 800x600 or 1920x1200.  I believe at this 2 resolution, we are sending the output at DVI format/mode, which means there will be no audio at this 2 resolution.

So to be safe, set the resolution to any instead of the above 2 listed instead of using Auto.

Beginner

Cisco C20 codec audio issue

Hi guys,

first of all thanks for your help, appreciated !

Here're my replies:

Marius

----------

this system was working fine till recently and no one touched (apparently) anything. Could it be possible/probable that a working HDMI cable all of a sudden stops sending audio just when carrying full HD video signals ?

We indeed connected another monitor (Samsung) and also on this one, when C20 is set to full HD, audio is not carried over ... on this device as well, switching to a lower resolution solves the problem.

Teck

-------

I'm sure the output resolution was 1920x1080 and no auto-negotiation was enabled ... unless there's a special/specific flag somewhere else than in the video output resolution menu subsection, I'm sure we were using 1920x1080 ... anyway, once more, is it possible that without changing this setting (we did not and I'm sure cu didn't do that as well) all of a sudden it stopped working ?

Cheers,

Andrea

Cisco Employee

Cisco C20 codec audio issue

I would recommend you to carry out the following steps.

The reason that i want to replace the HDMI cable is that i know old HDMI cable standards supports lower bandwidth  than newer HDMI cables. The reason this suddenly happened could be a bad connecting, degrading cables ect.

1. Try to upgrade the system to TC5.1.4 ( newest software version )

2. I would recommend you to try another HDMI cabel.

If none of this options work, I would recommend you create a TAC case to have this addressed accordingly.

//Marius

Beginner

Cisco C20 codec audio issue

Ok Marius,

we'll give your suggestions a go and we'll let you know.

Thanks for the tips.

- Andrea

Beginner

Cisco C20 codec audio issue

This may seem like a dumb fix, but try just unplugging and replugging the HDMI output cable into your monitor.  We have audio drop while picture stays up on numerous different installations and it seems to be an issue with the codec and the display not syncing properly on startup.

Often we find that if we just unplug and replug the display HDMI cable, the audio is restored.

Beginner

Cisco C20 codec audio issue

Hi James,

if you mean un-plugging and plugging the cable back into the monitor/TV, we already tried this (at least once when I plugged the cable into the other 'Samsung' monitor).

... if you mean un-plug the cable C20 side ... I didn't try that.

Thanks for your 2 cents ;-)

Cheers,

Andrea

Enthusiast

Cisco C20 codec audio issue

Hi Andrea,

We have a similar issue with no sound through HDMI.

Did you fix the issue?

Thanks for your feedback.

Yorick

Cisco C20 codec audio issue

Yorick,

  Are you on the same version of code as well?  Has anyone been able to see if this is still an issue on TC6 or possibly TC7?

Kenny

Enthusiast

Cisco C20 codec audio issue

We are running TC6.2.0 on C20. The codec was working fine until now with 2 monitors.

Last week, the screens have been replaced with bigger plasma ones. The long HDMI cables stopped working and a blackbox repeater has been placed between the codec and the screens. It was working fine Friday morning. Today, the sound stopped working.

The onsite technician tried to unplug the cables and switch them but this did not help.

Tomorrow he will try to lower the screen resolution to 720p and see if it helps. Then he will also try to connect the screens directly without the HDMI repeater.

I'm pretty sure the problem is HDMI connectivity with the blackbox device, the HDMI cable and the screens. But it was working fine Friday morning and that's strange it suddenly stopped...

Cisco C20 codec audio issue

Yorick,

  That is pretty odd symptoms.  From a troublshooting standpoint it sounds like you have the right idea in place.  It seems like you have a few possibilities for what the culprit could be.  In situations like this I would look at "what changed?"  and work from there.  I would think it to be pretty odd that it worked one moment and not the next when nothing changed.  Keep us updated on the results of your test.

Kenny

Beginner

Cisco C20 codec audio issue

Hi Yorick,

some good time has passed since I opened this discussion, didn't it ;-) ?!

... we had to solve quickly the problem so we replaced the box, period.

As I said, lowering the resolution from 1920x1080 seems to bring back things to normal state but this is just a workaround, when feasible. Not sure but this could be some sort of bug ... it could be interesting to try out either an upgrade or factory reset and see if it helps.

Should it come in handy, I realized there're also pretty old flat panels (plasma/LCD) which have a sort of limited HDMI stack which doesn't support audio at all ! On those kind of TVs you won't have audio through HDMI no matter what you'll try.

... of course this is not your case since it was working fine after the TV/Monitor replacement but I'd like just to share my knowledge to avoid some other good guy bumping his head on the wall ... just in case ;-)

- Andrea

Enthusiast

Cisco C20 codec audio issue

Hi Andrea,

Thank you for your hints. We discovered that a technician manually configured the TV with a resolution of 1080p 50Hz. Even if this worked for several days, it seems this triggered a HDMI negotiation problem with the codec.

After we put it back to Auto neg, the problem did not occur again... Fingers crossed but I think this was the cause.

Thank you for your answer anyway

Yorick

Highlighted
Beginner

Cisco C20 codec audio issue

No worries Yorick ;-)

... glad to know you found the cause which triggered the issue in your scenario.

Cheers,

Andrea

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards