cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1017
Views
0
Helpful
8
Replies
Highlighted
Beginner

Cisco C40 Web Interface Camera Control

We have three Cisco C40's on site set up identically and I am having an issue with only one of them. The issues is in the Call Control portion of the web interface. I can control the primary camera just fine, but if I switch to the secondary camera, it still controls the primary camera.

The Crestron control in the room is able to control both cameras individually, but the web interface only controls the primary camera. I would like to be able to use the web interface to set up calls from my office.

I'm not sure what the issue is and I was hoping turning to the support community for help would point me in the right direction.

Any help would be appreciated.

Thanks

8 REPLIES 8
Highlighted
Participant

Hi John,

This happened with me as well in one of our customer deployments.

More likely, I think the issue with the Camera Control cable running from 1st Camera to 2nd Camera.

Please check the cables from the codec also. Dont use too much of extenders or extrons and long cables.

Please check and revert.

Thanks,

Saurabh

Highlighted

I will have to check the cable that connects it to the primary cable. I had read about the camera software only being deployed to the primary camera so I went ahead and swapped them hoping that would fix the issue. It did upgrade the firmware, but it didn't fix the issue. 

What makes me think that it is not the cable is that their is full control over the camera with Crestron. I am fairly new to this position, and this installation, but wouldn't the Crestron system use the same protocol?

Highlighted

Hi John,

Cable issue most likely.

The other possibility is software version on 2nd camera. When a TC upgrade is applied to an endpoint, any camera updates bundled with the TC upgrade is deployed to the camera -unfortunately it is only deployed to the first camera in the series.

To check software versions on cameras connect to endpoint using SSH and check SoftwareID for both cameras...

xStatus Camera n SoftwareID 

n with be 1 for first camera and 2 for second camera in series.

If there is a mismatch with versions, try upgrading the second camera in series. It can either be done by:-

  1. Swapping cameras so camera 1 becomes camera 2 and camera 2 becomes camera 1. Reboot your endpoint which should detect firmware needs to be updated after start up. Note that camera firmware updates can take a good 15-20 minutes to deploy.
  2. If cameras are difficult to access and relocate you can try updating via Ethernet. Cisco has a guide that details this. Provided you have a nearby active ethernet outlet with DHCP enabled, the only other difficulty we had was sourcing the required camera firmware. Cisco haven't made these available through My Cisco. We sourced the version we needed through our maintenance provider. If you can create a Cisco TAC then look to source that way.

Cheers

Tom

Highlighted

Hi,

this issue is related to CSCue01414  and it is having fix in TC 6.2. I have tested in lab and it is working with TC 6.2 - beta1.

I will send you link for software by email

Kind regards,

Dharmmesh

Highlighted

Hi Dharmmesh,

I cannot access above bug link. How do I fix this so my profile can access them?

Cheers

Tom

Highlighted
Cisco Employee

Are you able to download software? I will look in to bug detail .



Sent from Cisco Technical Support Android App

Highlighted

Hi Tom,

This bug is internal bug so you are not able to see it .

Please install software which i provided to you by email and test the function .

Kind regards,

Dharmmesh

Highlighted
Cisco Employee

Hi,
Crestron use api commands to control codec , you can try remote control it will also work in your setup.


Sent from Cisco Technical Support Android App