cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

775
Views
0
Helpful
5
Replies
Highlighted

CISCO C60 Codec

Hello,

the system does not start up, potentially it is stuck in bootloop. At the start there only appears shortly the CISCO Logo. I will send my contacts by mail now a log for review.

Everyone's tags (5)
5 REPLIES 5
Cisco Employee

CISCO C60 Codec

Hello,

I looked at the log you sent via email. The codec boots as far as the login prompt, but then apparently reboots.

login:

U-Boot 2010.06-89 (Aug 10 2011 - 14:36:51) MPC83XX

Reset Status:

CPU:   e300c1, MPC8347_TBGA_EA, Rev: 3.0 at 600 MHz, CSB: 200 MHz

I2C:   ready

DRAM:  DDR2 RAM: 512 MiB

RAM data bus test          [PASS]

RAM address bus test          [PASS]

Either the main application crashes or there's some hardware issue.

Since you have console access I would let the codec reboot and enter followed by at reboot.

Press 'b' to enter u-boot prompt

Press 'c' to stop autoboot:  0

The you should get the u-boot prompt.

From there, we need to set some environment parameters so the codec does not reboot when it crashes and we can access the root shell to get the logfiles.

CASPER>setenv othbootargs allowroot noboot

CASPER>boot

Now when there's a crash, it should not reboot.

login as root and get all the logfiles

tar -cvf /tmp/historical_log_bundle_tar /config/logs/*

gzip /tmp/historical_log_bundle.tar

scp /tmp/historical_log_bundle.tar.gz user@system:historical_log_bundle.tar.gz

Last is secure copy to get file from your codec to some unix system.

You can also use winscp or some other program to get the file of the codec so it can be sent over.

If there are crashes, we should be able to run the files through a tool to look for known issues.

That would be the first step.

Also, at the CASPER> prompt, collect the output of hwmon :

CASPER>hwmon

That will show the voltages are in spec or not.

If you can get these files, that would be great!

Another way of looking at error messages would be to use following procedures, ones you broke into u-boot.

CASPER> setenv othbootargs allowroot noconsolefile noboot timestamp

CASPER>setenv console ttyS0

CASPER>boot

Now all the logging info is sent straight to your console.

Good luck,

Danny.

Beginner

Re: CISCO C60 Codec

Need help,

I have a cisco c60 codec, it powers up and show the green LED in front of the codec, but no display. i connected a serial cable via usb to my laptop and tried connecting using PUTTY and SecureCRT, but no response from the codec. pls can anyone help resolve this issue. am i connecting wrongly. serial connection is (Baud Rate- 38400, Data bits- 8, Parity- None, Stop bits-1, Flow Control-RTS/CTS -ticked.

 

VIP Advisor

Re: CISCO C60 Codec

Try with XON/XOFF flow control instead of RTS/CTS.  The 38400, 8, N, 1 is correct.

Have the serial cable connected and the terminal app running before powering on the endpoint, then turn it on and see if you can see any of the boot messages on the screen.

If you need to, you can also repeatedly press "b" while the system is being powered on, which should break out in to the u-boot where you can then use the "selectsw" command to try to swap to a different software image, or perform some other low level troubleshooting.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Beginner

Re: CISCO C60 Codec

Thanks for your quick response. The device is still not working, cant connect to it, tried the serial connections and changed the flow rate. is there a diagnostics tool i can use?



[1501666622290_PastedImage]

[1501666680772_PastedImage]

Raphael Kingsley Okpere

Network/Audio-Video Engineer

AiteoGroup

Tel: 09055693965.


Disclaimer: This e-mail and the attachments transmitted with it are confidential and intended solely for the use of the addressee. If you have received this e-mail in error, kindly notify the sender. If you are not the addressee, you should not disseminate, distribute or copy this e-mail. Any views or opinions expressed in this e-mail or attachments are solely those of the sender and may not necessarily represent the views and opinions of AITEO Group and or her associate companies. This e-mail may however contain information which is protected by legal, professional or other privileges. The contents of this e-mail and its attachments have been scanned for all viruses and all reasonable precautions have been taken to ensure that no viruses are present. You should however carry out your own virus checks before opening this e-mail or its attachments as AITEO Group cannot accept responsibility for any loss or damage arising from the use of this e-mail or its attachments.
VIP Advisor

Re: CISCO C60 Codec

Neither of the images you put in your reply seem to work at this end.  Are you able to attach them again?

Other than the serial port, or accessing via the network, there aren't really any other "diagnostics tools" you can use.  If it's looking really dead, your best bet would be to RMA the device through the TAC.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here