Showing results for 
Search instead for 
Did you mean: 

Cisco CMS add participant to a bridge

I'm working on deploying Cisco Meeting Server in our company and was trying to figure out how DX systems interact with CMS to add or invite participants. Let me explain.


In our prod enviroment:

CUCM 12 (without Resource Groups configured)

CMS 2.5.2 (connected to CUCM)

Cisco Jabber 12.5

Cisco DX70 CE9.6.2


If Jabber is on a CMS bridge, if I select the invite participant option and type in a SIP URI, Jabber will tell CMS to place the call. This behavior I like.

If the DX is on a call, I hit the add button, the DX places the call on hold, places the 2nd call and when trying to merge, fails, probably becaue the resource groups are not configured.


In my lab environment:

Same as above except CUCM is 12.5 and Resource groups are configured


Jabber behaves exactly the same way, the added call is initiated from CMS and not via the RG as an adhoc bridge

The DX however, when the Add button is pressed, the call is placed and merged, the DX will escalate the call to an adhoc CMS bridge connecting the new participant and the existing CMS bridge. Obviously this is no good.


Is there any for the DX to instead of trying to escalate the call to just tell CMS to place the call exactly like Jabber does for cleaner experience?






I think you are doing it in a wrong way for DX or please correct if i am getting wrong.

When you are initiating a call with jabber this is the one who has initiated the AD-hoc so all the participants will add in same bridge.

So in similar way, when you start a call from DX to a jabber (when jabber is not on a call) and then add the third person it will escalate the call to CMS bridge and all participants will join the same bridge.

But if jabber is already on a bridge call between DX and CMS and then DX user decided to add some one it will escalate a new call to CMS bridge including the old one which is a normal behavior from DX side.

So ideally when Jabber has initiated the ad-hoc then jabber only needs to add the participant not the DX.



Please rate if it is helpful....


Please rate if it is helpful and mark as accepted solution if applicable....

Hi Anurag,


Let me clarify and let's stick to my production environment where adhoc is not enabled/functionnal.



Jabber user calls into a preconfigured space using it's associated SIP URI address

Jabber user "invites a participant" CMS makes an outgoing call to such participant, CMS reports it as an outgoing call and the called party correctly sees the call coming from CMS



DX user calls into a preconfigured space using it's associated SIP URI address

DX user is unable to add a participant since the add button only shows up if Adhoc and ressource groups are configured in CUCM.


I want the DX to behave like the Jabber.

If I enable adhoc/Ressource Groups, the add button appears but it creates an unwanted behavior where a currently active bridge call will get escalated to a different adhoc bridge.


Hello Sebastian,


So you are still not doing the ad-hoc call.

When you are dialing directly to space how you are inviting the participant from jabber?
and how the CMS space is calling to some third endpoint?

I am still not clear with this.

Ideally if you need Ad-hoc conference you need to add the CMS as a conference bridge and add it to media resource group.
And apply that to endpoints so user can use ad hoc feature.

and if you are dialing directly to space the other user can also join the space no need for ad-hoc then.



Please rate if it is helpful...

Please rate if it is helpful and mark as accepted solution if applicable....


As you can see, I'm inviting the participant directly from the Jabber UI (in this case it's 12.6 but it works in 12.0 as well)

When you click on invite and type a URI to call or search for a contact, what happens is that CMS places an outbound call to the invited participant and it is thus joined to the existing space.


Again, the issue with adhoc is that we use pre-configured spaces/bridges so if you "add a participant" what happens is a 2nd adhoc gets created and joins the existing space/bridge with the added participant. This is not a good experience.




Seems like this is resolved in CE9.8 but at the expensive of ad-hoc call escalation? If there's a way to do both it would be great but as it stands which feature is more useful?


For this feature to work, Active Control must be enabled
on the device, the call protocol must be SIP, and the CMS
must be on version 2.4 or higher. The feature doesn’t work if
multipoint mode is set to CUCMMediaResourceGroupList.


Hi Chris, indeed I have tried and it's one or the other.

More problematic for me are two things:


- The add participant works great in the sense that it does indeed tell CMS to place the call as expected but it does not support DTMF commands which make it borderline useless for us as we wanted to to use this feature to tell CMS to call an audio bridge and then subsequently enter the DTMF commands


- It disables the multisite capabilities of my Webex Room kit systems (albeit they don't have the multisite, they are able to place 1 video + 1 audio). This means that it breaks the ability to place an audio call + DTMF


Dissapointing, I really hope Cisco adds DTMF support...





Please see the release notes for CE9.8.0 (Add participant to CMS conference from the device UI)

you need to upgrade DX80 on 9.8.0



Please rate if it is helpful..



Please rate if it is helpful and mark as accepted solution if applicable....


Does anyone have any details as to what this would look like in CE9.8?  Is it just pressing the Add button on the Touch?  Is there a new control in the participants list?




Cisco CMS add participant doesn't work!!!

Hi there,

Does anyone have any ideas about why adding participant from searching box is failed?

please see the attached file.


I'm using CMS 2.9.1.

I would appreciate if anyone could help me to solve the mentioned problem.



Content for Community-Ad