cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2698
Views
5
Helpful
15
Replies
huangzg
Beginner

Cisco Meeting Server Single-Split Deployment Changing TURN Server Port

In Single-Split Deployment, TURN server and Webbridge server are co-located on Edge server. By default, they both listen to same port 443. In the document, it says either use two interfaces or change the port TURN server listens to, i.e. 447.

In my DMZ setup, I only have one subnet. So the only option for me is to change the port.

In CMS API reference guide, it is not very clear. In section 10.7.2, it says to use the tcpPortNumberOverride to override the port.

But when I connect poster to edge server, GET https://<Edge FQDN>:445/api/v1/turnServers, it responds with 200 OK <turnServers total="0">.

Anyone can show me how it is done? Thanks.

15 REPLIES 15
s.sitthichai
Beginner

I found the same issue. I deploy single combined only one interface.

But I'm not sure how to check TURN server id. I tried to use poster to edge server and it get the same results.

Hi.  Make sure you have the turn port of your choosing configured on the edge MMP.  

SSH to edge, then type in: turn

If you don't see the port for turn tls, configure the port you wish to use.  

turn disable

turn tls <port number here>

turn enable

Once done, you have to tell callbridge what port to use.  

The api is done on the core server. If you configure turn over api, you have to remove it from the webadmin on the core. 

Then create a new turnserver by doing a POST to /turnservers with the parameters set in this doc: http://www.cisco.com/c/dam/en/us/td/docs/conferencing/ciscoMeetingServer/Reference_Guides/Version-2-0/Cisco-Meeting-Server-API-Reference-Guide-2-0.pdf

Page 102 section 10.7.2

You will see the parameters needed to complete the setup.  

Does this help?

VR

Patrick P

Hi Patrick

Thank a lot. I deploy single combined Acano Server and only one interface.
I can send PUT command to turn server id and add tcpPortNumberOverride = 447 which status is 200 OK.

After try to GET command, XML content not shown that parameter.

PUT

GET

If you are creating a new /turnserver to that node, you have to use POST. To modify existing, then use PUT. If you do a GET on /turnservers, does it return the ID? Then do a PUT to /turnservers/ with the parameter set. What program are you using for API commands etc? Can you screen grab what you are doing and put here? VR Patrick P

Yes,

I use command POST method to the /turnServers node and it created Turn Server ID.

POSThttps://172.168.2.40:445/api/v1/turnServers/

Then I use command PUT to /turnServers/<turn server id> and add parameter tcpPortNumberOverride = 447

PUT : https://172.168.2.40:445/api/v1/turnServers/api/v1/turnServers/8e682ad4-b0f5-47fb-8381-ffb82e8aabd8

From the previous picture, I'm not sure something wrong or not.

I'm using the Firefox add-on called Poster to access and update the API.

API

It has been fixed.

My problem it occur from parameter tcpPortNumberOverride.

It cannot have spaces "tcpPortNumberOverride=447"

If you put "tcpPortNumberOverride = 447", it's not working.

Working

Ahh. I can look into that a bit further as I believe it shouldn't return the 200 OK if it never took the command. Most folks I've worked with use chrome postman, and I generally use x-www-form-urlencoded to do this. Will look at raising this is an issue with the spaces like this.

Yes, I think it shouldn't return 200 OK if some parameter is wrong.

I tried to use content type is "x-www-form-urlencoded" (default is text/xml) it return 200 OK too but XML code not added.

So i tried to delete space and it is working fine.

Hi~Did you had fix the problem?

My turn server still <reachable>false</reachable>

I don`t now how to do~

Turn Server`s setting...

<?xml version="1.0"?>
<turnServer id="029fbb44-af34-4328-abf9-79bd3a602ddf">
    <serverAddress>192.168.1.xxx</serverAddress>
    <clientAddress>60.251.101.xxx</clientAddress>
    <numRegistrations>0</numRegistrations>
    <username>admin</username>
    <type>standard</type>
    <tcpPortNumberOverride>447</tcpPortNumberOverride>
</turnServer>

 

 

<?xml version="1.0"?>
<turnServer>
    <status>success</status>
    <host>
        <address>192.168.1.221</address>
        <portNumber>3478</portNumber>
        <reachable>false</reachable>
    </host>
</turnServer>

Isen Lin

Hello,

Did you fix your "<reachable>false</reachable>" problem

Im having exactly the same problem, with both 443 and 447ports

Thanks

Hello, I have same problem, deploy in single vm, so I need set "turn tls 447" after remove config from webadmin and doing config by API. I follow API doc and add new Turn Server, then add every parametre as... username, password, clientaddress, serveraddress and tcpPortNumberOverride = 447 then when I check status I see false and if I try connect to space from internet I can't see video, meanwhile If I connect from Intranet and not use Turn... CMS works fine. Where I wrong ? thanks M.

It cannot have spaces "tcpPortNumberOverride=447"

If you put "tcpPortNumberOverride = 447", it's not working.

Hello, sorry I put "tcpPortNumberOverride=447" and if I check I can see turnServers with this... but if I check /status I see "false I don't understand where I wrong... only 1 thing by API I can't see password, I put it but after I can't see... is it normal ?

I put my replay from API, this is my /status

<?xml version="1.0"?><turnServer><status>success</status><host><address>192.168.XXX.XXX</address>
<portNumber>3478</portNumber><reachable>false</reachable></host></turnServer>

this is my /turnServer/4dde9b51-d878-4bce-b616-32f97a18787b

<?xml version="1.0"?><turnServer id="4dde9b51-d878-4bce-b61632f97a18787b"><serverAddress>192.168.XXX.XXX</serverAddress><clientAddress>185.73.XXX.XXX</clientAddress>
<numRegistrations>0</numRegistrations><username>turnadmin</username>
<type>standard</type><tcpPortNumberOverride>447</tcpPortNumberOverride></turnServer>

Thanks

M.

I'm not sure but this is my output.

Create
Recognize Your Peers
Content for Community-Ad