cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1608
Views
5
Helpful
4
Replies
Highlighted
Beginner

Cisco SX20/80 not sync with NTP

Hello,

 

The SX20 and SX80 codecs version ce 9.7.1 registered to Cisco CUCM 10.5 often getting timeout error. I understand unlike regular IP Phones SX devices are not getting time updated from CUCM NTP / NTP reference in CUCM.

 

I configured NTP servers in GUI : Configuration > Network Services > NTP  mode Manual and enter the NTP details and it is getting sync with it however after a reboot of the codec the system will download config from CUCM and the NTP settings configured in codec web GUI will be lost and after a day or 2 the time is again wrong.

 

We are using static IP address for the codecs so DHPC option 42 for NTP reference is not possible in my scenario.

 

Any advice is appreciated. Thanks

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Check the NTP reference in CUCM that is associated with the device pool for your devices. The NTP reference for Cisco sx endpoints needs to be Unicast, the default CUCM time reference for NTP is broadcast. Create a unicast reference and apply it to the device pool, you will then need to restart the endpoint and see if the NTP is fixed.

View solution in original post

4 REPLIES 4
Highlighted
Rising star

it sounds like CUCM is pushing it's settings to your endpoints and overriding what you've done on the endpoint itself. So what you need to do is correct the configuration that's going to the endpoints. 

 

See this document - it outlines how to create the NTP references in CUCM for TC/CE endpoints. 

 

https://www.cisco.com/c/en/us/support/docs/collaboration-endpoints/dx70/213278-configure-a-phone-network-time-protocol.html

Highlighted
VIP Advisor

One thing to check is that if you are using a domain name for the ntp server (ie ntp.company.com) that you also have appropriately set the DNS Server settings on the endpoints so they are able to resolve the name to an IP address.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Highlighted
Beginner

Perhaps you could institute a Startup Script to reinforce the settings specific to you NTP servers (image attached).
Highlighted

Check the NTP reference in CUCM that is associated with the device pool for your devices. The NTP reference for Cisco sx endpoints needs to be Unicast, the default CUCM time reference for NTP is broadcast. Create a unicast reference and apply it to the device pool, you will then need to restart the endpoint and see if the NTP is fixed.

View solution in original post