cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1311
Views
0
Helpful
10
Replies
Highlighted
Beginner

CMS webrtc from Internet

we have CMS 2.2.2 and expressway 8.9.2. I can open the link from Internet and after I join the meeting, the media stream cannot be connected and then the call dropped.

10 REPLIES 10
Highlighted

Did you configure CMS to use the Expressway for TURN services?

Make sure your certificates are correct as well, that the web bridge trusts the call bridge's certificate.

Cisco Expressway Options with Cisco Meeting Server and/or Microsoft Infrastructure (Expressway X8.9.2)

Highlighted

Yes, expressway for TURN services. I have added the FQDN of web bridge to the certificate.

Highlighted

Given that it says "Unauthorized", maybe your TURN credentials either on CMS or the Expressway?

Other than that, I would highly suggest getting the firewall people involved.  If you have access to a VM or switch in the same network segment as the Expressway-E's external interface, you could try joining from there so that the firewall wasn't in the way...

Highlighted

I have a same issue on same deployment model, and get same error too,

I know the documentation is tell if that error appear we must check the Turn credentials either on CMS or Expressway, i have already make sure and the credentials should be match.

in my case, Webrtc (internal) works fine, however, when remote user through expressway E (WebRTC from internet) join a meeting, a remote user was kicked after some time..

i have already adjust video rate to very low quality still no luck.

Please advice about what steps are being used to resolve this issues

Highlighted

Gilang, do you get video and subsequently get kicked, or do you get no video at all?  If you do have video, does it look like you have packet loss?

If you get good quality video then get kicked, I would suggest firewall, possibly a timeout issue.

If you get poor quality video and later get kicked, it's probably packet loss, this can be an issue even in low bandwidth calls.

If you never get any video, it's likely firewall or TURN server configuration, see my posts above.

Highlighted

This sounds like the same issue I had: https://supportforums.cisco.com/discussion/13307211/issues-getting-cms-webrtc-work-expressway

A few things to check;

The TAC re-added my TURN server via API, using IP address instead of FQDN (not sure if this was actually required or not).  In addition, I was missing some ports on my firewall (TCP/UDP 3478) - I would suggest writing down the public IP address of the computer you are trying to connect from, then searching for drops to and from that address on your firewall.

Highlighted

I also added the turn server via api and saw the status was OK.

Highlighted

Have you checked the firewall for packets being dropped/blocked while you are initiating a call?

Highlighted

The firewall is maintained by other guys and I cannot get the log easily. But I can capture the packet of expressway and CMS. When I connected the webrtc from internet, I saw the error message from wireshark.

Highlighted
Beginner

Hi,

 

I have same problem with you but our system is

- Expressway 8.10.3 (duel NIC)

- CMS 2.5.1

- Didn't enable NAT Reflection on Firewall side.

 

My problem is cannot establish connection to space. Same error with you. So how you to resolved this case? It may came from NAT Reflection?

Content for Community-Ad