cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1741
Views
30
Helpful
7
Replies
draach-85
Beginner

CMS3.2: no webbridge URL in invitation email

Hello everybody,

 

I am running into problems with CMS3.2 and the invitation email template. I've configured a working callbridge and webridge3. The spaces and users come from LDAP and I am able to access the personal spaces via SIP and via WebRTC. For the invitiaion I'm using the template of the customization guide:

call_branding.zip (local on CMS)> invitation_template.txt
------------------------------------------------------------------------------
Subject: {% if name %}You are invited to join a meeting: %name%{% else %}You are invited to join a meeting{% endif %}

#if numeric_id
TESTTESTTESTTEST Meeting ID: %numeric_id%
#if passcode
Meeting passcode: %passcode%
#endif
#endif

#for wba in sort(web_bridge_addresses)
#if wba.address or wba.hyperlink
#if loop.index == 0
Join from a computer, mobile phone or tablet
#endif
{% if wba.label %} %wba.label%:{% endif %} {% if wba.hyperlink %}%wba.hyperlink%{% else %}%wba.address%{% endif %}
#endif
#endfor

#for ivrn in sort(ivr_numbers)
#if ivrn.number
#if loop.index == 0
Join by phone
#endif
{% if ivrn.label %} %ivrn.label%:{% endif %} %ivrn.number%
#endif
#endfor

#if uri
Join from a video conferencing system or application
Dial %uri%
#endif
------------------------------------------------------------------------------

 

When I am logging into the webridge user area and click on my personal space on the left I am able to see the link "https://webcall.domain.int/meeting/8871001?secret=btuljr6UhjR3VWEP59IrMg". But after clicking the email icon I only receive:

------------------------------------------------------------------------------
TESTTESTTESTTEST Meeting ID: 8871001

 

Join from a video conferencing system or application
Dial sip:8871001@domain.int
------------------------------------------------------------------------------

Because of the TESTTESTTESTTEST I know that "my" template is used. It seems like the configuration which is used by the variable "web_bridge_addresses" is missing in my CMS configuration, where do I have to configure it? In the old CMS versions I had some settings on the webadmin > Configuration > General but in the newer CMS versions this setting is removed. In the API I've configured one webbridge with the url c2w://webcall.domain.int:9999.

 

Regards, Daniel

1 ACCEPTED SOLUTION

Accepted Solutions
Sebastian Hughes
Cisco Employee

The webbridge addresses come from /api/v1/webbridgeprofiles/<GUID>/webbridgeaddresses

View solution in original post

7 REPLIES 7
Sebastian Hughes
Cisco Employee

The webbridge addresses come from /api/v1/webbridgeprofiles/<GUID>/webbridgeaddresses

Hi Sebastian, thanks a lot, that did the trick.

cnkysr
Beginner

Hi draach-85

 

Did you solve this problem ? I have same issue.

 

Thanks,

Sebastian Hughes
Cisco Employee

@cnkysr Did you check if there are any entries in the API I posted above?

Hi Sebastian, 

 

I checked but there aren't any entries in the API . Any example on this issue ? 

 

thanks,

In order for this section in the template to work:

#for wba in sort(web_bridge_addresses)
#if wba.address or wba.hyperlink
#if loop.index == 0
Join from a computer, mobile phone or tablet
#endif
{% if wba.label %} %wba.label%:{% endif %} {% if wba.hyperlink %}%wba.hyperlink%{% else %}%wba.address%{% endif %}
#endif
#endfor

You need atleast one entry under the webbridgeaddress API that I talked about above.

 

Thanks Sebastian, 

Create
Recognize Your Peers
Content for Community-Ad