cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1520
Views
0
Helpful
3
Replies
Highlighted
Enthusiast

CTS Connection Error to Room Phone after Upgrade

A few days ago I upgraded a CTS 3010 and CTS 1300 from 1.7.0.2(4719) to 1.7.2.1(2).  I also upgraded their room phones from SIP75.8-5-3SR1 to SIP75.9-1-1SR1S.  I noticed that in the downloads section on CCO the jar and jad files were not included under 1.7.2.1(2) so I grabbed the ones from 1.7.2(4937).

The CTS endpoints work great, however, when I'm on the CTS Web UI, I notice that the System Status says it cannot connect to the room phone.  The exact error is "Connection: error; Software: Unable to retrieve software  version".

Anyone have an idea as to how I can resolve this error?  Everything seems to be working fine on the endpoints.

Thanks!

Jeff

Everyone's tags (5)
3 REPLIES 3
Highlighted
Beginner

CTS Connection Error to Room Phone after Upgrade

Hello Jeff,

Is the IP Phone registered to the CUCM

In the CCM, have you configured new Services for Midlet

Are the Phone’s subscribed to the new Midlet services

Kindly open a TAC case in case you require any trouble shooting assistance

With Regards

Shyam KN

Enthusiast

CTS Connection Error to Room Phone after Upgrade

Yes, the phone is registered to CUCM and using the new Midlet.  However, the midlet was actually for version 1.7.2(4937), not 1.7.2.1(2) which is the latest on CCO.

I suspect this problem is caused by me not having the exact same version of Midlet as the CTS code.  However, in the downloads section of CCO it does not have the Midlet files for that particular version.  Where am I supposed to get the .jar and .jad midlet files for this particular version (1.7.2.1(2))?

Thanks, Jeff

Highlighted
Beginner

Re: CTS Connection Error to Room Phone after Upgrade

Jeff,

The midlets for the CTS / Phone systems work on what I like to think of as the "Price is Right" system. Just as in the in the showcase showdown, you can be a winner by getting a midlet version as close to the CTS code version without going over.

So, in the case of 1.7.2.1(2) software you just download the midlet in the latest version previous to the one you are using, if there is no midlet released with that version. In this case the 1.7.2(4937) midlet looks to be the correct one.

In 1.7 versions of CTS code, you can verify the system is using the correct midlet, by logging into the endpoint and looking at the sysop log. There should be a line similar to the one below, which will tell you the CTS midlet version expected and the version running on the phone. These should match.

INFO Phone UI version. Phone:1.41.0, CTS:1.41.0

The things that I'd suggest looking at surrounding midlet issues are the following.

1. Have TFTP services been restarted on the CUCM after the midlet was uploaded?

2. Is the midlet configuration in the Phone Services section correct? (the naming convention for the midlet changed slightly in the 1.7.x version, so the best thing to do is just paste the midlet file name into the fields as needed, instead of trying to edit it by hand)

3. The midlet config can get "stuck" during an upgrade. Try removing all the midlets from the phone then restart the phone. After the phone comes back up, subscribe the midlet again.

Like Shyam said though, should those things not correct your issue. Just open a TAC case and someone will be happy to assist you.

CreatePlease to create content