cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3334
Views
0
Helpful
22
Replies
ratz.andras
Beginner

CUCM integration into CTS Manager.

Hello Everyone.

My problem is, that I'm trying the integration of an Cisco TelePresence Manager into our TP network.

I read all the information on the cisco website, and did everything, what is writen there, but I get error everywhere.


At the CUCM integration, I made the user,I made the group, I added the roles as writen, but at the CTS configuration website I'm getting the following error:

Failed to establish a connection to 'XX' with the information provided.
    Code: 501000.
    Message: The system has encountered an unexpected condition (com.cisco.ts.scheduler.exception.DiscoveryException(502406,DM,CCM_AUTH_CONN_FAILURE,Unable to authenticate and connect with Unified CM 'XX' because Invalid application user credential.)).

I used a simpley user password, I downloaded the cerficate file, as writen in the documentation.


I hope, someone can help me.

Thanx.

Andras

22 REPLIES 22
gogasca
Advocate

Which version of CUCM and which version of CTs-Man

Make sure under CUCM System its configured to use an IP address, then restart CUCM and CTI manager

After that try again.

Make sure user has associated to all roles

Thanks

Hi.

The CUCM version is 8.5

The CTs-Man is the newest 1.7.1

I restarted several times the CUCM and the CTs-Man, but it don't work.

The interesting part is, if I only load the certificate and I dont fill out the server, user and pass fields, and then hit the Test button, it write out the same error message.

Can be a problem, if both systems are on VMware?

"Make sure under CUCM System its configured to use an IP address"

Can you confirm above (CUCM Admin | System | Server) , as if CTS-Manager is not able to resolve CUCM name, it will fail with a similar error

Once you confirmed this, make sure Roles:

Standard AXL API Access

CCMAdmin Users

CTI Enabled

RealtimeandTraceCollection

Serviceability

CUCM,CTI and AXL services must be restarted after this,

confirm password

then restart CTS-Man

Then if still doesnt work, send me the CTS-MAn logs Discovery logs set to DEBUG.

We have VMware similar setup with no issue,

Thanks

I checked everything what you wrote, it was good, but it is still don’t work. I attached the log file what you asked for.

The name is no problem cause I use IP address not a host name.

Hello Andras,

Your attachment has been removed to protect your confidential information. Please proceed to open a Service Request and upload the logs to the SR for a TAC engineer to assist you. Thank you!

Hi Andras,

Can you run CTSMan PreQualification Assistant Tool 1.7.1 and see if it passes the test or not ?

Thanks

Arun

Hi Arun.

I allready tried the prequalification tool, and it don't passed. It wrote out the same error.

Azrael667
Beginner

Got exacly the same error here.

Azrael667
Beginner

Problem resolved here.

The error message is strange as the problem came from the certificate. I re-downloaded it from my browser on the cucm web page then uploaded it for the test connection page in ctsmanager and that works fine.

I think the certificate is the problem here too. Which certificate did you downloaded exacly?

You did nothing jus re downloaded?

Actually i logged on my cucm admin webpage then clicked on the blue part of the url (connexion secured). Then i applied these steps given by someone from cisco:

For downloading the new certificate from CUCM and then upload it to CTM

# a.open an IE browser and log in to the CUCM

#b.when security alert window pops  , click View Certificate

c.click Details at the Certificate pop up

d.click Copy to File on the bottom right corner

e.click Next, and leave the default DER encoded binary X.509(.CER),
click Next

f.pick a folder and enter ccm-cert as file name from Browse and click
Save

g.click Next, Finish, Ok

Go to the folder and find ccm-cert.cer, change it to ccm-cert.der

Then use your .der file during the connection test with your hostname/ip of cucm and app user logs.

Thanx for the tips, but sadly it's not working.

Your certificate is self signed? Or you have a public certificate?

One thing I don't get, what should be the extension? .der or .cer? or it doesn't matter?

When you get the certificate from your browser, the extension format doesnt really matter ( .crt/.cer ... ). You just need to change it to ".der" after downloading it on your computer.

The certificate is generated by the cucm so yeah it's self-signed.

Did you tried to delete/create the app user you are using for ctsman ? (and the group which is associated to this user)

I had the same problem.

In the documentation it doesn't say you have to enter the digest password as well, but when I did the authentication works fine.

the stupid thing is that for the prequalification assistant you don't have to enter the digest passwd for it to work..

(took me days to find this one out)

Create
Recognize Your Peers
Content for Community-Ad