cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1336
Views
0
Helpful
1
Replies
Beginner

Dial-Peers and Incoming Caller-ID

I am trying to setup my first CME VOIP Lab and I am having some trouble.  I can dial local #s and national #s, but toll free numbers aren't going through.

Also when I get an incoming call the Caller-ID doesn't show up, the 7960 just says "External Number"

I tried the "caller-id enable" under the voice-port 1/1/0 (which is my FXO card) and I get this:

CallManager(config-voiceport)#caller-id enable

                               ^

% Invalid input detected at '^' marker.

Any ideas?

Here is my config:

Current configuration : 6606 bytes

!

! Last configuration change at 01:26:24 pst Fri Jun 7 2013

! NVRAM config last updated at 01:12:02 pst Fri Jun 7 2013

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CallManager

!

boot-start-marker

boot-end-marker

!

no logging buffered

!

no aaa new-model

clock timezone pst -8

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool VOICE/DATA

   network 10.0.50.0 255.255.255.0

   option 150 ip 10.0.50.1

   default-router 10.0.50.1

!

!

!

multilink bundle-name authenticated

!

!

!

trunk group  OUT

!

!

!

voice service voip

dtmf-interworking rtp-nte

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

voice class h323 1

h225 timeout tcp establish 3

h225 timeout setup 3

!

!

!

!

voice class cause-code 1

no-circuit

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 /^702586\(1...\)$/ /\1/

!

!

voice translation-profile DID

translate called 1

!

!

!

crypto pki trustpoint TP-self-signed-2215009052

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2215009052

revocation-check none

rsakeypair TP-self-signed-2215009052

!

!

crypto pki certificate chain TP-self-signed-2215009052

certificate self-signed 01

  30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32323135 30303930 3532301E 170D3133 30363037 30343133

  34385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 32313530

  30393035 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100B100 E333437B 44D0EC60 8FADE1A0 89D3ADBC CDE13BD5 623B5205 75493AFB

  C0D8BF0F 8D9129F1 5DE54189 C182498F 531FE400 AEA816C6 F6A7FCF0 447636BB

  79B90C31 51B2879A 84489D5D 889DA761 835E8501 C9D86C3F 453214A2 A8EEA53C

  C0244A31 703DA1F7 CA61AAAE A9BD3AED A1910AB4 98F24607 18208372 6E12F2B1

  85450203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603

  551D1104 0F300D82 0B43616C 6C4D616E 61676572 301F0603 551D2304 18301680

  14490111 E89DCDAD EBB061C6 84597CC0 58E8CFCE 30301D06 03551D0E 04160414

  490111E8 9DCDADEB B061C684 597CC058 E8CFCE30 300D0609 2A864886 F70D0101

  04050003 8181000B 6829EF4F 26D5A8A8 BD03CFC2 810A2ED2 FDDBFAB3 097B4074

  4A24959C 6564863D 9B7C6B67 E0C817D8 0CC796C2 945DA12B BA30D9A1 9EA6FB70

  BB2E2653 D88D07A2 A530EE03 D9E72CB3 6B267C9A 0E130BF1 D6EAACC5 9EB375DF

  2BF2AB25 F03C3FCA C5611B0B 94BACA6B 12238396 D885D4D8 492B75BD 4B40073F

  27CF0FB5 D562B9

        quit

!

!

username woodjl password 0 henry999 privilege 15

username woodjl1650 password 0 henry999 privilege 15

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.50.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

!

interface Serial0/0.31 point-to-point

ip address 10.1.12.3 255.255.255.0

snmp trap link-status

frame-relay interface-dlci 301

!

interface FastEthernet0/1

ip address 20.0.24.2 255.255.255.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 10.0.10.0 0.0.0.15 area 2

network 20.0.24.0 0.0.0.255 area 4

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.0.10.3

!

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

ip http path flash:gui

!

!

!

!

!

tftp-server flash:P00308000400.bin

tftp-server flash:P00308000400.loads

tftp-server flash:P00308000400.sb2

tftp-server flash:P00308000400.sbn

!

control-plane

!

!

!

voice-port 1/0/0

ring cadence pattern01

cptone GB

description Fax_Machine

caller-id enable

!

voice-port 1/0/1

!

voice-port 1/1/0

trunk-group OUT

no battery-reversal

cptone GB

connection plar opx 1001

description Office Line

!

voice-port 1/1/1

no battery-reversal

cptone GB

connection plar opx 1002

description Home Line

!

!

!

!

!

dial-peer voice 1004 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 200 voip

destination-pattern 1...

session target ipv4:10.0.50.1

!

dial-peer voice 1 pots

preference 1

destination-pattern 91..........

port 1/1/0

forward-digits 11

prefix 1

!

dial-peer voice 2001 voip

destination-pattern 1001

codec g711ulaw

!

dial-peer voice 2002 voip

destination-pattern 1002

codec g711ulaw

!

dial-peer voice 1001 pots

trunkgroup OUT

description Long Distance

forward-digits all

!

dial-peer voice 1002 pots

trunkgroup OUT

description Local Calls

destination-pattern .T

forward-digits 7

!

dial-peer voice 80 pots

trunkgroup OUT

description Toll Free Dial-Peer

destination-pattern 18[00,55,66,77,88][2-9]......

forward-digits 11

prefix 1

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

load 7960-7940 P00308000400

max-ephones 24

max-dn 48

ip source-address 10.0.50.1 port 2000

timeouts interdigit 2

time-format 24

max-conferences 4 gain -6

web admin system name woodjl1650 secret 5 $1$j3F0$ZJyBANEPW2SAmJp8OUcXL.

dn-webedit

time-webedit

transfer-system full-consult

directory entry 1 7027787551 name Home

directory entry 2 9137580443 name Steve & Teresa Wood Home

directory entry 3 9136831205 name Teresa Wood Cell

directory entry 4 9136833052 name Steve Wood Cell

create cnf-files version-stamp 7960 Mar 23 2013 00:14:46

!

!

ephone-dn  1

number 1001

label Lab

description Lab

name Lab

hold-alert 30 originator

!

!

ephone-dn  2

number 1002

label Office

description Office

name Office

hold-alert 30 originator

!

!

ephone  1

device-security-mode none

mac-address 0013.80DF.7F34

speed-dial 1 7024011492 label "Jonathan Cell"

speed-dial 2 7024011526 label "Katie Cell"

speed-dial 3 7024041362 label "Ops Desk"

speed-dial 4 1001 label "Cisco Lab"

type 7960

button  1:1

!

!

!

ephone  2

device-security-mode none

mac-address 0011.20BA.F7B8

speed-dial 1 7024011492 label "Jonathan Cell"

speed-dial 2 7024011526 label "Katie Cell"

speed-dial 3 7024041362 label "Ops Desk"

speed-dial 4 1002 label "Home Office"

type 7960

button  1:2

!

!

ephone-hunt 1 peer

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

line vty 5 15

login

!

ntp server 64.250.229.100

!

end

Everyone's tags (4)
1 REPLY 1
Highlighted
Hall of Fame Master

Dial-Peers and Incoming Caller-ID

Try

dial-peer voice 80

forward-digits all

no prefix 1

CreatePlease to create content