cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
410
Views
0
Helpful
5
Replies
David Imrie
Beginner

Does my router support IGMP?

Hi,

Can anyone help me with this issue?

I am trying to set up multicast routing on my cisco 887va-m to support TV services from my ISP.

I have entered ip multicast-routing, but when I go under an interface, the commands "ip pim", and "ip igmp" are not recognised / dont exist in the context sensitive help.

Can anyone tell me why this might be?

 

My IOS is c880data-universalk9-mz.152-4.M1.bin with the advanced security licence.

 

Base Router config

 

no aaa new-model
memory-size iomem 10
clock timezone GMT 0 0
!
!
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool LAN
network 10.0.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
domain-name home.local
default-router 10.0.1.1
remember
!
ip domain name home.local
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip multicast-routing
ip cef
no ipv6 cef
!
!
controller VDSL 0
operating mode vdsl2
!
interface Ethernet0
no ip address
!
interface Ethernet0.101
encapsulation dot1Q 101
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 103
no ip address
spanning-tree portfast
!
interface FastEthernet1
switchport access vlan 102
no ip address
spanning-tree portfast
!
interface FastEthernet2
switchport access vlan 102
no ip address
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 102
no ip address
spanning-tree portfast
!
interface Vlan1
no ip address
!
interface Vlan102
description LAN_ACCESS
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan103
ip address 192.168.1.254 255.255.255.0
!
interface Dialer0
no ip address
!
interface Dialer1
description **BT INFINITY**
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication pap chap ms-chap callin
ppp chap hostname bt@btinternet.com
ppp chap password 0 password
ppp ipcp address accept
no cdp enable
!
ip dns server
ip nat inside source list NAT_ADDRESSES interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list standard NAT_ADDRESSES
deny 10.0.0.0 0.0.0.255
permit 10.0.1.0 0.0.0.255
!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

 

You only have security services. You need to purchase advanceipservices to get multicasting working

View solution in original post

5 REPLIES 5
Marcel van Dorp
Beginner

You say under the interface it does not take the command. I could not see in your explanation where you did this but your physical interfaces are set to be access ports so you need to do this under the vlan interface the ports are set to.

I'm pretty sure I tried the command on every interface going including SVIs, but I'll double check and get back to you.

Hi,

 

Check the output of the command show lic feature and see if advipservices license is enabled or not.

 

I don't think it is because the router isn't taking the command. If you already purchased this license then you can enable it using the command 'license boot module c880-data level advipservices'

 

 

ahhh thank you... I think that's my problem?

 

What is the easiest/quickest/cheapest way to get a licence upgrade for home use?

I've never dealt with licencing before.

 

HOME_ROUTER#show lic
Index 1 Feature: advipservices
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 2 Feature: advsecurity
        Period left: Life time
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
Index 3 Feature: ios-ips-update
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 4 Feature: WAAS_Express
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: Non-Counted
        License Priority: None
Index 5 Feature: SSL_VPN
        Period left: Not Activated
        Period Used: 0  minute  0  second
        License Type: EvalRightToUse
        License State: Not in Use, EULA not accepted
        License Count: 0/0  (In-use/Violation)
        License Priority: None

Hi,

 

You only have security services. You need to purchase advanceipservices to get multicasting working

View solution in original post

Content for Community-Ad

Spotlight Awards 2021