cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

615
Views
0
Helpful
6
Replies
Highlighted
Beginner

downgrade C20 from 5.x to 3.x - “Corrupt software-package uploaded.”

I have to downgrade my C20 from 5.x to 3.x because in 4+ version I has issues with video-freeze during 5-7 minute of a call when I connects to Sony codec (G50). When I had 3.x version it worked fine. My devices were shipped with 3.0 version.

When I try to upload old firmware (3.x) using codec’s web interface it shows me “Corrupt software-package uploaded.” I downloaded all 3.x firmware files – each file had the same result. How I can to downgrade to 3.x?

Everyone's tags (3)
6 REPLIES 6
Beginner

downgrade C20 from 5.x to 3.x - “Corrupt software-package uplo

I am having the exact same issue with an EX90. I have tried every file as well. Can anyone help?

Cisco Employee

downgrade C20 from 5.x to 3.x - “Corrupt software-package uplo

Have you try upgrading software by directly uploading software on EX90 by using SCP instead of upgrading from Web GUI?

If you are using Windows, then WinSCP is probably most friendly application for uploading software to EX90.

If you are using MAC, there are several similar application (fireftp, Cyberduck, etc.) and you may also create WinSCP.app by using WineBottler (to use WinSCP on MAC).

For software upgrade procedure by using WinSCP, please refer to https://supportforums.cisco.com/docs/DOC-24297 or https://supportforums.cisco.com/docs/DOC-15643 (Endpoint Technical Handbook).

Cisco Employee

downgrade C20 from 5.x to 3.x - “Corrupt software-package uplo

BTW which TC3.x software are you trying to downgrade on your EX90?
Please note if you have newer HW (system ship out from Cisco with TC4.0.4 or newer version) may not compatible with old TC3.x software “except” TC3.1.4 (additional information is available on TC3 release note).

Beginner

downgrade C20 from 5.x to 3.x - “Corrupt software-package uplo

Downgrading via WinSCP worked like a charm! Thank you!

Cisco Employee

downgrade C20 from 5.x to 3.x - “Corrupt software-package uplo

Great and thanks for sharing the result which will be useful tip for other may experience same error/issue.

Beginner

downgrade C20 from 5.x to 3.x - “Corrupt software-package uplo

I found solution.

I downgrade it from 5.x to 4.x, then from 4.x to 3.x

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards