cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1289
Views
6
Helpful
10
Replies
Highlighted
Beginner

DTMF problem with MRA via Expressway-C/E 8.5.3 and 8.6.x

Hello,

It worked like a charm on Expressway-C/E v8.5.1, but since we upgrade to Expressway-C/E v8.5.3 (or newer, v8.6.x) to try MRA for 7800/8800/DX series endpoints, we have a problem with DTMF.

 

Endpoints:

Jabber for Android/iOS v11.1.0, IP Phone 7841 v10.3(1)

 

Symptom:

DTMF not sent during call through Expressway-C/E.

 

Conditions:

We make calls to many different IVR-enabled numbers(e.g.,owned-UCCX;PSTN), try to follow the IVR dialogue, and the IVR cannot detect any entries. But if we put the call on hold and then resume it, the other end will hear/receive all digits we pressed before in sequence and then DTMF work again for that call session.

 

Have I missed something?

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

There were a couple defects

There were a couple defects in pre 8.7 code that caused DTMF to fail across the expressways. The issue was with how the KPML Subscribe message was handled on the Expressways. This however was resolved in 8.7.


If you are still having issues with 8.7 it leads me to believe that you are using shared lines across the expressway. During your testing, do you happen to have multiple devices registered over MRA with the same extension?

View solution in original post

10 REPLIES 10
Highlighted
Beginner

What versions are in use for

What versions are in use for Jabber/7841?

Are these B2B calls? if so, is RF2833 checked on the sip trunk?

Beginner

Thank you for your reply, but

Thank you for your reply, but these are not B2B calls.

It's Jabber v11.1 and CP-7841 v10.3(1).

 

I will add this information to the main post.

Highlighted
Beginner

Hi

Hi

Did you find the solution for this, having the same problem with Jabber 11 with exp 8.6.1

Thanks

Highlighted
Beginner

Now it works on EXP 8.7

Now it works on EXP 8.7 version.

Highlighted
Beginner

I still have this DTMF issue

I still have this DTMF issue on Expressway 8.7 with or without a SIP trunk with DTMF set. Some IVRs work we only have issues on some IVRs on RMA, if the Jabber client use the corporate network we don’t have any issues. It’s a combination of RMA and this IVR. Not sure what I can do to work towards a solution on this. Any ideas would be helpful.
Thanks,
Nico

Highlighted
Cisco Employee

There were a couple defects

There were a couple defects in pre 8.7 code that caused DTMF to fail across the expressways. The issue was with how the KPML Subscribe message was handled on the Expressways. This however was resolved in 8.7.


If you are still having issues with 8.7 it leads me to believe that you are using shared lines across the expressway. During your testing, do you happen to have multiple devices registered over MRA with the same extension?

View solution in original post

Highlighted
Beginner

Hi Chad, thank you very much

Hi Chad, thank you very much for your reply and interest. To ensure I give you acurite feedback I asked my test team to test:
1: Jabber Client on MRA with a shared line where the Desk Phone is registered
2: Jabber Client on MRA with a shared line where the Desk Phone is not registered
3: Jabber Client on MRA without a shared line configuration.
4: Jabber Client on Corporate Network with a shared line where the Desk Phone is registered
5: Jabber Client on Corporate Network with a shared line where the Desk Phone is not registered
6: Jabber Client on Corporate Network without a shared line configuration.

CETEST01 – No Shared line
CETEST02 – Shared line
CETEST03 – Shared line
CETEST04 – No Shared line
CETEST05 – No Shared line

At this stage the feedback I have from them is that in the Corp Network DTMF work perfectly, we only have the issue on MRA.

I will get back to you with the results as soon as I hear back from the UAT team.

Thanks,

Nico Kotze

Vodafone UK.

Highlighted
Beginner

Hi Chad,

Hi Chad,

There was a fix applyed to the SIP CUBE that resolved this DTMF issue.

All working now.

Thank you,

Nico

Highlighted
Beginner

Nico,

Nico,

Can you please share what was applied on the CUBE?

Thanks.

Highlighted
Beginner

Hi Dalton, It was a codec

Hi Dalton, It was a codec preference to include all codecs.

CreatePlease to create content