cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1228
Views
10
Helpful
11
Replies
Highlighted

Enabling (SIP) digest authentication on SX20

Hello


I am looking for steps/instructions on how to enable (SIP) digest authentication on an SX20.

Authentication is currently set to OFF (pls see attached screen snapshot). It seems that as a result, SX20 is not filling in the username (extension number) in the register message. [Waiting for SIP debugs from client to verify this..]

Will entering a non-null string for username and password automatically cause authentication to be enabled?

Thanks in advance,

Baktha Muralidharan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

To close the loop on this--

   The following fixed it.

    In the past, you could choose the Call Control from the SIP Settings page, which is a pull down with options including CUCM, VCS, Avaya etc.

    Now, you have to go into Provisioning and turn OFF provisioning if the call control is NOT CUCM or VCS. [See attachment]

   I am not sure when [i.e. which version] this change was done.

View solution in original post

11 REPLIES 11
Highlighted
Cisco Employee

You can use SIP Authentication on SX20 by providing SIP Authentication username and password:

*c xConfiguration SIP Authentication Password: " "
*c xConfiguration SIP Authentication UserName: " "

CUCM/VCS would be able to authenticate this SX20 using those credentials if this is what it expects.

Highlighted

To add to Shashank's comment, if you're registering the endpoint to VCS, suggest you take a look at the VCS Authenticating Devices Deployment Guide (X8.7).

Highlighted

Hi Shashank

thanks for your reply.

Are you suggesting that  configuring username and password will automatically enable authentication?

I have never configured an SX20 and so, pardon my ignorance.

Your reply sounds like a config setting that goes inside a file?

thanks!

Highlighted

What Shashank provided is the API commands if you were to configure the authentication username/password via SSH.  You can also set the username/password via the web interface under Configuration > System Configuration > SIP.

What call control are you using, CUCM or VCS?  If VCS, take a look a the guide I link to in my earlier reply.

Highlighted

Patrick,

thanks for that!.

Seems after entering the username and password and clicking SAVE, the username/password fields go blank again-- perhaps, the SX20 attempts to register but fails.

Forgot to mention that the call control is Avaya SM :(

Anyway to capture SIP messaging or packet capture on the SX20?

Highlighted

Just looked at the logs-- seems the  SX20 is NOT sending the username in the SIP REGISTER message.. pls see the attachment.

Highlighted

You need to look into the xConfiguration file to see if it has saved the username and password for SIP authentication. Please collect the log archive from SX20 for further troubleshooting.

SX20 GUI > Maintenance > System Logs > Download Log Archive.

Highlighted

You can capture logs as well as perform a packet capture from the web interface.  You didn't say what software version you're running, as the menu structure of the web interface has changed recently, but the option is under either Diagnostics > Log Files (TC7 and ealier) or Maintenance > System Logs (CE8 and later).

Highlighted

The version is  TC 7.3.6

I looked at the logs, but couldn't find any anything that indicates why the username was not sent in the SIP REGISTER message. Perhaps, I wasn't looking at the correct log file?

Highlighted

To close the loop on this--

   The following fixed it.

    In the past, you could choose the Call Control from the SIP Settings page, which is a pull down with options including CUCM, VCS, Avaya etc.

    Now, you have to go into Provisioning and turn OFF provisioning if the call control is NOT CUCM or VCS. [See attachment]

   I am not sure when [i.e. which version] this change was done.

View solution in original post

Highlighted

I remember facing something similar to what you describe, where the provisioning mode had to be disabled, don't recall the exact issue though.  Thanks for following up with what caused the issue..