cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
779
Views
0
Helpful
4
Replies
Highlighted
Beginner

Exchange Subscription Error

We are running Cisco Telepresence Manager version 1.6.5.0.  Everything was working fine last week.  Today the Cisco Telepresence Manger shows a red "X" under Microsoft Exchange Web Services Subscription on all rooms.  We have changed nothing in our Telepresence system.  What does this mean?  How do we troubleshoot this error and fix it?  Is it a problem with Telepresence or Exchange?

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Exchange Subscription Error

dtom,

The /active/ctis/adapter/logs/GroupwareAdapter logs contain the communication between CTM and Exchange.

One thing to look for would be:

26 Sept 2012 15:55:27,813 ERROR [GA-EWSInternalEventThreadPool-Thread-1] common.DBHelper (isRoomInADAndUnique:1082) - Room email ID XX_myemail@XX_mydomain.com associated with more than one room

Another thing would be:

26 Sept 2012 00:45:54,392 ERROR [GA-EAInternalEventThreadPool-Thread-1] dbaccess.ExchangeDBHelper (isRoomInADAndUnique:1373) - No Room retrieved from LDAP for email ID XX_myemail@XX_mydomain.com

Two important things to check for errors where the room is sync'd but not subscribed are:

  1. Are the Exchange Room Name fields in each endpoint's CUCM device profile 100% correct?
  2. Is the LDAP configuration on CTM correct?

Double check that the rooms in Active Directory are in the OUs specified under the CTM LDAP configuration in the web GUI. Also make sure each OUs is only listed once, or you may see the "associated with more than one room" error above.

View solution in original post

4 REPLIES 4
Highlighted
Cisco Employee

Exchange Subscription Error

Hi dtom:

Subscription errors in CTM mean that CTM is no longer listening for new events (add/modify/delete) from Exchange on the room calendars; CTM subscribes to certain events on the room calendars, and when they occur, Exchange notifies CTM of those events so CTM can process those changes accordingly.   A quick test:  If you book a new Telepresence meeting, does the meeting appear under the "Scheduled Meetings" page in CTM?  

Have you tried manually resynching any of the rooms to see if the subscription error clears?   If you test the connection under "Microsoft Exchange Web Services" page, does the test connection succeed or fail?

You state nothing changed on the Telepresence side, but did anything happen on the Exchange side (any upgrades, patches, hotfixes, etc.)?  Have you tried simply restarting CTM to see if the errors clear, especially if there was work done on the Exchange side?  Also note that in the past, we've seen Exchange upgrades to a higher version take place without any consideration of CTS-Manager, causing similar issues and errors. 

In any event, there are a number of reasons your subscriptions would show in error, most on the Exchange side.  If none of the above helps, you'd need to set the CTM logging levels to DEBUG and resynch at one or all of the rooms in order for us to see why the subscriptions are failing. 

HTH

Tina

Highlighted
Beginner

Exchange Subscription Error

Thanks for the informatin.  I set all log files to DEBUG and resynch a couple of rooms.  Which log file should I look at to find out why the subscriptions are failing?  What should I look for?

Highlighted
Cisco Employee

Re: Exchange Subscription Error

dtom,

The /active/ctis/adapter/logs/GroupwareAdapter logs contain the communication between CTM and Exchange.

One thing to look for would be:

26 Sept 2012 15:55:27,813 ERROR [GA-EWSInternalEventThreadPool-Thread-1] common.DBHelper (isRoomInADAndUnique:1082) - Room email ID XX_myemail@XX_mydomain.com associated with more than one room

Another thing would be:

26 Sept 2012 00:45:54,392 ERROR [GA-EAInternalEventThreadPool-Thread-1] dbaccess.ExchangeDBHelper (isRoomInADAndUnique:1373) - No Room retrieved from LDAP for email ID XX_myemail@XX_mydomain.com

Two important things to check for errors where the room is sync'd but not subscribed are:

  1. Are the Exchange Room Name fields in each endpoint's CUCM device profile 100% correct?
  2. Is the LDAP configuration on CTM correct?

Double check that the rooms in Active Directory are in the OUs specified under the CTM LDAP configuration in the web GUI. Also make sure each OUs is only listed once, or you may see the "associated with more than one room" error above.

View solution in original post

Highlighted
Beginner

Exchange Subscription Error

Thanks for the information.  The problem was, as suggested above, with the LDAP configuration.  Someone changed the credentials for the LDAP user.  Ran Test Connection and it failed.  Fixed the user credentials and now everything is fine again.