Showing results for 
Search instead for 
Did you mean: 

external audio calls from VCS through CUCM?

I have a Tandberg VCS system I was able to get integrated with CUCM through a SIP trunk and can make OnNet audio calls between video endpoints and IP phones, however, I can't figure out how to make external calls from the video endpoints.  It seems that the trunk is only looking for specific numbers configured on the CUCM and isn't necessarily just routing calls through it.

CUCM version 8 and VCS version X5.2.  The video endpoints are Codec C40.

Any help would be greatly appreciated!

Anthony Thomson

Sounds like you need to create another Search rule on your VCS.  Currently you probably have something that takes (\d{number of digits in internal dial plan})@your.domain and does a regex replace with \1@ip.address.of.CUCM, and routes it to your CUCM SIP zone.

This is your current SIP Trunk: a Search rule in conjuction with a SIP Neighbor Zone.

You need to create another Search rule that does this for outside lines; your pattern string will probably look something like this (9.{10,20})@your.domain, and you'll replace it with the same syntax as the first rule, and point it towards the same CUCM SIP Neighbor zone.  This will capture any numbers, using a 9 prefix, between 11 and 21 digits long (for strange long distance numbers).

Without knowing the exact rules you already have in place (and your call route patterns for CUCM), it's difficult to get exact in the response, but this should help you know where to look.

I had tried that initially but it seems like the search rules only work for numbers on actual devices.  The error I get is below.  Just to test I also created a search rule for the range of numbers used for Parked calls and MeetMe conferences and none of those work, only the rules that reference specific phone extensions, even though the rule is created no differently.  It makes me wonder if it's even possible to route calls "through" CUCM rather than just "onto" it if that makes sense.

    • Name: Sip Trunk to Call Manager
    • Type: Neighbor
    • Protocol: SIP
    • Found: False
    • Reason: Forbidden
    • Gatekeeper (1)
      • Address:
      • Alias (1)
        • Type: H323Id
        • Value: 85#############@

would appear to be your problem.

I think the only time I've ever seen this is when  Call Policy was in place.  Do you have any Call Policy Rules in place on the VCS, or a Call Policy Script?  Check those out.

When you're making these calls, are you selecting Audio/Telephone as your Call Type?  This call property often won't negotiate with SIP, and the call will fail if you're trying to put video through to external number.

This is definitely a solveable problem (i.e. it works for me and other people); raise a ticket with Cisco if you have to.

No, Call Policy is turned off altogether.  I don't see a way to specify type of call as audio, making test calls from a C40 or my Movi client.

On Movi you can't.  As far as I know this won't work.

On a c-series though, when you place your call, the 4th softbutton typically allows you to choose your Call Rate.  At the very bottom of the list is Audio Call.

Found it, thanks.  Same result though. 

Did you ever get this resolved?  I'm having the same issue and can't seem to sort it out. 

no, sorry I didn't.  I've just been calling via phone and parking it, then dialing into that from the VCS.  I'm not really sure how everyone else is pulling it off.

I was able to get mine working partially.  I had an issue with TLS and the search transform from calls to CUCM.  Still have a small issue where some external calls work and some do not, still troubleshooting that issue.

Recognize Your Peers
Content for Community-Ad