cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4839
Views
10
Helpful
8
Replies
Michel Tosu
Beginner

Grey out "Sign in Automatically" Movi/Jabber

Hello,

We are running Cisco Jabber Video on pthe new Provisioning extensions.

We have a prolem with users sharing accounts for Jabber and accidentaly chek the sign in automatically.

I have modified a install file .msi woth ORCA to disable remember password and sign in automatically by default. However a user can still just open the menu and tell the client to login automatically if they want to.

I would like to know if there is any way to gray out this setting? Just like you can grey out the advanced login settings.

1 ACCEPTED SOLUTION

Accepted Solutions
aostense
Beginner

Hi Michel,

I’m happy to announce that Jabber for Telepresence 4.5 will have an option to force not saving the password.

This could be a solution for you, if your user accounts are protected with passwords.

In registry, just simply add this key:

StorePassword = 0 (REG_DWORD in HKEY_LOCAL_MACHINE\Software\Wow6432Node\Cisco\JabberVideo\Forced)

*1 = will force to save passwords

This means if "Sign in automatically" is checked, Jabber Video will not try to sign in but prompt for password when StorePassword is set to false (=0).

Let me know if you want to try the 4.5 version, and see if this could be a workaround for you.

Cheers,

Arne

View solution in original post

8 REPLIES 8
aostense
Beginner

Hi Michel,

This is not possible (and won’t be implemented), but I can try to lead you to a workaround.

As a Jabber tester, I deal with different account all the time (from the same computer). What I do then, is to export the registry settings per account (export after successfully signed-in), and create a batch file (windows) to import this file and start Jabber with these registry configurations. My batch does the following:

     1)      Terminate Jabber

     2)      Import the new registry file for a specified user (or similar)

     3)      Start Jabber

In the registry file here, you can set the registry string “AutoSignIn” to “Off” (in HKEY_CURRENT_USER\Software\Cisco\JabberVideo), and clear the username and password (you can do whatever you want here).

Then delete the “Cisco Jabber for Telepresence” shortcut from Start menu/Desktop, and create a new shortcut (you can name it the same) for the batch-file.

The batch file should look something like this:

@echo off

color 2f

echo Terminating Jabber

TSKILL JabberVideo* /A

echo .

echo ..

echo ...

echo Copy in fresh registry

regedit.exe /s "D:\Files\CiscoMovi.reg"

echo .....

echo Starting Fresh Jabber

start JabberVideo.exe

echo ......

Please let me know if you need more assistance with this, or if you’d like to share other ideas.

Hope this helps,

Arne

Hi Arne,

Thank you for the explanation. I don't think this will be a good solution for me so i will have to rely on our customers' will to follow the instructions provided by us.

How come Cisco choose to not implement this kind of feature? I mean, the ability should be there for people that want to do it. Or is there a good reason?

Hi Michel,

It could be that this feature will come in the Jabber for Telepresence client, but not in any “Movi” clients, as “Movi” is being transitioned to the new Jabber for Telepresence client.

Another solution could be to lock the registry keys to read only mode, so that the system do not allow any changes here. If this is correctly configured, the user can still click the items, but it won’t be saved, as Movi will not be able to update the key as of e.g. ReadOnly permission (Windows configuration – Regedit per key folder).

The downside with this, is that no other keys in that folder can be changed as well, so that the Movi will have to use the same account and settings for all users.

You can also use a 3rd party application to restrict changes to certain registry keys, but I cannot recommend any of these applications right now, as I haven’t played with them myself.

Best regards,

Arne

aostense
Beginner

Hi Michel,

I’m happy to announce that Jabber for Telepresence 4.5 will have an option to force not saving the password.

This could be a solution for you, if your user accounts are protected with passwords.

In registry, just simply add this key:

StorePassword = 0 (REG_DWORD in HKEY_LOCAL_MACHINE\Software\Wow6432Node\Cisco\JabberVideo\Forced)

*1 = will force to save passwords

This means if "Sign in automatically" is checked, Jabber Video will not try to sign in but prompt for password when StorePassword is set to false (=0).

Let me know if you want to try the 4.5 version, and see if this could be a workaround for you.

Cheers,

Arne

View solution in original post

Arne;

I've tried doing as you suggested, and inputting the REG_DWORD of StorePassword setting it equal to 0.  And indeed it does make it such that whenever Jabber is started for the first time since being fully exited, the password isn't remembered.  My question is, is there a way to make it to where the software simply will never remember the password?  I.e., when a user signs out (whether intentionally or by network errors) but doesn't actually exit the software, they will have to type in their password again to log back in?  This is using version 4.5.7.16762.

Thank you!

Jesse Young

Hi Jesse,

Yes, you could also use the other registry keys (from the registry folder [HKEY_CURRENT_USER\Software\Cisco\JabberVideo]) in the /Forced-folder ([HKEY_LOCAL_MACHINE\Software\Wow6432Node\Cisco\JabberVideo\Forced]), e.g.:

DWORD RememberUsername = 0 and/or

DWORD RememberPassword = 0

The first one (RememberUsername) will delete its username when signing out or lost network,

and the second one (RememberPassword) will delete the password, in the scenarios you mentioned.

Hope this helps,

Arne

Arne;

I don't have a \Cisco folder, or obviously anything below it, located in the (HKEY_LOCAL_MACHINE\Software\Wow6432Node) location.  I do however have one in the (HKEY_LOCAL_MACHINE\Software) folder.  In that "Forced" key, I have input the "RememberUsername" and "RememberPassword" DWORDs and set them to 0, but that seems to have no effect.  I can still click "Remember Username" in Jabber, and when I do so, the username/password are both remembered still through a sign-out and through a full exit.

So I tried creating a \Cisco\JabberVideo\Forced directory under Wow6432Node to see if that would help, and it didn't seem to have any effect at all.

Shortened; I'm still experiencing the same problem.  No matter what I have changed in the registry so far, nothing works to keep the password from being remembered through sign-outs and exits.

Thank you!

Hi Jesse,

Do you have any special policies on your computer? E.g. from AD? Do you have administrator rights on the Windows user you are logged in with, when using Jabber Video?

I’ve tried this, and it works perfectly here, however the registry location was already there. Could be you have to restart your PC?

Make sure this is the path you are adding the DWORDs in: [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Cisco\JabberVideo\Forced]

If it still doesn't work you can open a TAC ticket, and I can take a look on WebEx if you’d like. Please send me a private IM in this forum, and I’ll take a look on Monday.

Cheers,

Arne

Create
Recognize Your Peers
Content for Community-Ad