Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Issue Changing DefaultCall Protocol (Codec Seems to Override Choice)

Despite changing the defaultcall protocol to SIP all calls are being placed using H323. The codec(s) is/are capable of making a SIP call. It's a choice in the directory (driven by TMS), but not the default.

At this point, a factory reset isn't feasible. It seems that there is some override in place prohibiting the change from the Codec's webgui from taking effect. It's not just one Codec that this is happening on, it's all the codecs that were "inherited" with pre-existing settings.The behavior is happening on SX20,EX60, and C40 codecs.

Thanks for any help,


Cisco Employee

Hi Kyle,

In case, default call protocol on codec is set to SIP and you are dialing an entry from TMS which has a call type of H323, they it will use H323 as call protocol.

let me know if my assumation  iscorrect regarding your query.

Steve Kapinos
Cisco Employee


Is the behavior only when you call entries from the phonebook?  Or when you manually enter the dial string on the remote or web?

Phonebook entries provided by TMS include a protocol choice (and bandwidth)... which will be the protocol used for the call regardless of endpoint default setting.

If it's a phonebook entry, the protocol choice is made by TMS depending on the type of phonebook it is and how the entry is created. 

A select group of endpoints are not behaving correctly. It's not just the TMS directory, it's any call made from these endpoints. All calls default to H.323, despite the webgui being set to SIP. The entries in TMS are fine. There are both SIP URIs and H323 Ids in TMS. Most of the phonebook sources are endpoint folders.

I believe it's important to note that these endooints are perfectly capable of making a SIP call. To get the system to dial a SIP call  it just needs to be selected when dialing. It's like there's an override in place that is ignoring the setting in the webgui. If such an override is possible, I don't know how to disable it.

Thanks for contributing!

I dont know if this is of any assistance (or a "red herring") - I have come across the situation on newly installed SX20's that the unit would not appear as h.323 enabled (or perhaps SIP).

Login to the codec web interface as an administrator and go to Configuration --> System Configuration --> Network Services.

Scroll through the entries and check to see if h.323 mode and SIP mode are set to ON.  If not then turn them On.

This fixed our issue, but I dont know if it is relevant to the issue you are experiencing.



Well.. isolate the problem.

Ignore phonebooks to start with because there are more variables there... and focus on dialing from the remote control.

If you have the DefaultCall Protocol set to SIP.. and are dialing from the remote (do not use history.. just type the alias in) it should go SIP.

There isn't anything that would override this that I can think of.. only mistakes in reusing other entries/profiles or having the protocols disabled in the endpoint (services).

Establish that first.  Then move onto phonebooks.

If the directory is coming from TMS phonebooks (and not provisioning), recognize TMS customizes the phonebooks sent to each phonebook based on the capabilities TMS believes the system has.  So even tho a contact may have both SIP and H323 entries in it, TMS will only send the contact methods it thinks the device supports.  This can be impacted by the scheduling permissions set for the device in System Navigator, or if TMS does not see the device as having SIP mode on and registered in System Navigator.

Then at the endpoint, if there are multiple contact methods available, it picks one.  How that is handled depends greatly on the endpoint type and software.. it's changed a few times over the years.

Content for Community-Ad

Spotlight Awards 2021