Showing results for 
Search instead for 
Did you mean: 

jabber unable to authenticate when trying to log in from outside the organisation

Dear Team ,

We have a VCS, TMS and VCE expressway. We are able to call outside, but we are unable to receive any call. We can authenticate to jabber from inside, but we are not able to authenticate to jabber from outside.

Please help with a solution.

Jens Didriksen

There are numerous threads covering this, however, I recommend you start with the deployment guide:


Please rate replies and mark question(s) as "answered" if applicable.
Paulo Souza
Rising star

I agree Jens, there are many threads here talking about the same matter.

Check your configuration:

If you want to register your external Jabbers to VCS Expressway, you should setup a configuration like this: VCS registration VCSE setup.png

If you want to register your external jabber to VCS Control through proxied registration in VCSe, you should setup this configuration:

VCS proxied registration setup.png

Save a time to search in the Community and read the topics about Jabber for Telepresence from Internet, there are some important considerations you would like to know.

You may want to start with this thread, there are many explanations about device authentication issues, proxied registration, dial plan considerations and another subjects related to external Jabber:


Paulo Souza

Please rate replies and mark question as "answered" if applicable.

Paulo Souza Was my response helpful? Please rate useful replies and remember to mark any solved questions as "answered".
Zac Colton
Cisco Employee

I would first start with collecting and reviewing debug diagnostic logs taken from the Control and Expressway of a failed attempt. These log will assist in determining the failure point. It would be a bit difficult to assist in your issue without the specifics if your VCS and Provisioning deployment. If you can identify at what point the process is failing, we can assist it providing details of what to look at.

- Zac

Alok Jaiswal
Cisco Employee

Hi Wasim,

Since you can't receive calls from outside plus no registration from outside i would start looking from vcs-exp search history.

if you don't see any call hittings probably then you want to talk to your firewall admin and check with them what ports are opened.

if the ports are opened as per VCS firewall deployment guide then you want to start looking at the configuration.

most of the customers make mistake by not adding the external sip server address in TMS provisioning template. Check that. Also verify the VCS config as mentioned in above posts.

If after everything it doesn't work, better you open tac case with logs from VCS to further investiagte the issue.




Hi Wasim,

in addition to all above posts:

- what version VCSs are you running?

- what version of Jabber client are you using?

- are you VCSs clustered or standalone?

- is your VCSE in DMZ? if yes, can you take your jabber client on VCSE subnet and try to register it from there?

- do you have AD integration?

- are you trying to register your jabber client on VCSC or VCSE?

Inspecting the logs helps to identify the problem.

regards, Ahmad


Dear Team,

I have found the solution with assistance from Cisco Tac. I deleted the "device provisioning key" from options in VCSE and then i was successful in connecting from outside.



Thanks for your feedback. Cisco support is the best.  =)

Take a look at the two tables that I posted above, they show you don't have to enable Provisioning on VCS-E. In a common deployment, you really should not have Provisioning enable on VCS Expressway, only in VCS Control. The guide which Jens has suggested also says the same thing.

I guess if you start your troubleshooting  checking your configuration, you can save time and maybe find a solution faster. But of course, TAC support is always available and ready to assist you anyhow.


Paulo Souza

Please rate replies and mark question as "answered" if applicable.

Paulo Souza Was my response helpful? Please rate useful replies and remember to mark any solved questions as "answered".

Thanks Wasim for posting the solution as it may help others with the similar problem.

regards, Ahmad

Recognize Your Peers
Content for Community-Ad