cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1495
Views
0
Helpful
11
Replies
Highlighted

Lync integration and Presence

Hi,

I have integrated Lync 2010 and VCS X7.03 using the B2BUA. It is all working fine except from Presence. From a Lync client I can’t get any Presence information from a VC client, a Movi client of the MCU Auto Attendant. From the documents I have been reading I think this is possible. I have Presence working fine in Movi and have got the default status to be online.

Any ideas?

Thanks,


Robert

11 REPLIES 11
Rising star

Lync integration and Presence

Hi Robert,

when encountering this problem, are you attempting to subscribe for presence for FindMe accounts which the B2BUA has registered to Lync, or are you subscribing to presence for a domain which is statically routed from Lync towards the VCS?

- Andreas

Lync integration and Presence

Hi Andreas,

Thanks for your reply.

The presence is for B2BUA registered FindMe accounts.  Its all on the same domain.  The FineMe address are in the form of name@domain.com however the end points are using H323 and 164 no.  They are nor in SIP URI format, just a 4 didgit number. 

I read somewhere today that to get presence from an H323 device the H323 Id needs to be in the form of a SIP URI.

The FindMe Id is for an Individual and not a group.

Regards,

Robert

Rising star

Lync integration and Presence

Hi Robert,

yes in order for presence to work, you would have to register your endpoints in URI format, and make sure that the FindMe devices map to these URI's. You can of course register your endpoints with an E164 number in addition to the H323 ID/URI, but the corresponding FindMe device needs to point to the H323 ID/URI, not the E164 number.

Hope this helps,

Andreas

Lync integration and Presence

Hi Andreas,

Thanks- that has confirmed what I found today.  I am no longer using an H323 Id only e164 and system name.  The reason for this is that I have also integrated VCS with Call Manager V7.  When the EP calls into a Call Manger Cisco phone the H323 ID appears on the phone eg Meeting Room 1.  This appears on the lower part of the phone and doesnt not look good.  If I use e164 only then the e164 sppears on the upper part of the cisco phone and looks good as its a 4 difit number just like the rest of the call manager numbers.

Its seems I cant get everything I want with all the level of integration I am doing on this project.

TMSXE V3

Integration with Call Manager

Lync Integration with B2BUA

ISDN GW

Thanks for your help!

Robert

Beginner

Lync integration and Presence

Hi Robert

Could you give me more details about Lync integration with B2BUA ?

I tryied to use B2BUA, but the status shows "SIP: Failed to connect to vcs_ip:65070 : Connect failed"

What I need to do to have B2BUA working ? (I have no FindME feature)

VCS x702 and Lync 2010.

Thank you.

Enthusiast

Re: Lync integration and Presence

Hi Robert

I think you could also use your E.164 number as an URI with the format e.164@domain.tld i.e. 1234@example.com

If you configure your search rules to search with and without the domain with the same priority, always the best match will be picked.

I have also configure some deployments to work with CUCM and we are using a sip trunk from CUCM to VCS. All URIs sent with DN@vcsip will be transformed to DN@domain.tld. With the search rules mentioned above, the E.164 alias will also be found.

Does this solution support all your reqiurements?

Sent from Cisco Technical Support iPhone App

Regards, Paul
Enthusiast

Re: Lync integration and Presence

Hi,

the Lync Server has SIP transport disabled by default. Did you activate SIP TCP transport?

BR Paul

Sent from Cisco Technical Support iPhone App

Regards, Paul
Beginner

Lync integration and Presence

Hi Paul,

Could you explain better this information ? B2BUA use TCP or TLS ? I saw in my vcs that was setup to use TLS/5061

Thanks.

Enthusiast

Lync integration and Presence

Hi Lucio,

depends on what you configure on your B2BUA:

If you configure TLS, it will you use TCP 5061 with encryption. if you configure tcp, it will use TCP port 5060 without encryption.

I just configured Lync Integration once and we had an issue connecting to the Lync Server. Calls from the Lync Server worked fine, but calls to the Lync Server did not. We resolved this by activating TCP Transport on the Lync Server. I do not know exactly where the setting was, because this was done by the Lync admin.

Regards, Paul
Beginner

Lync integration and Presence

Hi Paul,

Ok.. understood.

In my VCS the status of B2BUA is :

Take a look at the OCS/LYNC status...

I dont know what I need to do now... in my Lync server the trust application with VCS was done...

Do you have any idea ?

Thanks.

Lucio

Rising star

Lync integration and Presence

Lucio,

you have already raised these questions in another thread, where I suggested that you keep working with TAC to resolve this issue, since it is likely that logs have to be collected to find the root of the problem.

There is no need for asking the same questions in multiple threads.

Thanks,

Andreas

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards