cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
10534
Views
10
Helpful
16
Replies
Paulo Souza
Rising star

MRA on Expressway - No audio for Jabber calls

Hi folks,

We are deploying a new project with Mobile Remote Access solution in order to allow Jabber client to communicate from internet. These are the version and servers that we have:

CUCM 10.5.1

Presence 10.5.1

Expressway-C and Expressway-E running 8.5.1 (Both were installed with the version 8.2 and were upgraded to the version 8.5.1)

 

This is a simple topology of our environment. Expressway is using two interfaces and its external interface is behind NAT 1 to 1 (with the proper public IP address configured on the IP settings):

 

The issue we facing is very weird. The external Jabber clients are able to register and make calls to the internal devices properly, however, when the call is connected, we have no RTP from both sides.

After performing some debugs we came to conclusion that it might be some king of bug on VCS Expressway. This is what happens:

 

  • The codec negotiation takes places just fine
  • Local endpoint starts RTP transmission to Expressway-C
  • Expressway-C transmits RTP traffic to Expressway-E (we can see it by using tcpdump)
  • Expressway receives the RTP traffic from Expressway-C on its internal interface (we can see the traffic coming in by using tcpdump), however, Expressway-E does not send the RTP traffic to the remote device (when we run a tcpdump on Expressway-E's external interface, we dont see any RTP traffic being sent to the external Jabber client)
  • In addition, the RTP ports negotiated between C and E seem to be ok, I mean, 36000 and 36001. I also tried to manually set them to 2776 and 2777, but the result was the same, only the first call worked after the reboot.

 

The most weird point is that, If I reboot Expressway-E, the first call made after the reboot works just fine (we have RTP in both directions), however, the next call attempts have the same symptom, no RTP at all. Then another reboot makes the first call to work correctly.

 

Has anybody here got a issue like that? 

 

Thanks in advance.

Paulo Souza

 

 

 

 

Paulo Souza Was my response helpful? Please rate useful replies and remember to mark any solved questions as "answered".
16 REPLIES 16
Mohamed Gaffoor
Beginner

Hi Paulo

 

Check your log file on your Expressway C .

It will give you an idea of what you should look at.

Have you added all your CUCM , IM&P servers to your HTTP server allow lists

Thanks for your repply.

Everything was configured correctly on Expressway-C, including the UC servers. I spent hours debugging both Expressway C and E. As far as I can see, there is nothing wrong with call signalling, everything is negotiated just fine, including ports for RTP traffic. The only issue is that Expressway-E receives that RTP traffic from Expressway-C but it does not send it to the remote endpoint on internet. I also made sure that the IP settings are properly configured on Expressway-E (since it is using 2 interfaces).

At this moment I have a TAC case for that issue. I hope to have some feedback from TAC very soon. I will provide a update on this post after we find a solution for this issue.

Paulo Souza

Paulo Souza Was my response helpful? Please rate useful replies and remember to mark any solved questions as "answered".

Hi Paulo

 

Did you find a solution to your issue.

 

Folks, unfortunately, we dont have a solution for this case yet. A TAC case was oppened and the engineer is still trying to find a solution.

Regards,

Paulo Souza

Paulo Souza Was my response helpful? Please rate useful replies and remember to mark any solved questions as "answered".

 

What firewall are you using .

Is it a Fortigate by anychance.

 

 

Yes it's a Fortigate :)

 

I solved the problem.

I put the External Interface of the Expressway-E in NAT Mode and configure the IP Public adress.

After that, RTP is OK trought the the Fortigate.

 

Thanks guys !

 

Ronan

Hi guys,

 

Have someone found a solution for this issue?

I have the same architecture using a fortigate firewall. 

When the call is incoming (from PSTN to jabber) the audio flows .

In the other hand, when i make an external call to PSTN there is no audio (both sides).

Calling internal extensions just work fine.

N.B: I tried disbaling SIP ALG on the fortigate but nothing changed

Regards

If the hostname of the Expressway-E resolves to DMZ or internal IP Address The SIP packets are trying to go to that IP address, and as you know that is not an internet routable addres. In fact that is the Expressway internal addres.  If you are doing it please don’t and point it to the External one and perform a method called NAT reflection on your Firewall.

 

Regards,

 

Thiago Almeida

 

 

Hi Friends,

I have same setup UCM 10.5.2, CUC 10.5.2, CUPS 10.5.2, DC 2012, EXP-C and EXP-E 8.6.1 with Cisco ASA 5505 8.4(3).

Jabber both audio and video call goes perfect for a couple of minutes then no audio (sound like cutting voice comes). if i restart then again works for a some calls.

Can someone help to share list of ports to open in ASA?

Thank you in advance.

Sounds like the firewall ports are not opened correctly on the Expressway-E to the internet.

36000 and 36001 are just for RTP negotiation of which ports to use for the Expressway-E to the public internet.

Expressway-C and Expressway-E should be using the Unified Communications traversal zone, and whichever SIP port you have chosen for that internal DMZ firewall traversal.

 

Double check that the firewall also has from the expressway-e to the internet, and the internet to expressway-e ports 36002-59999 open for the actual RTP and SRTP media to flow.

Hi Paulo,

I have the same problem. 

if I reboot Expressway-E it works fine,but the issue again after a few hours

Did you find a solution?

Hi Paulo,

I have exactly the same problem do you have.

The Epressway-E don't send traffic outside with the external Interface (LAN 1) but receive the traffic from the Expressway-C on the internal Interface (LAN 2).

Did you find a solution ?

 

Regards,

Ronan

Hi Paulo,

Would you like to share outcome of your TAC case on above issue, I'm facing similar issue where everything looks good except no RTP on connected calls.

Pradeep

Tiago Lima
Beginner

Hi Paulo,

I have the same problem. Did you find a solution?

Best Regards,

Tiago Lima

Content for Community-Ad

Spotlight Awards 2021