cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3298
Views
5
Helpful
26
Replies

Qos-Confusion for Video and Best effort traffic

anilkumar.cisco
Level 4
Level 4

Hello Friends,

 

with regard to the Qos.. I am little bit confused with below things..

 

1. what is difference between video media and video signalling..

 

I know how to categarize the voice traffice and media in Qos as follows:

 

ip access-list extended voice-signaling

permit tcp X.X.X.0    0.0.0.255 any range 2000 2002

permit tcp X.X.X.0    0.0.0.255 any eq 5060

permit udp X.X.X.0    0.0.0.255 any eq 5060

 

and to categorize Voice media  we used the below access list.

 

ip access-list extended voice-bearer

permit udp X.X.X.0   0.0.0.255 any range 16384 32767

 

Now , My question,

 

How I will categarize the video media traffic..

is the below class map  is good to use for video media or video signaling 

 

class-map match-all video-traffic

match access-group name voice-bearer

match ip dscp af41

 

Also, my video traffice is of jabber and normal Cisco 9971 IP phone traffice, so it will be categorize as 

a)  Interactive Video (general guideline\standard from Cisco to mark voice with a dscp 46 or ef, Interactive video 34 or af41)

or

b) Streaming Video (Streaming video as dscp 32 or cs4)

so , I am confused with marking of the traffic..

 

and also,

what is difference between marking of data traffice to best effort versus marking it default unconditionally..

 

Kindly advise.

 

Best Regards

Anil Singh 

 

26 Replies 26

I m new to the qos , so little bit confuse..

I have prepared the below sample for Ethernet Module, pls check and advise.

!
class-map match-all Video
match ip dscp af41

class-map match-all Voice
match ip dscp ef

class-map match-any signal
match ip dscp cs3
match ip dscp af31

class-map match-all PHONE1
match input-interface g0/0/0
!
policy-map VOICE-C
class PHONE1
police XXX000 8000 conform-action transmit exceed-action drop
!
policy-map SIGNALLING-C
class PHONE1
police 16000 8000 conform-action transmit exceed-action set-dscp-transmit cs1
!
policy-map VIDEO-C
class PHONE1
police 10000000 8000 conform-action transmit exceed-action set-dscp-transmit cs1
!
!
policy-map SVI
class VOICE
set dscp ef
service-policy VOICE-C
class SIGNALLING
set dscp cs3
service-policy SIGNALLING-C
class VIDEO
set dscp af41
service-policy VIDEO-C
class class-default
set dscp 0
!
int vlan110
service-p in SVI

How about this ?

class-map match-all Video
match ip dscp af41

class-map match-all Voice
match ip dscp ef

class-map match-any signal
match ip dscp cs3
match ip dscp af31

class-map match-all PHONE1 >>>> remove this. You are already classifying traffic above
match input-interface g0/0/0


policy-map SVI
class Voice
police XXX000 8000 conform-action transmit exceed-action drop
set dscp ef
class Signal
police 16000 8000 conform-action transmit exceed-action set-dscp-transmit cs1
set dscp af31
class Video
police 10000000 8000 conform-action transmit exceed-action set-dscp-transmit cs1
set dscp af41
class class-default
set dscp 0

int vlan110
service-p in SVI

A little simplified.

so in above solution their is no need to create IP ACL,

Can we do it in similar way in 3750 switch, I think it will save me from the complex access list etc..
what you say..
but before doing this, I think
enabling of mls qos and
mls qos map cos-dsp 0 8 16 24 34 46 48 56 would be mandatory..

your above suggestion is amazing..

Yes, you can do it on 3750 in a similar way. So there are two things, there is MLS and then there is MQC. The class map/policy map config is part of MQC (modular QoS CLI). It is different than MLS.

MLS is disabled by default. With it disabled, switch does not do any QoS. It treats all traffic the same way.

The command "mls qos map cos-dsp 0 8 16 24 34 46 48 56" is used to change the COS to DSCP mapping. When you set the switchport to trust frame cos, the switch uses this value to map/write the DSCP value through an internal table. IP Phones set a COS value of 5. By default the internal cos to dscp mapping is to set the DSCP to "40" against a cos of 5. You change this to "46" with the above command.

On 3750, you set the switchport to trust the cos mappings with MLS and then use MQC to classify and mark/re-mark traffic as required or optional policing as well.

how I will identify type of voice signal and media packet, we need to create some access list and then apply to the Policy map..

I have created another sample for this requirement, pls suggest if it worked on Ethernet module .



ip access-list extended voice-signaling
permit tcp any any eq 1720
permit tcp any any range 2000 2002
permit tcp any any eq 5060
permit udp any any eq 5060

ip access-list extended voice-bearer_voice
permit udp x.x.x.0 0.0.0.255 any range 16384 32767

ip access-list extended voice-bearer_data
permit udp x.x.x.0 0.0.0.255 any range 16384 32767


class-map match-any voice-bearer
match access-group name voice-bearer_voice
match access-group name voice-bearer_data


class-map match-all video-traffic
match access-group name voice-bearer
match ip dscp af41


class-map match-all voice-signaling
match access-group name voice-signaling



policy-map voice-port-policy
class voice-bearer
police XXX000 8000 exceed-action drop
class voice-signaling
set dscp cs3
police 24000 8000 exceed-action policed-dscp-transmit
class video-traffic
set dscp af41
police 10000000 8000 exceed-action policed-dscp-transmit
class class-default
set dscp default


mls qos map policed-dscp 0 24 34 to 8
int vlan 110
service-policy input voice-port-policy




So there are a couple of ways to match traffic i.e. NBAR, NBAR2, ACL, Medianet etc.

Depending upon how you are deploying it and where you are applying it, you can make the appropriate choice.

the last method shared by you is NBAR..

 

and I want to it in ACL..

Can you cross verify pls.. and how can I used in Ethernet switch module of the Cisco 2900 router pls..

 

So you are basically marking all traffic be it RTP or video as AF41. The problem would be because of -

class voice-bearer
police XXX000 8000 exceed-action drop

class video-traffic
set dscp af41
police 10000000 8000 exceed-action policed-dscp-transmit

Both of those policies are calling the same access-group/traffic. So the IOS will be confused in terms with policer should be applied to this.

You either create an access-list to match video traffic and mark it based upon the jabber/PC IP only or like I said in my post make use of medianet or group QoS policies to have the jabber/PC mark the traffic correctly in the first place.

so you want me use of medianet or group QoS policies to have the jabber/PC mark the traffic correctly in the first place and their is no need to differentiate voice and data vlan , correct, the way I have did..
so below mention technique is media net and group Qos
class-map match-all Video
match ip dscp af41

class-map match-all Voice
match ip dscp ef

class-map match-any signal
match ip dscp cs3
match ip dscp af31

policy-map SVI
class Voice
police XXX000 8000 conform-action transmit exceed-action drop
set dscp ef
class Signal
police 16000 8000 conform-action transmit exceed-action set-dscp-transmit cs1
set dscp af31
class Video
police 10000000 8000 conform-action transmit exceed-action set-dscp-transmit cs1
set dscp af41
class class-default
set dscp 0

int vlan110
service-p in SVI

Pls correct me , If I am wrong.. and it will work on both 3750 and Ether Module switch..

Kindly advise, I will test tomorrow and confirm you.
hope the below command is Ok to test the Qos.
Show policy-map
Show mls qos maps
Show policy-map interface gig 1/0/4

That's correct.

At the end of the day, it's upto you how you want to deploy something. You can mark/provision video traffic correctly with medianet etc, then why not use it.

Also do yourself a favor and get your hands on this book - "End-to-end Qos Network Design" by Christina Hattingh and Tim Szigeti.

I am doing segregation of voice traffic from Data and voice vlan based on access list if you check my configuration carefully and calling in on specific class in order to segregate video and voice traffic.

here video traffic I am considering from Cisco 9971 IP Phone and Jabber PC attached to the phone.

 

ip access-list extended voice-bearer_voice

permit udp X.X.X.0     0.0.0.255 any range 16384 32767

 

ip access-list extended voice-bearer_data

permit udp X.X.64.0     0.0.0.255 any range 16384 32767

 

class-map match-any voice-bearer

match access-group name voice-bearer_voice

match access-group name voice-bearer_data

 

class-map match-all video-traffic

match access-group name voice-bearer

match ip dscp af41

 So I don't think I will get confused here.. because in policy map , I am calling two different type of class..

One with Voice traffic i.e. general voice traffic from Cisco IP Phone attached to the port plus any voice traffic generated from Data vlan i.e. jabber here because by default jabber will not marked it packet from any dspc value thus its voice & Video traffic will be treated as normal voice traffic as per my access list and class map , because its video and voice will fall under my voice bearer class where I am saying match-any.

Now, My confusion is , such type of marking is not possible via the sample configuration which you had shared with me , because it will not understand any voice traffic from data vlan which jabber originate because jabber will not do any marking of packet from the source.

class-map match-all Video
match ip dscp af41

class-map match-all Voice
match ip dscp ef

class-map match-any signal
match ip dscp cs3
match ip dscp af31

if my above understanding is correct, then what would be alternative, where I don't want to any type of changes in Windows PC and CUCM , in order to instruct jabber to send packet with marking.

I want ever thing to be default but should treat jabber atleast voice or if possible jabber video also..

and how the similar thing we can do in Etherswitch module as well..

Hope you understand my requirement.

Hi

 

Jabber application on windows isn't marking the traffic. Now to mark it, you need to make a configuration on your switch based on acls, medianet or using NBAR to recognize the protocol (match application...).

 

Make sure the technology you'll use (NBAR, Medianet) is compatible with your devices platform and IOS version.

 

Here some documentation about medianet that can help:

https://www.cisco.com/c/dam/en_us/solutions/medianet/docs/2_4_deployment_guide.pdf

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/mdata/configuration/15-1sg/mdata-15-1sg-book/metadata-framework.html

 

On your router with etherswitch module, you can also apply policy-map like your doing in your switches.


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: