cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4508
Views
0
Helpful
11
Replies
quake3bak
Beginner

[Question] is it possible direct call number calling to outside?

Hi. I'm a junior telepresence engineer, and I wish to know it is possible to direct calling with only numbering.

I'm using several SX20 and ISDN G/W for connecting to phones.

I set ISDN G/W 3241 coneect to SX20 when rings with certain phone number by 'Dial Plan configure'

So, if I call 1234-1234 from phone, then my SX20 answers it.

but, outbound call is not simple, I don't know how to setting on dial plan.

of course, it's possible to call like this 2932483@10.200.244.200, then the phone starts ringing.

(10.200.244.200 is ISDN G/W IP) (2932483 is PSTN phone in outside)

but call with only number 2932483, it doesn't work.

ISDN G/W is gatekeeper itself with 127.0.0.1 registered and SX20 is H.323 Gatekeeper call mode. so, I think only numbers also possible to call to outside.

I tried and changed several settings, but never worked. Am I wrong? or need more devices like VCS?

I wish someone help me.

thanks for reading. English is not my mother tounge, sorry for inconvenience.

1 ACCEPTED SOLUTION

Accepted Solutions
Patrick Pettit
Cisco Employee

Hi Jinsung.  Good morning.  Sounds like you may need IP to ISDN dial plan rule on ISDN GW.  If you navigate to dial plan rule page and click IP to ISDN, do you have a dial plan rule listed?

If SX20, is registered to internal gatekeeper on ISDN GW, you have to create the IP to ISDN dial plan rule to have the call sent as you suggested.  So if you want to make voice call out your isdn GW, set dial plan rule to show:

The snapshot below is from 2.2 GW which was released a few weeks ago:

70 is the service prefix that I'm using for audio only calls.  Under action, i require a 9 to get outside line so I add it to the string so the user doesn't have to.  70(D*), so when i call 702932483 for audio only call, the 70 is registered to internal GK on ISDN GW and the call is sent to the GW side.  The call is then place out the ISDN network as 92932483. 

Once you've created the dial plan rule, you have to register the 70 to the gatekeeper.  Navigate to the H323 page on ISDN Gateway and input the 70 to the dial plan rule under "Dial Plan Prefixes"

At the bottom you should see the status as this GW is also using its onboard GK as well.

If you navigate to the gatekeeper page, you can then also verify the prefix is registered as well.

Place the call out when SX20 is registered using (Service Prefix)(ISDN Number) like 702932483 and see if the call goes like you would like it to. 

Hope this helps.

VR

Patrick

View solution in original post

11 REPLIES 11
Patrick Pettit
Cisco Employee

Hi Jinsung.  Good morning.  Sounds like you may need IP to ISDN dial plan rule on ISDN GW.  If you navigate to dial plan rule page and click IP to ISDN, do you have a dial plan rule listed?

If SX20, is registered to internal gatekeeper on ISDN GW, you have to create the IP to ISDN dial plan rule to have the call sent as you suggested.  So if you want to make voice call out your isdn GW, set dial plan rule to show:

The snapshot below is from 2.2 GW which was released a few weeks ago:

70 is the service prefix that I'm using for audio only calls.  Under action, i require a 9 to get outside line so I add it to the string so the user doesn't have to.  70(D*), so when i call 702932483 for audio only call, the 70 is registered to internal GK on ISDN GW and the call is sent to the GW side.  The call is then place out the ISDN network as 92932483. 

Once you've created the dial plan rule, you have to register the 70 to the gatekeeper.  Navigate to the H323 page on ISDN Gateway and input the 70 to the dial plan rule under "Dial Plan Prefixes"

At the bottom you should see the status as this GW is also using its onboard GK as well.

If you navigate to the gatekeeper page, you can then also verify the prefix is registered as well.

Place the call out when SX20 is registered using (Service Prefix)(ISDN Number) like 702932483 and see if the call goes like you would like it to. 

Hope this helps.

VR

Patrick

View solution in original post

Rob Huffman
Hall of Fame Community Legend

Hi Patrick,

Very thorough answer my friend! Great work +5

Cheers!

Rob

"Clocks go slow in a place of work
Minutes drag and the hours jerk" 

-The Clash

yesterday, I set the configure as same your advice.

yes, it worked well from inside condec to outside call to mobile phone through the ISDN G/W.

ISDN to IP and IP to ISDN is perfectly well worked. but, when I set like this, the new issue that IP to IP call never worked

has happend.

we have used standalone mode SX20 to connect other users, but for IP to ISDN call we should change the H.323

mode from Direct to Gatekeeper at each SX20. when we call ther others, it looks calling and signalling,

but opposite side never got any signal.

the H.323 gate keeper is ISDN G/W internal gate keeper, and it looks registed well.

we called with IP, ID@IP, E.164 Number but, the opposite side never got any signals.

if we have VCS then we can control by the dial plan menu but, we only have ISDN G/W and MCU 4501.

and I saw the menu IP to ISDN and ISDN to IP in ISDN G/W 3241, but I couldn't see IP to IP or ISDN to ISDN dial plan.

I thought ISDN G/W GateKeeper or MCU GateKeeper can forward the h.323 video call to other connected devices.

am I wrong? and is there any way to be enabled IP to ISDN, IP to IP and ISDN to IP call all?

quake3bak
Beginner

Wow.. Patrick, this answer looks very detail.

I'll test and relpy again. thanks a lot~!

Patrick Pettit
Cisco Employee

Hi Jinsung.  Running a test in my lab GW with GK enabled, seems to work ok.  This GW is very very simple, and is not beefy like VCS to modify things etc.  The internal GK is direct mode only, so when the SX20 sends ARQ to GW, if the system is registered, will send ACF with the signal IP address of the system he is trying to reach.  The calling SX20 will send SETUP direct to the endpoint he is calling.  Once the called system receives the SETUP, he will send ARQ to GW GK and get ACF for the call to continue.  I've tried direct IP address and E164 Alias and all is good.  Can you make sure that the default call is H323 and not SIP or anything?

The GW GK is direct mode GK, so the rest of the communication will occur between both SX20's. 

So i'm wondering is, when you call E164 Alias, the calls fail right?  If you go direct mode and place the call the same way it works over h323? The H323 Log would be pretty simple.  ARQ, ACF to/from calling party and ARQ, ACF from/to called party and thats it. 

Want to explore further on SX20, on SX20, would need to see xcon, xstat and log ctx h323packet debug 9, then log output on to putty session while capturing the output.  Do this on both sides to see whats going. 

VR

Patrick

Hi. Patrick

for the first, thanks for the advice.

the site ISDN G/W 3241 is set GW compatible CISCO G.K mode, and SX20s are set gatekeeper mode.

of course, all settings are H.323 and non-sip mode, and all well registered. defualt call is H.323.

when I call the SX20 to other SX20, I can hear the ringtone and see the calling message on the screen.

and it looks going to infinite calling, even never answer the phone, caller SX20 keeps the status of calling.

I tried watched the log dump from 2 SX20's as followed what you wrote. but It wasn't easy to find out what was wrong

and couldn't find the ARQ... it looks uneasy to newbie

Hi Jinsung.  All good.  Once you get into it, it gets much easier.

So when both SX20's are registered to the ISDN GW now, one SX20 calls another, and the called SX20 rings? This is a good sign.  So the H225 connections seem to be made between the two.  So if boh SX20's which are registered to ISDN GW Gatekeeper, the called SX20 rings now, if you answer on the called SX20 what occurs now? Is the called SX20 set to Auto Answer?

What is the calling SX20 doing?  If the called SX20 answers, and the calling SX20 is still ringing maybe there is a problem with H245 connection being made here. 

If you change to Direct Mode on both SX20's, does the call connect or do the same?

Would love to get a chance to see this in action.  I'm in the US East Coast Time.  Maybe you and I can do a webex and take a look at this together if you want.  Let me know. 

VR

Patrick

Thanks, you are very kind.

our SX20s are non-registered status, these are standalone and direct mode on H323 setting.

in this status, these SX20 has no problem, calling & answer are well worked with autoanswer mode.

but for the changing what you wrote, I set the SX20s to regist the ISDN G/W 3241.

all SX20s looks well registed with ISDN G/W.

and I can hear and see the signalling message and calling sound when one call to other SX20.

but, the opponent SX20 never get ringing, so peaceful status. that is signalling didn't reached the opponent.

however, from PSTN phone calls to SX20 rang well through the ISDN G/W dial plan.

should I suspect the firewall port blocking? Even the SX20 rang when from outside call that means h245 incoming was well.

webex will be nice way to solve my issue, this timezone is GMT +9 (Korea) and between 08:00 ~ 20:00 in anytime is ok.

I'll match your time, just tell me when you can do it. I think Thursday will be good (28.Feb) or tommorrow is also good.

plz send a webex invite mail to jspark@icent.co.kr

HI Jinsung.  Let me see what I can do.  Since I'm in the US on GMT -5, it will have to be really early. Let me see what I can do. 

VR

Patrick

Hi Jinsung.  Haven't heard from you in a while on this.  You make it out to the customer site to see whats going on?

VR

Patrick

that site gave up the Gatekeeper mode, instead of that, they decided using standalone mode.

because it took too much time.

I don't need the test anymore, but sometimes it getting on my nerves ... anyway, your advice was very helpful to me. Thanks a lot.

Content for Community-Ad

Spotlight Awards 2021