cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
241
Views
5
Helpful
6
Replies
dgonzalez1
Beginner

Replacing a touch device on a EX60

Hello, we had to RMA a touch device on a EX60 endpoing. Someone plugged the new one but it didn't go up automatically. Now, I am remotelly connected to the EX60 endpoint and I could see in Configuration --> Peripherals --> Touch screen device that it had configured the old device (based on the mac address). I tried to modify it but was no possible. So I removed that device, but now I don't see how to add the new one. Is there a procedure to add a new touch device? I can't find it in the guides.

 

Thank you,

Diego G.

6 REPLIES 6
Nithin Eluvathingal
VIP Mentor

Try to do a factory rest of  Cisco Telepresence touch screen controller and reconnect with the EX60. Hopefully EX60 will detect the new device automatically

 

You can refer below video for reseting the Touch Controller.

 

https://www.youtube.com/watch?v=9d2D8lox2_c

 

 



Response Signature


The Cisco TelePresence Touch device can be factory reset by pressing the exclamation mark for 10 seconds until it lights up, then press the mute button twice...

Thanks Nithin, we did the factory reset but there was no success.

The touch pannel stucks at this point as before:

 

Touch1.jpg

What software release are you running on the EX - if you have one of the newer hardware versions of the Touch8 it won't work with some of the older TC software versions.   If you are running software release 5.1.4 or later, you shouldn't have an issue - but I'd suggest you re-upgrade the EX to a current software release just to make sure it's on current code, and it is able to provide the correct software to the Touch8.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Hi Wayne, I'm running software release s52000tc6_0_1 on the EX60.

The new touch hardware is this:

New Touch.jpg

 

I tried upgrading the EX60 to s52000tc7_3_17 or s52000tc7_3_20 but it failed with error "/share/installimage/hooks.d/installimage-endeavour failed to run!" As I found, it could be due to HW incompatibility. Previous SW versions are unable to download.

Thanks.

From that photo, you have the wrong part.

The CTS-CTRL-DVC8 is a Touch 8 for a C Series or Profile Series.

The Touch 8 you will need for an EX is a CTS-CTRL-DV8.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

So that is the problem? It makes sense, the original touch device was CTS-CTRL-DV8.

Well, thank you Wayne, I'll try to replace it for the correct one.

Create
Recognize Your Peers
Content for Community-Ad