cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
8451
Views
10
Helpful
21
Replies
Highlighted
Beginner

Shoretel VOIP QOS, auto or policy

We are preparing to evaluate a Shoretel VOIP system. I was wondering about QOS, what is the easiest /best setup is for a none Cisco phone: Auto QOS or policy/profile? I will be using LLDP. The design will use 2960s-48 POE flexstack switches and 4506-e collapsCORE. The user PC will connect to the phone thus the uplink from the phone to the 2960s will have both data and voice.

Thanks

21 REPLIES 21
Highlighted
Beginner

I'm thinking of this on the 2960 .... thoughts ???

lldp run

!

no lldp tlv-select power-management

!

mls qos

!

network-policy profile 91  (default cos and dscp look to match shoretel)

voice vlan 91

voice-signaling vlan 91

!

interface range g0/1-24

switchport access vlan 101

switchport mode access

speed 1000

duplex full

storm-control broadcast level 1.00

storm-control multicast level 1.00

storm-control action trap

priority-queue out

mls qos trust dscp

auto qos voip trust

no cdp enable

network-policy 91

lldp med-tlv-select network-policy

spanning-tree portfast

Highlighted

As long as the Shoretel markings match with the default VoIP audio (ef) and signalling (cs3) - you can set up trust at trunks and pass these markings to routers. Which again if not already having will need QoS to priortise this traffic.

-Terry

Highlighted

Just for reference, I ran:

show lldp neighbors Gi1/0/30 details

on my Cisco 3850 switch connected to a shoreTel phone, the port is a regular access port without any voice port configuration. The phone by default advertises a DSCP marking of 46

Output,....shortened:

ShoreTel IP485g...................

.

.

Network Policy(Voice): VLAN 0, untagged, Layer-2 priority: 0, DSCP: 46

So the marking is taken care of, it's just the policy creation on the router or firewall that's required that gives priority to DSCP:46

Highlighted

I know this is a year old, but hoping to see if I can get some clarification.  I have configured my ShoreTel phones with the following configuration, and it works, but not great, there are intermittent call quality issues, and occasional drops.  My vendor had recommended to not turn on QoS, but I have decided that is crazy talk, so now I am on the internet to find out.  Also the "network guy" is not there anymore.

I have a few questions that I am trying to clarify.  I have taken the above configuration and modified it for my environment for when I turn on QoS.  However, I would like clarification on the trunk port configuration for the ports between switches, and the ports that the ShoreTel switches physically connect to.

Question 1:  Could you tell me how trunk ports between switches are configured?  I configured the ports that connect to other switches the same as my access ports and that seems incorrect, but it did get me up and running.  Here is a sample of what I think I need to add only to trunk ports:

interface GigabitEthernet0/1
description **** Trunk Port ****
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 30    ??? – may not need this
mls qos trust dscp

Question 2:  I was told to configure the ports on my Cisco switch that connects to the ShoreTel switches as access ports.  This seems incorrect.  Here is my configuration for those ports:

 interface GigabitEthernet0/15
 description these ports are for ShoreTel voice equipment
 switchport access vlan 50
 switchport mode access
 no cdp enable
 spanning-tree portfast

 

Lastly, here is the configuration I plan to use for each port.  VLAN30 is data, VLAN50 is voice.    This is basically the same as the one in this thread, so I'm confident(ish) that this is correct.  

interface GigabitEthernet1/0/3
description These ports have BOTH phone + pc
switchport access vlan 30
switchport mode access
switchport voice vlan 50
speed 1000
duplex full
storm-control broadcast level 1.00
storm-control multicast level 1.00
storm-control action trap
priority-queue out
mls qos trust dscp 
auto qos voip trust  
no cdp enable
network-policy 50
lldp med-tlv-select network-policy
spanning-tree portfast

 

I apologize if I should've done this as a new post.

 

Highlighted

You don't need to have a native vlan (untagged) on your trunks.  I don't.  I am not a fan of untagged traffic unless its a necessity.

 

You also don't need the voice vlan command.  Your network policy, depending on how you set it up, actually can take the place of the voice vlan command.  It is correct to set your ports as access ports.  This way they will default to the data vlan and your network policy will dynamically create the trunks when the phones get plugged in.

Can you post your network policy config?

 

Highlighted

jhainy, thank you for the response.  I do not currently have one in place, but here is what I am going to put on.  I also do not have lldp in place yet.  It appears from some Cisco documentation that the voice vlan command is ok to leave if it's already in place, but if it were a new port, then you would rely solely on the network policy.  Here is the change below to add LLDP and to create a network policy

 lldp run
no lldp tlv-select power-management
mls qos
network-policy profile 50       
voice vlan 50 voice-signaling vlan 50 dscp 46

---

Also, I failed to mention, but within ShoreTel it is turned on to send out with DSCP value of 46.

Highlighted

The config looks good.  Once you have everything in place, you should be set.  I have this set up in 3 buildings thus far.  Only 37 buildings to go.  ;-)

Highlighted

Thank you, you have been very helpful.  Do you also mark the ports that you ShoreTel switches plug in (Mostly ShoreTel 220 T1's) in as Access ports or also as trunk ports?  It seemed odd that those would be Access ports, but that is how they are configured as of now. 

Highlighted

The ShoreGear switches themselves have no need to pass 802.1q trunks that I am aware of.  I set the switchports that the ShoreGear switches plug into to access ports and they reside in the voice vlan.  So using your config above, I would just label the ports on your Cisco switch that the shoregear switches plug into with the description command, then set them as access vlan 50 and call it good.

 

Highlighted

Wow.  Based upon your above answer, I actually have my ShoreGear port's configured correctly, and evenly labeled neatly!  Thank you, I am going to get this going soon and will follow up, as this thread was referenced in a ShoreTelsupport.com forum and that is how I found it. 

Highlighted

Glad to see that this was helpful.  You gotta love mixed networks with different vendors.  It does make things interesting.

Highlighted

Also, I kind of thought that I wouldn't need that, so thank you for confirming.

Highlighted

Just to be clear ... ALL trunk traffic has a native vlan. If you dont specify the native VLAN on the trunk interface the default is VLAN 1.

Highlighted

True, but just because it exists..... it doesn't mean you have to use it.  I typically shut vlan 1 down and let it do CDP only.

Content for Community-Ad