cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1739
Views
0
Helpful
7
Replies
afadeyev1
Beginner

SX\Room Kit microphone button on Touch 10

Hi all,

Trying to move away from 3rd party touch panels and use Touch 10 to control all room functions. One of the biggest problem so far is microphone button on Touch 10. Our rooms have recorders and it often used without an active call. The microphone button on Touch 10 is not active without a call, it used to be (I think in in 7.x), but not anymore. I can make mic mute button on the touch panel, but it will be very confusing for the users.

7 REPLIES 7
Nick Halbert-Lillyman
Collaborator

You could possibly use a macro to create a button to disable one or more of the audio inputs, see this thread for some ideas: https://community.cisco.com/t5/telepresence-and-video/ce9-2-1-macro-framework-discussions/td-p/3220093/page/7

 

 

Not sure how disabling audio inputs will help me with microphone button.

It won't help with the button, but if you disable the input/s that the microphones are plugged into, you can mute the unit.

This is not the problem I have. The physical button on the touch panel is not active without the call. if you hang up, there is no red\green indicator and pushing the button does not trigger any events. What I need is the way to catch mic mute button events via feedback and control led via xcommand.

It sounds like you may be running an older CE software release on your device, or that you have changed the microphone mute functionality.

In the later versions there is a command that will make the mic mute work outside of a call as well as in a call.

See the Admin Guide:

Audio Microphones Mute Enabled

Define the microphone mute behavior on the video system.

Requires user role: ADMIN, INTEGRATOR

Default value: True

Value space: True/InCallOnly

True: Muting of audio is always available.

InCallOnly: Muting of audio is only available when the device is in a call. When Idle it is not possible to mute the microphone. This is useful when an external telephone service/ audio system is connected via the codec and is to be available when the codec is not in a call.

From your description of the functionality that you want, you would need to make sure that this is set to True.  

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Hi Wayne, thank you for the suggestion.

Unfortunately, this command does nothing:

xfeedback register /

xconfiguration Audio Microphones Mute Enabled: True

The microphone button on panel and microphones does not light up, no feedback in the console if button is pressed.

I do get feedback if I press Vol+\- buttons.

Tested on SX80 and Room Kit Pro (both at 9.5.2).

 

Weird...I turned off "Mic unmute on disconnect mode" under setup/configuration/conference and the mute button on the touch 10 was working outside of a call until I booted the codec. 

Content for Community-Ad

Spotlight Awards 2021