cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
36192
Views
55
Helpful
28
Replies
Highlighted
Beginner

SX20 as standalone?

Hi,

The customers bought SX20 package with multisite option and they want to work as stand-alone device. What ports do I have to forward to SX20 codec on the firewall. Can they use SIP and H323 for calling? I tried to forward tcp/udp 5060 port to the local codec address, Is it enough for SIP, What about h323? What are the bandwith requirements. Do I need QoS? Thanks

28 REPLIES 28
Highlighted
Beginner

Hi,

For standalone purpose you should use H323.

To use SX20 as standalone make sure to have following configured on SX20 using Web Interface:

Configuration->Advance Configuration->H323->Profile 1->Callsetup Mode: Direct

Configuration->Advance Configuration->H323->Profile 1->PortAllocation : Static

If you have Public IP address than there is no need to configure; however if you have NAT on router, you need to add NAT IP address on following:

Configuration->Advance Configuration->H323->NAT->Address : YOUR_NAT_ADDRESS

Configuration->Advance Configuration->H323->NAT->Mode: Auto

You need to open following port for successfull call

Q.931 call Setup

1720

TCP

H.245(Static)

5555-6555

TCP

Video*/Audio*/Data/FECC

2326-2485

UDP

There is one more configuration which depend on software version, Please let me know software version on your SX20

Regards,

Vivek

Highlighted

I dont know abot the version. Today I will be at customer site. Please if you can provide the additional config for the version you meant.

When you wrote YOUR_NAT_ADDRESS you mean the codec private addresss which or the site publkic address?

I tried at my lab SX20 kit to forward all this ports. When I am called by jabber client I can see the picture (very bad quality) and NO AUDIO receiving? When I try in different direction to call the jabber client I can't do it, only if I forward 5060 port?

Can I use both SIP and h323?

Highlighted

NAT ADDRESS: Will be your public IP address

You can use SIP; however SX20 should be register to Gatekeeper. If you use SIP without resgistration than you could face issue like one way audio/video.

While trying from different direction from Jabber Clien, Jabber Client look into its Gatekeeper, since SX20 is not register call will be rejected.

5060 is only for SIP signalling you need to open port for RTP/RTCP as well. This RTP and RTCP port you can define on SX20 if it has software version TC5.x and later.

Regards,

Vivek

Highlighted

So if I want two SX20 boxes to see each other I need the above port forwarding and configuration in your first post ? And if someone has SIP based video conferencing he can't call me, right? And the customer clients can't use Jabber client to talk with him while SX20 is working as stand-alone?

I saw in the codec RTP ports from 2326 to 2486 not 2485?

The software version is TC 5.1.2

I configured both SX20 boxes- in my office and at customers site like you wrote, forwarded the mentioned ports and H323 parameters. When I try calling there is no incoming video/audio on other side, just that call is established. What are the bandwith requirements?

Why I see the local address and not the public when I am called from other SX20. On both sides I only see like h323:192.168.104.200?

Thanks

Highlighted

hi,

      i have not static public IP and i try set Configuration->Advance Configuration->H323->NAT->Address : xxx.dyndns.org. it not work please help me.

thank you

 

Highlighted

What is this address - xxx.dyndns.org ??? Hostname? FQDN? Domain?

To make NATing to work properly assign a valid static IP in IPv4 or IPv6  address format.

Example IPv4: 123.3.2.1 

This will be the external/global IP address to the router/firewall with NAT support or they call it Public IP address in layman's term.

 

regards,

Acevirgil

 

Highlighted

You can't set a dyndns domain name as the Address.  It needs to be an actual IP address.

If you don't have a static public IP address then you'll need to keep updating the address on your endpoint each time your address changes, or switch to a connection that does provide a static IP address.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Highlighted

Thank you for Consulting.

Highlighted

What is this gatekeeper?

How do you register witha gatekeeper?

Highlighted


@yusufadam wrote:

What is this gatekeeper?

How do you register witha gatekeeper?


https://en.wikipedia.org/wiki/H.323_Gatekeeper

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Highlighted

I have the same problem below I have used all of the same settings you mentioned above. I included my Software version can you provide me with "the one more setting" you mentioned here?

Profile 1 Setting:

Call setup mode :Direct

PortAllocation: Static

Nat address: My nat address is here

H323 Setting:

NAT MODE: AUTO

SOFTWARE VERSION TC7.3.1.8a4696f

Highlighted

Hi Vivek,

 

I'm facing a similar situation. I have two Telepresence units- SX10 and SX20. There is no CUCM or VCS, these are deployed in standalone mode. I have configured H.323 mode: direct and port allocation: static. These devices are in my local LAN now, I have assigned private IPs and these are able to place call to each other.

 

However, I also have WebEx Named Users subscription, with CMR cloud. When I start a meeting from WebEx, I get a video address (e.g. 576381543@asrotex.webex.com), but when I dial to this address from my SX10 or SX20, it fails. I have performed static NAT on the devices, and have also put the inside global IP address in the NAT address filed and have set the mode as "auto".

 

I'm new to collaboration, and this is my first deployment. I was just wondering if you could give some valuable information or suggestion as to what should I do to have these TPs be able to dial and join to my WebEx meeting. Thanks in advance.

 

Rishad

Highlighted

Hi Rishad,

A couple of basic things to check:

Have you configured the DNS settings on the endpoint correctly so they can resolve your webex.com domain to an IP address to make the call?

Have you configured your firewall to allow all the required ports in and out of your network?

Are you able to dial to other Test addresses (ie loopback@rtp.ciscotac.net or 111@bjn.vc)?

Wayne

Wayne
--
Please remember to rate responses and to mark your question as answered if appropriate.
Highlighted

Hi Wayne,

 

Thanks for your reply. In DNS addresses I've put 8.8.8.8, I didn't put a domain name, what should I put?

 

Also, regarding the ports, in this environment, there is no firewall. There is only a Mikrotik router and I've made sure that I'm not blocking anything. I've contacted ISP and they are saying that every port is open from their end too. Perhaps IIG in Bangladesh is blocking ports. Is there a sure fire way to identify exactly where the ports are being blocked?

 

I've dialled the test addresses and failed. Log in SX10 says "network rejected".

 

Please help.

Rishad