cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
17074
Views
0
Helpful
10
Replies
jeffrey-young
Beginner

SX20 Web Access and CLI Access Unavailable

Good afternoon,

I have 2 SX20 units which I am not able to access either by web or by ssh.  These units were changed from DHCP to Static, and are registered in CUCM and fully functioning.  Any thoughts on why this happened and is there anything I can do to restore this access?

Thanks,

Jeff

10 REPLIES 10
Tomonori Taniguchi
Cisco Employee

Are you trying to accessing SX20 from same network subnet or alternatively directly connect your PC?

SX20 support multiple methods for factory reset in worst case scenario.

  • Turn off SX20, then hold the power button for 10 seconds until it starts blinking. Then press the power button twice. SX20 should factory reset and restart automatically.
  • Select “Reset” under More > Administrator Settings from Touch control unit (if you have Touch control with SX20)
  • Using CLI (probably not good method for your case this time): xcommand systemunit factoryreset confirm: yes
  • Remove config.db file (probably not good method for your case this time)

There is no touchpad.  I will have the customer try holding down the power button. 

Thanks for the info!

Do you know what would cause this to happen? 

Does customer configure IP address, subnet and default gateway before change Static from DHCP?

One possibility that customer change IP address assignment to Static before properly configure the static IP address on SX20.

Would be interesting to see system status information on monitor which customer should able to navigate by using remote controller.

Teck Chye Tang
Cisco Employee

Hi,

Might be worth checking the endpoint settings in cucm to make sure that the web and ssh are not disabled.

Sent from Cisco Technical Support iPhone App

Hi Jeff,

Go to CUCM administration Devicd --> Phone -- product specific configuration layout and enable SSH , web .

Kind regards,

Dharmmesh

You can also configure the ash username and password on the same page as well.

Sent from Cisco Technical Support iPhone App

Danny De Ridder
Cisco Employee

Hello,

is the CUCM in the same subnet as the SX20? That could explain why SX20 can reach CUCM but fails to reach hosts on other subnets, e.g. due to incorrect default gateway.

If there are any config issues related to static IP addressing on the SX20 it will be reported in /var/log/console. However,

when you do not have access, that file can currently not be viewed 

Can you check the default gateway? It needs to "sit" on the same subnet as the SX20.

Alternatively, you can enable DHCP again and then the SX20 becomes reachable? If that's the case, run DHCP and check the network settings :

xstatus Network 1 IP

*s Network 1 IPv4 Address: "10.60.142.199"

*s Network 1 IPv4 SubnetMask: "255.255.255.240"

*s Network 1 IPv4 Gateway: "10.60.142.193"

And verify your static address with these settings.

jeffrey-young
Beginner

Thank you all for the information.  The process I followed when changing the IP was:

Web to SX

Change from DHCP to Static

Enter IP/Gateway/Subnet Mask

Save

I will try setting the IP then changing from DHCP to Static.  I have also requested them to attempt to factory reset by:

Turn off SX20, then hold the power button for 10 seconds until it starts  blinking. Then press the power button twice. SX20 should factory reset  and restart automatically.

I did notice that ssh and web access were disabled in CUCM, I attempted to enable this and reset the SX.  The SX came back up sucessfully and registered to CUCM but was still not accessible.  I do have a few EX's on the same system that SSH and web are disabled...and I can still access them via web.

I will let everyone know the results of the reset.

Thank you again for the input, I appreciate it.

Jeff

hi jeffrey-young and hi all

i have a problem when i reset factory SX20. i finished to turn off SX20, then hold the power button for 10 seconds until it starts  blinking. Then press the power button twice. SX20 should factory reset  and restart automatically.

But after that, i can not log in by web access. i can ping to SX20. but i can not log on Web or Telnet and i don't know what user admin and password are.

can you help me for that?

Please help me to check it.

Thanks all

Dear All,

 

can any one tell me how to access into cisco Sx20 codec device.

I have new device in my.

 

Content for Community-Ad

Spotlight Awards 2021