cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3538
Views
30
Helpful
6
Replies
cdillon
Beginner

SX80 Halfwake

I have a SX80 and am using the cameras for other applications, is there a way to disable the codec going into its halfwake so the cameras stay awake.

6 REPLIES 6
Magnus Ohm
Cisco Employee

Hi,

 

Not by configuration but by customising the codec behavior. A macro should do the trick for this. 

 

Ill provide an example for you.

 

/Magnus

Magnus Ohm
Cisco Employee

Hi,

 

Here is a quick example on how to "disable" Halfwake. Whenever the device is about to enter Halfwake it just resets the timer. Copy the below and create a new macro on the device, paste in the code and start it.

 

const xapi = require('xapi');

function resetHalfwake(state) {
  if (state === "Halfwake") xapi.command("Standby ResetHalfwakeTimer", {Delay: '480'});
}

xapi.status.on("Standby State", resetHalfwake);

/Magnus

We have the same problem.

We did try the Macro and it does wake the SX80 back up, but there is a momentary loss of video each time it re-awakes.

I wish there were simply a way to disable half wake. This was not an issue in older revs of software.

 

 

I tried the macro Maguns posted and got the same result with a momentary loss of video but changing the delay value to '400' instead of '480' fixed that issue on the one SX80 I have tested it on.

davisjaron
Beginner

I came across this post when looking for how to disable the halfwake as well.  I wrote a slightly different macro than magnus did because my goal was to put the system straight to sleep rather than sitting in halfwake.

 

Rather than restarting the timer and keeping the system awake, I immediately set the system to go into standby when halfwake hits.  The reaction time is so fast that you don't even seen the halfwake state on the codec.

 

const xapi = require('xapi');

xapi.status.on('Standby State', state => {
  console.log('going to ', state);
    if (state === 'Halfwake') xapi.command('Standby Activate');
});

 

For what you're trying to do, just change "Standby Activate" to "Standby Deactivate" so that it keeps the system awake.  Shown below:

const xapi = require('xapi');

xapi.status.on('Standby State', state => {
  console.log('going to ', state);
    if (state === 'Halfwake') xapi.command('Standby Deactivate');
});

 

I am looking for the opposite.

 

How can I make the system stay in halfwake state forever and not shutdown?

Create
Recognize Your Peers
Content for Community-Ad