cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1248
Views
0
Helpful
9
Replies
Juergen Hornung
Beginner

TC7.01: Webserver down

After upgrading a c40 to 7.01 I can't access the codec via browser anymore, the webserver seems to be down.

Additionally I ran into same error that was reported as "Touchscreen warning message"

9 REPLIES 9
Juergen Hornung
Beginner

Update to this problem: Logged into codec as root, in dmesg file I found the following error:

Starting lighttpd

Duplicate config variable in conditional 0 global: server.bind

2013-12-19 12:00:23: (configfile.c.943) source: ./lighttpd_dynamic_conf.py /config/sysconfig/http /config/certs/apps/https_server.pem /config/certs/ca/default.pem line: 3 pos: 1 parser failed somehow near here: (EOL)

2013-12-19 12:00:23: (configfile.c.943) source: /etc/lighttpd.conf line: 22 pos: 16 parser failed somehow near here: (EOL)

Failed to start the web server.

ERROR: S95lighttpd: Failed

How to fix this?

We have also Issues runing MX200 with 7.01.

MX300, SX20 running fine. After EX90 I had to FactoryReset, now it works.

On the MX200 I see a lot of Rcv-Err on the Switch and the device is nearly unreachable. I figured out, that disabling HTTPS in NetwerkServices menu, fixes the issue for me. After Reenabling HTTPS it errors keeps away.

CCNP R&S

CCNP R&S

It seems that the problem occurs if the system has installed a certificate and is running in https mode only.

To fix this login as root, go to /config/sysconfig/ , edit file http and enable "RUN_HTTP=On"

Strange

Juergen

Nick Halbert-Lillyman
Collaborator

EDIT: Sorry - I meant ot post this in the thread about the touchscreen warning message

amehla
Cisco Employee

Hi Juergen,

on TC 7, try disable and reenable Http to on through ssh or telnet and check

Hi Amit,

I had this issue too with TC7.01 on different C40 codecs.

Codecs are running in strong security mode / http is deactivated and https is activated.

Another manually reboot after update from TC6.3.2 to TC7.01 wasn't successfull.

I activated http via ssh => still no websession via http and https possible.

I rebooted the codec again => http and https websession are possible!

But after that, we faced another issue:

Only logon as admin will be possible at a websession => no login with own created users/account.

I've tried to set a new password on an existing user => authentication still be denied.

I've set the account to Inactive, saved, set back to Active => authentication still be denied.

I've deleted the user account and recreated it (with same old password) => authentication was possible!

Hi Fabian,

Have you registered the codec with any VCS/TMS?

May be the issue here would be the authentication set on that.

It would be registering only with that authentication details.

Try changing this value from VCS/TMS if it is there and then check.

Hi Nikita,

yes, devices are still registered in TMS and VCS, but I don't understand what this should have to do with a local user account on a C40.

The issue is NOT that this system (with TC7.0.1) can not register to TMS or VCS anymore.

The issue is, that we can not logon with any other account than "admin". We have to delete and recreate all the local and personal "video admin" accounts on a C-codec after updating to TC7.0.1, to can logon as before with TC6.3.0.

We never faced such a problem after any update - not with TC3.x, TC4.x, TC5.x or TC6.x

Hi All,

Please note the BUG ID for this issue  CSCum24631

Resolve in next release TC7.1. You can either downgrade to TC6 or use HTTP as a workarround.

Hope this helps!!!!!!!!!!.