cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
6037
Views
20
Helpful
15
Replies
Highlighted
Beginner

Time not correct on SX80 in CUCM

I have an SX80 that is registered in the CUCM. The time will not sync up correctly even though the codec is on the correct time zone. The codec is on Software CE8.0.1, is it possible that this is a bug in the software? I have tried reboots and even a factory reset. Any help would be appreciated.

Thanks,

John

15 REPLIES 15
Highlighted

Is the SX80 using DHCP or have a static IP address?  If static, did you also specify DNS servers for it to use?

I believe when you provision the SX80 with CUCM, it should use the date/time group that you have configured in the device pool that you assigned to the endpoint based on Vivek's posts here: do-tetc-endpoints-registered-cucm-get-their-time.

If verifying the endpoint has DNS configured so it can lookup the NTP address, and if it still doesn't work even registered to CUCM, you can try to manually input an NTP address yourself using the SX80 web interface under Configuration > System Configuration > NetworkServices.

Highlighted

Thanks for the response. The codec is on DHCP. I also checked the device pool in CUCM and the date/time group is on the correct time zone.

What address would I add in the NTP settings?

-John

Highlighted

Does CUCM have the correct NTP servers configured, and assigned to the date/time group used in the device pool?

If the endpoint is using DHCP, the endpoint typically reaches out to the DHCP server to get the time, however I'm not sure in the case of the endpoint being registered to CUCM if that still applies.  If you decide to set it manually, I'd use whatever you have configured for CUCM if the endpoint can reach it.

Highlighted
Beginner

Just in case this was not resolved, can you check your CUCM NTP reference configuration. Your NTP reference should be Unicast. the default of broadcast  will exhibit NTP problems as the VC units do not support it.

CUCM reconfigured the endpoint to AUTO for NTP if you have broadcast NTP reference configured

Highlighted

Hi Garvan, we were having the same issue and setting the NTP reference to Unicast fixed it. Thanks for the post!

Anton

Highlighted

No Problem Anton,

Glad it was of assistance to you

Garvan

Highlighted

Is there any impact or what changes if I changed from direct broadcast to unicast?

Highlighted

Appears to just be the behavior at how endpoints obtain time from the NTP servers, from the CUCM admin guide:

  • Unicast: the phone sends an NTP query packet to that particular NTP server.
  • Directed Broadcast: the phone accesses date/time information from any NTP server but gives the listed NTP servers (1st = primary, 2nd = secondary) priority.

I don't know what the specifics are between the two, just what's noted in the guide.

Highlighted

Hi Anton, when you changed the Phone NTP Reference from Directed Broadcast to Unicast, did you have to restart any services or is it safe to do it during business hours? Does it automatically get applied to all devices or you need to restart devices?

 

Thanks in advance.

Highlighted

You will need to reset (restart) the endpoints so it will pickup and apply the configuration changes made in CUCM.
Highlighted

Hello Garvan, I believe I have a similar issue as my codecs will lose or gain time after a couple of weeks.  Curious to know if I make the change, do I need to reboot/reset all the endpoints in the environment or will they sync up once the change has been made?

 

Thanks!!

Highlighted

Apply configuration does the trick. No need to Reboot or Restart.
Highlighted

 
This solution worked for me too. Thanks.
Highlighted

Thanks Garvan, had the same issue and setting to unicode fixed it for me as well (Cisco DX70 CE8.3.4)