cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2792
Views
0
Helpful
19
Replies
Justin Ferello
Contributor

TMS 14.1 Upgrade Error

Hey all,

I was running TMS 14.1 Beta (Yes I am part of the EFT) with PE and everything was running fine.  I decided to upgrade to TMS v14.1 final today and now TMS will not talk to PE anymore.

I am seeing the following error over and over again in the log-tmsagentproxy.txt file:

2012-12-19 10:13:41,397 [7] WARN  Tandberg.TMS.Framework.Proxy.ReverseProxy - Request failure: http://localhost:8788/dr/groups/id/b8e3d61c-8567-477b-921b-2cbbe8c181a3

2012-12-19 10:13:41,397 [7] ERROR Tandberg.TMS.Framework.Proxy.ReverseProxy -

System.Net.WebException: The remote server returned an error: (503) Server Unavailable.

   at System.Net.HttpWebRequest.GetResponse()

   at Tandberg.TMS.Framework.Proxy.ReverseProxy.ProcessRequest(HttpContext httpContext, Dictionary`2 proxyRequestHeaders)

The TMSAgent service is running & so is the TMSPE service.  Please help

Thanks,

Justin

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ
2 ACCEPTED SOLUTIONS

Accepted Solutions

Ok

I think I got this one. In this case you are seeing this error because of the fact you have named pipes enabled. You need to verify that named pipes are turned off and that TCP ip is enabled (it has to be enabled as a protocol as well (there are two places to enable TCP/IP in the SQL configuration)

The safest way to success is to download the hot fix:

http://www.microsoft.com/en-us/download/details.aspx?id=963

Read about this error here:

Windows Server If using the Named Pipes protocol for SQL database connection, the following security

updates/hotfixes to Windows Server are required :                     

n Windows Server 2003: http://support.microsoft.com/kb/958687

n Windows Server 2008 R2: http://support.microsoft.com/kb/2194664 and

http://support.microsoft.com/kb/2194664

Note that the default connection protocol is TCP/IP. If this protocol is used, no hotfixes are

required.

What I have experienced is that even though you enable TCP/IP only and not using named pipes I have still got this error. Safest is to install the hotfix, reboot and you should have a "voila" moment (hopefully ) hehe.

/Magnus

View solution in original post

Just disable Named Pipes so has to force TCP and I'm also begining to think about the mssql properties file for TMSPE since you mentioned trying to use the TMS Tools...meaning I wonder if the properties file is incorrect in some way. However, the quick and dirty here would be to uninstall and reinstall TMSPE.

As far as webex, getting way to late for me and already on a very long day now so I actually gotta get home else I won't have a home...if you catch my drift

View solution in original post

19 REPLIES 19

What version of Java do you have installed on the server, you can´t run Java 7

Jorgen,

I am running JAVA 6 Update 35

Thanks,

Justin

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ

i ran into the same problem...

i was getting the below error while installing TMSPE 1.5 

Ran into exception when invoking Java code: The driver encountered an unknown error: java.sql.SQLException: Network error IOException: Connection reset error: org.jruby.exceptions.RaiseException: (JDBCError) The driver encountered an unknown error: java.sql.SQLException: Network error IOException: Connection reset

after some troubleshooting i found that, i was using Java latest version which is not supported for this TMSPE.

Jave 7update 51--> is the supported one for this TMSPE.

Justin Ferello
Contributor

All,

Little update, apparently Windows enabled the firewall on its own again!!!  Grrr I hate that.  Anyway I disabled the Windows firewall and rebooted the server.

Now I get the following error in the log-tmsagentproxy.txt file:

2012-12-19 10:58:02,028 [8] ERROR Tandberg.TMS.Framework.Proxy.ReverseProxy -

System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:8788

   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)

   --- End of inner exception stack trace ---

   at System.Net.HttpWebRequest.GetResponse()

   at Tandberg.TMS.Framework.Proxy.ReverseProxy.ProcessRequest(HttpContext httpContext, Dictionary`2 proxyRequestHeaders)

Thanks,

Justin

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ
Magnus Ohm
Cisco Employee

Hi Justin

What is in the tms provisioning extension logs?

:)

Sent from Cisco Technical Support iPhone App

Hey Magnus,

Here is the last entry in the log:

2012-12-19 16:02:02,048 [portal] [Task-Thread-for-com.mchange.v2.async.ThreadPerTaskAsynchronousRunner@163da81] WARN  U: c.m.v.resourcepool.BasicResourcePool - com.mchange.v2.resourcepool.BasicResourcePool$AcquireTask@1ce5a9 -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (5). Last acquisition attempt exception:

java.sql.SQLException: Unable to get information from SQL Server: TMS.

at net.sourceforge.jtds.jdbc.MSSqlServerInfo.(MSSqlServerInfo.java:97) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.ConnectionJDBC2.(ConnectionJDBC2.java:287) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.ConnectionJDBC3.(ConnectionJDBC3.java:50) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:184) ~[jtds-1.2.4.jar:1.2.4]

at com.mchange.v2.c3p0.DriverManagerDataSource.getConnection(DriverManagerDataSource.java:134) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:182) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:171) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool$1PooledConnectionResourcePoolManager.acquireResource(C3P0PooledConnectionPool.java:137) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.resourcepool.BasicResourcePool.doAcquire(BasicResourcePool.java:1014) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.resourcepool.BasicResourcePool.access$800(BasicResourcePool.java:32) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.resourcepool.BasicResourcePool$AcquireTask.run(BasicResourcePool.java:1810) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.async.ThreadPerTaskAsynchronousRunner$TaskThread.run(ThreadPerTaskAsynchronousRunner.java:255) [c3p0-0.9.1.2.jar:0.9.1.2]

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ

Hi Justin,

TMSPE currently only support the following JRE versions (32 bit):

JRE 6 Update 4-33 (32 bit version)

cheers,

Dale

Dale,

It was working fine on 14.1 Beta 1 with no problems, the only thing I did was upgrade to final release.  I will downgrade JAVA though so I can get proper support though.

Thanks,

Justin

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ

You can try that and let me know you get on. I'm seeing another similar issue internally.

Dale

Hi Justin,

In your latest log, it doesn't appear as though the TMSPE app is connecting to the tmspe sql db. What do your TMSPE diags telling you? Have you changed the Cisco TMS Connection Settings under Provisioning Extension Settings? As far as the connection to the tmspe sql db, do you have the SQL Browser service running on you SQL?

Dale

Magnus Ohm
Cisco Employee

I agree with dale here. You rebooted and if the sql browser service is set to manual it wont start after a reboot. Ive seen this several times.

/Manus

Sent from Cisco Technical Support iPhone App

Justin Ferello
Contributor

Ok guys,

Here is what I have done so far.  Note this is an appliance so TMS & SQL are on the same box.

  • Uninstalled JAVA 6 Update 38
  • Rebooted server
  • Installed JAVA 6 Update 33
  • Rebooted server
    • Still get red dots on diags with a warning that is not running
  • I then verified the following:
    • SQL Browser is running & set to auto
    • Windows firewall is turned off
    • No AV software installed
    • Opened TMS tools and re-entered the DB connection info and saved it
      • Re-started PE and waited, still same issue
    • I can connect to SQL DB fine using sa/TANDBERG in MS SQL Studio 2005
    • Verified in SQL config manager that named pipes & TCP were enabled
    • Veried in SQL surface area that named pipes & TCP were enabled

I am still getting the following in the PE log:

2012-12-19 17:43:39,195 [fm] [com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread-#0] WARN  U: c.m.v.resourcepool.BasicResourcePool - com.mchange.v2.resourcepool.BasicResourcePool$AcquireTask@1b10f9a -- Acquisition Attempt Failed!!! Clearing pending acquires. While trying to acquire a needed new resource, we failed to succeed more than the maximum number of allowed acquisition attempts (5). Last acquisition attempt exception:

java.sql.SQLException: Network error IOException: \\TMS\pipe\MSSQL$SQLTMS\sql\query (Windows cannot find the network path. Verify that the network path is correct and the destination computer is not busy or turned off. If Windows still cannot find the network path, contact your network administrator)

at net.sourceforge.jtds.jdbc.ConnectionJDBC2.(ConnectionJDBC2.java:395) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.ConnectionJDBC3.(ConnectionJDBC3.java:50) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:184) ~[jtds-1.2.4.jar:1.2.4]

at com.mchange.v2.c3p0.DriverManagerDataSource.getConnection(DriverManagerDataSource.java:134) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:182) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.c3p0.WrapperConnectionPoolDataSource.getPooledConnection(WrapperConnectionPoolDataSource.java:171) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool$1PooledConnectionResourcePoolManager.acquireResource(C3P0PooledConnectionPool.java:137) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.resourcepool.BasicResourcePool.doAcquire(BasicResourcePool.java:1014) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.resourcepool.BasicResourcePool.access$800(BasicResourcePool.java:32) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.resourcepool.BasicResourcePool$AcquireTask.run(BasicResourcePool.java:1810) ~[c3p0-0.9.1.2.jar:0.9.1.2]

at com.mchange.v2.async.ThreadPoolAsynchronousRunner$PoolThread.run(ThreadPoolAsynchronousRunner.java:547) [c3p0-0.9.1.2.jar:0.9.1.2]

Caused by: java.io.FileNotFoundException: \\TMS\pipe\MSSQL$SQLTMS\sql\query (Windows cannot find the network path. Verify that the network path is correct and the destination computer is not busy or turned off. If Windows still cannot find the network path, contact your network administrator)

at java.io.RandomAccessFile.open(Native Method) ~[na:1.6.0_33]

at java.io.RandomAccessFile.(Unknown Source) ~[na:1.6.0_33]

at java.io.RandomAccessFile.(Unknown Source) ~[na:1.6.0_33]

at net.sourceforge.jtds.jdbc.SharedLocalNamedPipe.(SharedLocalNamedPipe.java:61) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.ConnectionJDBC2.createNamedPipe(ConnectionJDBC2.java:503) ~[jtds-1.2.4.jar:1.2.4]

at net.sourceforge.jtds.jdbc.ConnectionJDBC2.(ConnectionJDBC2.java:320) ~[jtds-1.2.4.jar:1.2.4]

... 10 common frames omitted

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ

Ok

I think I got this one. In this case you are seeing this error because of the fact you have named pipes enabled. You need to verify that named pipes are turned off and that TCP ip is enabled (it has to be enabled as a protocol as well (there are two places to enable TCP/IP in the SQL configuration)

The safest way to success is to download the hot fix:

http://www.microsoft.com/en-us/download/details.aspx?id=963

Read about this error here:

Windows Server If using the Named Pipes protocol for SQL database connection, the following security

updates/hotfixes to Windows Server are required :                     

n Windows Server 2003: http://support.microsoft.com/kb/958687

n Windows Server 2008 R2: http://support.microsoft.com/kb/2194664 and

http://support.microsoft.com/kb/2194664

Note that the default connection protocol is TCP/IP. If this protocol is used, no hotfixes are

required.

What I have experienced is that even though you enable TCP/IP only and not using named pipes I have still got this error. Safest is to install the hotfix, reboot and you should have a "voila" moment (hopefully ) hehe.

/Magnus

View solution in original post

Concur grasshopper and you have gotten very speedy to the respond now And these hotfixes are actually mentioned in our TMSPE Deployment documentation

But interesting he got it after upgrading to TMS 14.1 release (?). Just wonder if Justin first uninstalled TMS and then installed 14.1 release or whether he ran it straight over the top. In any case, I still concur based on what we're seeing above.

And "Note this is an appliance so TMS & SQL are on the same box", recommend consider getting off the TMS Appliance and onto a later OS with increased resource capacity (i.e. note what we say about the TMS Appliance in the Deployment guide as well). And it's been EOSed for over 2+ years now and soon to be EOLed, i.e. next Feb I believe. Therfore, strongly recommend making this jump

Dale

Content for Community-Ad