cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3102
Views
15
Helpful
11
Replies
Highlighted
Beginner

TMS 15.1 upgrade fails with .NET framework not detected

Anyone here that can shed some light on the following issue.

I have a TMS server running version 15.0.1 on a Windows 2012 R2 install. When trying to upgrade it to 15.1 the installer fails claiming that it can´t find the 4.5 .NET Framework.

Since it´s part of the OS and has been a requirement for TMS the last couple of versions I am pretty sure it is in there...

Any tips on how to solve this or is it just another bug?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I get the same error when

I get the same error when trying to do a fresh install of TMS 15.1.  However, I performed a fresh install on two servers weeks before without any issue.  You might be hitting bug CSCux86484, which is the issue I'm facing, as I remember looking through the registry and noticed it said .NET 4.6 was installed.

Determine Which .NET Framework Versions Are Installed

View solution in original post

11 REPLIES 11
Highlighted

I get the same error when

I get the same error when trying to do a fresh install of TMS 15.1.  However, I performed a fresh install on two servers weeks before without any issue.  You might be hitting bug CSCux86484, which is the issue I'm facing, as I remember looking through the registry and noticed it said .NET 4.6 was installed.

Determine Which .NET Framework Versions Are Installed

View solution in original post

Highlighted
Beginner

Of course...

Of course...

It´s running 4.6 but the strange thing is that I believe it has been running that since the server was deployed last summer because it has not been installed as an update (checked installed updates)...

So no easy way of uninstalling it :(

Thanks for the info...

Highlighted

Yeah, I'm running into the

Yeah, I'm running into the same issue, no easy way to uninstall 4.6 as I'm still trying.  Just as you, it isn't listed in the installed updates, but I know it's installed.

Highlighted
Beginner

I am sure you are right.

I am sure you are right. Might just wait for Cisco to catch up instead.

Highlighted

You may be waiting awhile, no

You may be waiting awhile, no telling when the next TMS release may be and if/when it will support .NET 4.6. Not sure if you can see my earlier reply as forums have been acting up and not showing some posts, but I found the update that installed 4.6 on my server and was able to uninstall it. So it's not that hard, just a bit time consuming. 

Highlighted
Beginner

I´m sure it is not that hard

I´m sure it is not that hard to investigate and remove it but as it stands I have 15.0.1 running on it working fine. Upgrade isn´t critical at this point.

But since this is going to become an issue I hope Cisco makes it a top priority since it only seems to affect the installer.

Highlighted

Just to let you know, .NET 4

Just to let you know, .NET 4.6 is a part of a MS Update, just have to scour the Microsoft's website and find all the different possible KB updates that might install it - for me it was KB3102467.

Highlighted

.NET 4.6 is a part of a MS

Duplicate post. 

Highlighted
Beginner

If use .Net 4.7 uninstall the

If use .Net 4.7 uninstall the update KB3186539

Highlighted
Beginner

Re: If use .Net 4.7 uninstall the

Remove 4.7 without installing a different version? 

Highlighted
Beginner

Re: If use .Net 4.7 uninstall the

You need to:

1. Identify the .Net version that you run. Use this link.

2. Identify the KB corresponding to your OS. See example here for 4.7 and 4.7.1

3. Use the Add and Remove software -> Windows component to remove the identified KB. It will downgrade the .Net framework to the previous version.

4. Repeat 1-4 as needed.