Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

TMS agent data replication setup failed to VCS

Hi all,

      I am having serious problems when trying to set provisioning between my VCS and TMS, I have followed all the steps, DNS,NTP,SIP config and etc..Option Keys are installed,  But everytime that I switch on the TMS Agent Data Replication ON I get errors as shown:

10/9/2012 3:32:22 AMEvent Created
10/9/2012 3:32:23 AMEvent executed by CPM_TMS01
10/9/2012 3:32:23 AMTMS agent data replication will be set up for the following system(s): cpm_vcsc01
10/9/2012 3:32:23 AMReading local TMS agent status
10/9/2012 3:32:23 AMReading TMS agent status on 'cpm_vcsc01'
10/9/2012 3:32:23 AMClearing replication setup on 'cpm_vcsc01'
10/9/2012 3:33:07 AMWriting TMS agent settings to 'cpm_vcsc01'
10/9/2012 3:33:09 AMSetting up LDAP data replication between the local TMS agent and the TMS agent on 'cpm_vcsc01'
10/9/2012 3:33:15 AMSetting up LDAP data replication failed
10/9/2012 3:33:15 AMFailed to enable TMS agent data replication for 'cpm_vcsc01'
10/9/2012 3:33:15 AMThe event failed to complete. Details: TMS agent data replication setup failed for the following system(s): cpm_vcsc01

When i run the diagnostics i get this:

Error details from TMS Agent:

User  wasn't replicated to "cpm_vcsc01" within the timeout of 60 seconds  (UserId=uid=4e021a29-ddb8-4977-ae45-9d63cd765e87, ou=users).

Error details from TMS Agent:

System IP ( or host name ( not found in list of replicating agents.

I tried everything that could imagine to get it fixed, but the problem still persists!

TMS is 13.2.1

VCS is 6.0

Cisco Employee


If you are setting up provisioning from scratch and you did no thave it running before I recommend that you setup TMS Provisioning Extension since that is the new solution going forward.

As there could be many reasons for the replication setup to fail take a look at this document and see if you can get some hints on how to resolve the issue.

Here is the TMSPE deployment guide

No replication is needed to be setup, no additional licenses is needed either except that your VCS needs to be on at least X7.1 which requires the X7.x release key.


Content for Community-Ad