Showing results for 
Search instead for 
Did you mean: 
Robert McAffery

TMS and Polycom HDX Phonebook issue


I have just deployed TMS 13.2.2 and have added some Polycom HDX's to TMS.  The HDX's are in TMS ok however, when I apply the phonebook from TMS to the HDX it can not be seem on the HDX.  The HDX has TMS listed as its management server and it has the correct SNMP setting.  In Global Directories it has the IP address of the TMS server - but I cant see the phonebook.

Any ideas?



Magnus Ohm
Cisco Employee

Hi, check that port 3601 is open towards the tms server.

Check that the plcmdirectories services are running.

Make sure the pwx folder (like the public folder) in IIS has anonymous authentication enabled with a valid anonymous account. Hope this helps. If you fo a wireshark on the tms server while setting up the phonebooks you should get a better idea of what is wrong.


Sent from Cisco Technical Support iPhone App

Hello Robert

Just adding to what Magnus said you can check plcmdir.txt (from TMS logs). You should have some errors there.



Hi Magnus. I have the same issue.

The Polycom endpoint is added to TMS, but I am not able to connect to the directory service on the tms from the endpoint.

Plcmdirectories services is running. Port 3601 is open, anonymous authentication is also enabled, but I can't quite understand the thing you said about the valid anonymous account. Can you explain this a little bit more? How do i enable this?

Furthermore, the plcmdir.txt Rafal was talking about is empty by the way.

What I also was wondering: In the polycom I have the option to put in a password for the directory service connection. Do you know to which password in Tms it refers to?

Hope you can help me.

Kind regards.


Hello Edwin

There is no need for user name password.

You should add TMS ip, tick new and tick register.

After that please click update several times and you should get green tick next to register



Robert, Thank you for the additional info.

Unfortunately I still don't have it running.

The anonymous access is configured. I can access the default webpage by browsing to the ip-address of TMS from anywhere, but not the /pwx page.

Browsing to it locally works just fine. (through the browser on the TMS server)

Does anyone have any other suggestions? Could it be dns related?



Hi Edwin,

Is the Polycom EP on a differnet subnet than the TMS server? does the TMS server have its firewall on and are the posrt 3601 TCP open in BOTH directions? You could try totally switching the firewall off or allow everything in both directions frmo the IP address of the Polycom EP.  This would rule in or out the firewall config.



Hi Edwin,

I got this working.  I think the default Windows Sever firewall was switched on and blocking ports.  I made a rule that allowed the ports needed for the directory stuff.  I also checked to see if there was anonymous access for the Polcyom Phonebook directory.  This is a Windows/IIS task.  You need to check if there is anonymous read access to these files and folders.  To check, you can open from a web browser and open the files.  You should get something on the browser that is not an error. 

For the username and password on the EP you can leave this blank.  I alwats tick the register box.

Hope this help,


Thanks Magnus.

A +5 to that post.  We had the same issue here the other week - opening up port 3601 was the solution to the problem.  We had all the normal Cisco/Tandberg ports available, but didn't realise that the Polycom HDX was differnt in regard to the phonebook and assumed it worked on ports 80/443 as teh rest of our "normal" devices do.



Please remember to rate responses and to mark your question as answered if appropriate.

Please remember to rate responses and to mark your question as answered if appropriate.
Robert McAffery

Thanks Mahnus and Rafal.  This is very helpful.  I wil use this today.  Thanks for the posts! :-)

Hi all,

Thanks for all the help. I forgot to mention it's working for me as well.

There was also an issue with "browsing" not being enable on the pwx page :-s

Turned it on, and it worked.



Content for Community-Ad

Spotlight Awards 2021

This widget could not be displayed.