cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

541
Views
5
Helpful
18
Replies

TMS,VCS and Jabbber " unable to connect to the TMS agent on this VCS "

Dears,

 

We have Cisco TMS,VCSc and jabber deployment , we did the provisioning before between the VCSc and TMS and jabber was working fine , however after upgrading the VCSc from v7.2 to version 8.2 jabber stopped working and i can't login anymore and when i go to the TMS and connect to the VCS i get "unable to connect to the TMS agent on this VCS"  please advise 

1 ACCEPTED SOLUTION

Accepted Solutions

What version of TMS are you

What version of TMS are you using?  And are you using TMS Provisioning Extension (TMSPE)?

It sounds like you're using TMS Agent Legacy, which was supported in VCS X7.2, and since been removed starting in X8.1.  You'll need to migrate to TMSPE, and most likely upgrade your TMS server as well if you don't meet the minimum versions.

Cisco TMSPE Deployment Guide 1.0

Here is the deployment guide for TMSPE 1.0, there are newer versions, but 1.0 is the one you want to migrate from TMS Agent Legacy.  Once installed and migrated your data, you can then go to the most recent version, which is 1.4 (see below).

Cisco TMSPE with VCS Deployment Guide 1.4

View solution in original post

18 REPLIES 18

What version of TMS are you

What version of TMS are you using?  And are you using TMS Provisioning Extension (TMSPE)?

It sounds like you're using TMS Agent Legacy, which was supported in VCS X7.2, and since been removed starting in X8.1.  You'll need to migrate to TMSPE, and most likely upgrade your TMS server as well if you don't meet the minimum versions.

Cisco TMSPE Deployment Guide 1.0

Here is the deployment guide for TMSPE 1.0, there are newer versions, but 1.0 is the one you want to migrate from TMS Agent Legacy.  Once installed and migrated your data, you can then go to the most recent version, which is 1.4 (see below).

Cisco TMSPE with VCS Deployment Guide 1.4

View solution in original post

Dear Patric,Thank you very

Dear Patric,

Thank you very much for your answer , would downgrading the VCSc to version 7.2 solve the problem ? 

Yes, it should work. However

Yes, it should work. However I suggest you migrate to TMSPE, it's better than the older provisioning method. Once you migrate you can also upgrade your TMS and VCS, because the newer versions don't support the legacy provisioning mode.

Hi Patrick,i'd like to

Hi Patrick,

i'd like to migrate to version 8.2 too but the problem that the vcs-e is 7.2 so i think its easier to downgrade the VCSc only instead of upgrading both TMS and VCS-E , however does upgrading both TMS and VCS-E is free if they are under smartnet ?? would upgrading or downgrading let lose the configurations or the option keys ?

If you have active service

If you have active service contracts, you can upgrade TMS and VCS, just need release keys. 

You never said if you were for sure running TMS Agent Legacy or TMSPE. If you plan to upgrade TMS and VCS to anything later than 14.x and X8.x respectively, you'll have to migrate to TMSPE. See the documents I linked to earlier. 

Dear Patrick, The exisiting

Dear Patrick,

 

The exisiting units are TMS 13.1.2   ,,, vcsx8.2

 

the TMS was working when the VCS was x7.2 once we upgraded the vcs we got "unable to connect to the TMS agent on this VCS"  error please advise on the following :

1- do u think the versions are not compatible ?

2-i tried to install version 14.6 but it asks for SQL upgrade , the current SQL is 2008 , what is the recommended SQL ? and if i installed a new SQL would i loose the tmsng database 

3-if the upgrade was done on the TMS should we migrate to the new provisioning or the old steps will work ?

Collaborator

"the TMS was working when the

"the TMS was working when the VCS was x7.2 once we upgraded the vcs we got "unable to connect to the TMS agent on this VCS"  error please advise on the following :"

"1- do u think the versions are not compatible?"

You need to migrate to TMSPE as this is the only one which will work with X8.1 and onwards - so yes, your current versions are not compatible. (Read Patricks reply which you marked as "correct answer" again.)

/jens

Please rate replies and mark question(s) as "answered" if applicable.

Please rate replies and mark question(s) as "answered" if applicable.
Highlighted

Dear Patrick, I have upgraded

Dear Patrick,

 

I have upgraded the TMS to version 13.2.2 and migrated to TMSPE1.0 , now im trying to upgrade to version 14.6 but during the installation i reach to a window saying " configuring the TMS database" and its taking a lot of time , and i guess the old ISS is deleted and i can't access the TMS 13.2.2 ,please advise

Yes, it will take a period of

Yes, it will take a period of time, as the installation will delete the old version of TMS and upgrade the database.  Depending on how large the database is, it might take a while.

Dear Patrick,Thank you very

Dear Patrick,

Thank you very much for your usual support , but still i have few questions , now before i do the installation again for TMS 14.6 , im finding few errors in TMS 13.2 such as when i get to provisioning>users i see some errors on the right corner , and according to the deployment guide the sql connection is causing the errors , however should i solve the errors first , or should i ignore them and do the upgrade ? 

Can you tell me what the

Can you tell me what the errors are and/or provide screenshots, also where in the deployment guide are you referencing the errors?

Hi Patrick , I get

Hi Patrick ,

 

I get "connecting to User Repository"   and all the provisioning lights are not green,,, is it oky to ignore them and upgrade to 14.6 or we should solve them ,, if so how can i do that ?

It would be best to get TMS

It would be best to get TMS and TMSPE up and running first before you upgrade any further.

dear Patric,it looks like we

dear Patric,

it looks like we are having a trouble with the sql data base , so we have decided to do a fresh installation for the server and the sql , would i lose the serial number if we installed the tms on a new machine ?

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here