cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1485
Views
10
Helpful
7
Replies
duyvinhdao
Beginner

TMSPE Migration failed with "Access Deny"

Hi.  Im running into problem using the TMSPE migration tool.  Im receiving "Unable to export data from OpenDS"

Here is what i see from the command windows:

        at java.lang.Thread.run(Unknown Source) [na:1.7.0_06]
Caused by: com.cisco.ts.mgmt.migrationtool.exception.LdifExportFailedException:
Ldif export failed: Access is denied.
Access is denied.
Access is denied.
Access is denied.
Access is denied.
Access is denied.
Access is denied.
Access is denied.

        at com.cisco.ts.mgmt.migrationtool.ldif.LdifExporterImpl$1.call(LdifExpo
rterImpl.java:121) ~[migration-tool-1.0.159.jar:na]
        at com.cisco.ts.mgmt.migrationtool.ldif.LdifExporterImpl$1.call(LdifExpo
rterImpl.java:93) ~[migration-tool-1.0.159.jar:na]
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source) [na:1.7
.0_06]
        at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.7.0_06]
        ... 3 common frames omitted
30 Aug 2012 13:32:29 ERROR - Migration failed

The documentation says when encounter this error msg, do the following:

Corrective actions:

1. Check the log for details

2. Verify that sufficient memory for OpenDS exportconnection settings.

3. Check that connection details for Cisco TMS Agent Legacy in Cisco TMS are correct.

4. Re-run the migration tool.

My question is  What does it mean in corrective actions number 2 and 3? 
I have re-run the migration tool several times without any luck.  also, the TMS Agent Legacy is working fine. 

Thank you in advance for any advise.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Magnus Ohm
Cisco Employee

Hi

Open commandline as administrator (like run as administrator).

CD to the migration tool directory. C:\program files\tandberg\tms\provisioning extension\migration tool

Run the migration tool.bat from the cmd as admin. Should resolve the problem.

/Magnus

Sent from Cisco Technical Support iPhone App

View solution in original post

Hi

Great that it resolved the problem, but unfortunate that you are encountering a new issue. You do not explain very detailed how you setup the VCS to communicate with the TMS. For example, did you enable TLS? If you enabled TLS, are you sure the TMS is listening on port 443 (HTTPS enabled)?

If you have it to TLS try to set it to Off then it will use HTTP just to see if it works. Make sure the password and username is 100% correct. Use domain\username if its an AD account and make sure its Site Admin in TMS.

Make sure you do not configure this on the VCS webinterface but from the TMS. Do you see this IOError on all of the services you have enabled?

I assume all licenses etc are in order and that there is nothing in between the VCS and TMS that might block port 443 or 80?

Is there any other details you want to share that I have missed or you wondering if you have configured correctly? Did you follow the guide?

Unfortunately I don't have a TMSPE setup here at the moment so i'm just providing suggestions on best effort here.

/Magnus

View solution in original post

7 REPLIES 7
daleritc
Cisco Employee

Number 2 means that you need sufficient memory on your server to ensure the migration can occur appropriately since both Legacy TMS Agent and TMSPE are running at the same time during the migration of the data. The optimal memory requirements, etc can be found in the TMSPE Deployment Guide.

However, I don't believe your problem is memory...although double check...what I believe the problem here is that TMSPE cannot access the Legacy TMS Agent db (aka OpenDS) so has to migrate the data from OpenDS to the TMSPE SQL db (aka tmspe db). So number 3 is meaning with what password can you access the OpenDS Control Panel with? Meaning this is the same password that TMSPE is or should be using when accessing the OpenDS db? Have you changed the Legacy TMS Agent configuration and replication passwords, i.e. other than the default (TANDBERG)? Can you enter the OpenDS db via the OpenDS Control Panel?

I am having a similar issue with finally migrating a customer from 13.2.1 with trying to migrate the provisioning from the old to the tmspe. 

Getting an error that the ldif fails. 

ERROR - Export ldif error output:
ERROR - Ldif export failed

Can you point me to a doc on how to possibly use the OpenDS Control Panel?

Thank you.

Magnus Ohm
Cisco Employee

Hi

Open commandline as administrator (like run as administrator).

CD to the migration tool directory. C:\program files\tandberg\tms\provisioning extension\migration tool

Run the migration tool.bat from the cmd as admin. Should resolve the problem.

/Magnus

Sent from Cisco Technical Support iPhone App

duyvinhdao
Beginner

That did the trick.  Thank you Magnus


Now, I'm running into a different problem when trying to sync TMS up with the VCS.  Im getting

Summary:Failed: IOError
Response:(111) : Connection refused
Time of Last Update:
Time of Last Poll:
Time of Next Poll:8/30/2012 1:28:22 PM

Anything would be appreciated.
Note:  Im using an account that has Admin access to TMS and a in the server admin group to sync with VCS.  

Hi

Great that it resolved the problem, but unfortunate that you are encountering a new issue. You do not explain very detailed how you setup the VCS to communicate with the TMS. For example, did you enable TLS? If you enabled TLS, are you sure the TMS is listening on port 443 (HTTPS enabled)?

If you have it to TLS try to set it to Off then it will use HTTP just to see if it works. Make sure the password and username is 100% correct. Use domain\username if its an AD account and make sure its Site Admin in TMS.

Make sure you do not configure this on the VCS webinterface but from the TMS. Do you see this IOError on all of the services you have enabled?

I assume all licenses etc are in order and that there is nothing in between the VCS and TMS that might block port 443 or 80?

Is there any other details you want to share that I have missed or you wondering if you have configured correctly? Did you follow the guide?

Unfortunately I don't have a TMSPE setup here at the moment so i'm just providing suggestions on best effort here.

/Magnus

Once again, you came through.  You pointed me to the right direction and able to fix the problem.  Thanks again Magnus

Hi

Glad I could help!

/Magnus

Create
Recognize Your Peers
Content for Community-Ad