cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
482
Views
0
Helpful
4
Replies
maciej_wilk
Beginner

TMSPE with TLS enabled issue

Hi All,

When setting the Server Address in TMS Connection Settings under Provisioning Tab for VCS Control as the FQDN, the status for all services is OK but I receive the following error:

Certificate verification is enabled and certificate hostname checking is enabled. All is good besides the error.

When I change the FQDN to the IP address of TMS as suggested by the error, the services fail with the following error:

So I have to disable certificate hostname checking for the services to report OK status.

Is this a bug or am I missing something?

Kind regards

Maciek

1 ACCEPTED SOLUTION

Accepted Solutions

Hi

Check in the TMS Admin tools --> Configuration --> Network settings

IS the FQDN of the TMS typed in there? If not, try to type it in and setup hostname + hostname check as you did before. Does the error still stick?

I have not tested it but I have seen this before when the management address does not match the address is in the TMS Network settings.

/Magnus.

View solution in original post

4 REPLIES 4
Justin Ferello
Contributor

Maciek,

If you want to enable hostname verification then you need to have the following items in place:
1) A valid DNS entry for the TMS & VCS
2) A valid 3rd party signed certificate on the TMS & VCS
3) And if you happen to choose a certificate signer that is not listed in the VCS or TMS default CA list, then you will need to upload/import the correct CA Root and or Intermediate certificates to both systems.

Thanks,
Justin

Sent from Cisco Technical Support iPad App

Thank you,
Justin Ferello
Technical Support Specialist, ScanSource KBZ

Hi Justin,

Thanks for the answer.

1. Both TMS & VCS have valid entries in my DNS.

2. Certificates with FQDNs of VCS and TMS as CN are imported from a Microsoft CA.

3. Trusted root CAs are ok on both systems.

And it works as expected when the server name is set to the FQDN of TMS.

But then I get the error that it should be an IP address..

Kind regards

Maciek

Hi

Check in the TMS Admin tools --> Configuration --> Network settings

IS the FQDN of the TMS typed in there? If not, try to type it in and setup hostname + hostname check as you did before. Does the error still stick?

I have not tested it but I have seen this before when the management address does not match the address is in the TMS Network settings.

/Magnus.

View solution in original post

Percect, this resolved the issue

Thank you!

Kind regards

Maciek

Content for Community-Ad

Spotlight Awards 2021