cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1504
Views
0
Helpful
1
Replies
Bar1s
Beginner

TP,Cube to Cube video call

Hi everyone,

I need some advice,

I have two side;

First; CCM 6.1.5+CTMS(Cisco TelePresence Multipoint Switch)+Telepresence 1000+Cisco 3845(c3845-adventerprisek9_ivs-mz.124-22.YB8.bin).

Second; CCM 8.5+CTMS+TP 1000+3945 (3900-universalk9-mz.SPA.150-1.M4.bin).

I trying video call over cube to cube. I did some configs but will try tomorrow J.

I need some anwers:

  •        3845 router doesnt have pdvm, pdvm that mandatory for cube calling ?
  •        3845 router is there need license for cube?

Here is the configs;

3945 router config------------------------------------------------------

voice rtp send-recv

!

voice service voip

allow-connections sip to sip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  bind control source-interface GigabitEthernet0/0.21

  bind media source-interface GigabitEthernet0/0.21

  early-offer forced

!

voice class codec 1

codec preference 1 aacld profile 1

video codec h264 profile 2

!

!

interface GigabitEthernet0/0.21

encapsulation dot1Q 21

ip address CUBE3945 I_WANIP

!

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

!

!

!

!

codec profile 1 aacld

fmtp "fmtp:96 profile-level-id=16;streamtype=5;mode=AAChbr;config=B98C00;sizeLength=13;indexLength=3;indexDeltaLength=3;constantDuration=480"

!

!

codec profile 2 h264

fmtp "fmtp:112 profile-level-id=4D0028;sprop-parametersets=R00AKAmWUgDwBDyA,SGE7jyA=;packetization-mode=1"

!

!

dial-peer voice 1 voip

description to_CCM85

service session

rtp payload-type cisco-codec-fax-ind 110

rtp payload-type cisco-codec-aacld 96

rtp payload-type cisco-codec-video-h264 112

session protocol sipv2

session target ipv4: CCM85_IP

incoming called-number 10........

voice-class codec 1

dtmf-relay rtp-nte

!

dial-peer voice 2 voip

description to_CCM615

service session

destination-pattern 7.......

rtp payload-type cisco-codec-fax-ind 110

rtp payload-type cisco-codec-aacld 96

rtp payload-type cisco-codec-video-h264 112

session protocol sipv2

session target ipv4: 3845cube_wanIp

voice-class codec 1

dtmf-relay rtp-nte

!

3845 router config------------------------------------------------------

voice service voip

media flow-around

allow-connections sip to sip

sip

  bind control source-interface GigabitEthernet0/1.21

  bind media source-interface GigabitEthernet0/1.21

  early-offer forced

!

!

!

voice class codec 1

codec preference 1 aacld profile 1

video codec h264 profile 2

!

!

!

interface GigabitEthernet0/1.21

encapsulation dot1Q 21

ip address CM6_wanIp

!

codec profile 1 aacld

fmtp "fmtp:96 profile-level-id=16;streamtype=5;mode=AAChbr;config=B98C00;sizeLength=13;indexLength=3;indexDeltaLength=3;constantDuration=480"

!

codec profile 2 h264

fmtp "fmtp:112 profile-level-id=4D0028;sprop-parametersets=R00AKAmWUgDwBDyA,SGE7jyA=;packetization-mode=1"

!

!

!

dial-peer voice 1 voip

description to_CM8

service session

destination-pattern 10........

rtp payload-type cisco-codec-fax-ind 110

rtp payload-type cisco-codec-aacld 96

rtp payload-type cisco-codec-video-h264 112

voice-class codec 1

session protocol sipv2

session target ipv4:3945_wanIp

dtmf-relay rtp-nte

!

dial-peer voice 2 voip

description to_CM6

service session

rtp payload-type cisco-codec-fax-ind 110

rtp payload-type cisco-codec-aacld 96

rtp payload-type cisco-codec-video-h264 112

voice-class codec 1

session protocol sipv2

session target ipv4:CM6_IP

incoming called-number 7.......

dtmf-relay rtp-nte

!

Best, thanks..

1 ACCEPTED SOLUTION

Accepted Solutions
Paul Anholt
Cisco Employee

Hi Barris,

Try adding the following configuration:

voice service voip
rtp-ssrc multiplex
address-hiding
allow-connections sip to sip
sip
  midcall-signaling passthru
  session transport tcp
  header-passing error-passthru
  pass-thru content sdp
  rel1xx disable

Thanks,

Paul

View solution in original post

1 REPLY 1
Paul Anholt
Cisco Employee

Hi Barris,

Try adding the following configuration:

voice service voip
rtp-ssrc multiplex
address-hiding
allow-connections sip to sip
sip
  midcall-signaling passthru
  session transport tcp
  header-passing error-passthru
  pass-thru content sdp
  rel1xx disable

Thanks,

Paul

Create
Recognize Your Peers
Content for Community-Ad